BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-14-2010, 07:03 PM   #1 (permalink)
Thumbs Must Hurt
 
dawiz's Avatar
 
Join Date: Apr 2009
Model: 9550
OS: 5.0.0.713
PIN: 31394XXX
Carrier: Verizon
Posts: 102
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Dead Screen

Please Login to Remove!

There are two non-responsive lines on my phone. In landscape orientation, all buttons in the W line and and the O line are dead. Has anyone else experience this? What is the cause?
__________________
da infamous wiz of....
Offline  
Old 01-14-2010, 07:18 PM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,036
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

Has it gotten wet?

Did you drop it?

What have you done to resolve?
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 01-14-2010, 07:28 PM   #3 (permalink)
Thumbs Must Hurt
 
dawiz's Avatar
 
Join Date: Apr 2009
Model: 9550
OS: 5.0.0.713
PIN: 31394XXX
Carrier: Verizon
Posts: 102
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Never wet but I did drop it!
__________________
da infamous wiz of....
Offline  
Old 01-14-2010, 08:42 PM   #4 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,036
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

hmmmmmmm. Could be the problem.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 01-14-2010, 09:25 PM   #5 (permalink)
Thumbs Must Hurt
 
dawiz's Avatar
 
Join Date: Apr 2009
Model: 9550
OS: 5.0.0.713
PIN: 31394XXX
Carrier: Verizon
Posts: 102
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What would you suggest I do with this?
__________________
da infamous wiz of....
Offline  
Old 01-16-2010, 02:05 PM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2007
Location: Jackson, TN
Model: 9530
OS: 5
Carrier: Verizon
Posts: 243
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

I have experienced this the past couple days while snowboarding. Has this been happening while out in the cold? If so, let it warm up a little and pull the battery.
Offline  
Old 01-16-2010, 04:29 PM   #7 (permalink)
Thumbs Must Hurt
 
dawiz's Avatar
 
Join Date: Apr 2009
Model: 9550
OS: 5.0.0.713
PIN: 31394XXX
Carrier: Verizon
Posts: 102
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I honestly think itz a permanent damage...at first the W line went, so I had problems using the keypad in landscape orientation but it was ok as I could always use the SureType...but now that the O line is dead, I have serious problems!
__________________
da infamous wiz of....

Last edited by dawiz : 01-16-2010 at 04:32 PM.
Offline  
Old 01-18-2010, 03:16 PM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Jan 2010
Model: 8850
PIN: N/A
Carrier: Verizon
Posts: 20
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

factory wipe?
Offline  
Old 01-21-2010, 05:48 PM   #9 (permalink)
Thumbs Must Hurt
 
dawiz's Avatar
 
Join Date: Apr 2009
Model: 9550
OS: 5.0.0.713
PIN: 31394XXX
Carrier: Verizon
Posts: 102
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Naw...wouldn't help! I've done that before even tho it wasn't for this purpose. I'm thinking I may have to replace the screen but I'm not sure if I may have damaged internal components...Geniuses I NEED your input...Thanks.
__________________
da infamous wiz of....
Offline  
Old 02-01-2010, 09:19 PM   #10 (permalink)
New Member
 
Join Date: Jan 2009
Model: 9500
PIN: N/A
Carrier: vodafone
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Dead screen

I also have dead spots on my screen in the same places - w, o, i, e & the sound notification section at the top of the screen. I was told to do battery pulls to fix the problem, but this only made things worse with more dead spots appearing. Seems to be a common problem with the Storm's touchscreen. You are certainly not alone!
Offline  
Old 02-03-2010, 08:57 AM   #11 (permalink)
New Member
 
Join Date: Feb 2010
Model: 9520
PIN: N/A
Carrier: Vodafone
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

does it still click when you press the dead areas? it would be the digitizer thats faulty not the screen, you can usually pick up replacements from ebay
Offline  
Old 02-04-2010, 03:16 PM   #12 (permalink)
New Member
 
Join Date: Jan 2010
Location: Lagos, Nigeria
Model: 9530
PIN: N/A
Carrier: MTN Nigeria
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Currently experiencing the dead spots too so i switched to suretype but my frustration is that when i go to the phone menu, am unable to dail 0 but when typing i am able to use the keys on the same spot. I don't think it's the cause of a faulty screen since the alphabets on that same spot work and the 0 digit doesn't. Someone help
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.