BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-06-2010, 05:47 PM   #1 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default storm wont power up

Please Login to Remove!

I have been reading forums on different websites all evening. I bought a blackberry storm 9530 on ebay and it won't power up. I got two batteries with it and it won't work with either battery. The red light flashed twice and I haven't seen any kind of light since. I left the battery out for about 30 minutes and put it back in -- got nothing. It's been on charge for about 4 hours...still nothing. I don't have insurance on it because it was purchased on ebay, but I do have service with verizon wireless. If anyone can offer any information on how to fix this, please help!!!!

Last edited by lrbagwell84 : 07-06-2010 at 05:49 PM.
Offline  
Old 07-06-2010, 06:21 PM   #2 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Leave it charging and WITH IT STILL CONNECTED to the charger, remove the battery a minute, replace and see it if reboots.

If not, return it for your money back as it is a non-working device.
Offline  
Old 07-06-2010, 06:34 PM   #3 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had it plugged in earlier and I actually took one battery out and put the other in. I didn't try it with the same battery. I'll give it a shot. I'll try anything at this point. I read in another forum that it could be wiring. Any information on that?
Offline  
Old 07-06-2010, 07:09 PM   #4 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just got a little more information on the storm. It was dropped and WOULD come on after that, but froze once in a while. Then it stopped coming on and the red light would come on while charging.

Could it be the battery or...??
Offline  
Old 07-06-2010, 07:37 PM   #5 (permalink)
CrackBerry Addict
 
DaBlackberryBoy's Avatar
 
Join Date: Jul 2006
Location: NUNYA
Model: 9850
PIN: URADUMAS
Carrier: Verizon
Posts: 669
Post Thanks: 0
Thanked 3 Times in 3 Posts
Default

Good luck getting your money back!
__________________
DaBlackberryBoy
-- http://wardsmitchelljr.com --
Offline  
Old 07-06-2010, 11:30 PM   #6 (permalink)
New Member
 
Join Date: Jul 2010
Location: Brisbane, Oz
Model: 9520
PIN: N/A
Carrier: vodafone
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, mine is doing similar after going in washing machine, the red light comes on for a short while then goes off, it does not appear to be charging, I have measured 2.8V on the outside 2 terminals marked + and -, I think it should be 3.7V.
I have charged it using 3 x AAA batteries and a 10 ohm resistor, takes a while, and I made sure it didn't go higher than 3.72V.
This allowed it to start booting up, but it fails 10% into the boot and then cycles over again, and still does not appear to be charging.
If you can, could you measure the battery voltage across combinations of all 4 terminals, I will do likewise.
I read somewhere that USB1 may not be suitable for charging, i've tried USB2 and mains power pack but still no go.
Cheers, Spartanv12
Offline  
Old 07-07-2010, 12:01 AM   #7 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

spartan, you've got a different problem...

Got Your BlackBerry Wet? - BlackBerryFAQ
Offline  
Old 07-07-2010, 12:21 AM   #8 (permalink)
New Member
 
Join Date: Jul 2010
Location: Brisbane, Oz
Model: 9520
PIN: N/A
Carrier: vodafone
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeh I know, but I also have the not charging red light flashing, we may be able to help each other diagnose the battery / not charging issue.
Cheers, Spartanv12
Offline  
Old 07-07-2010, 07:06 AM   #9 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

im not going to get into anything im not familiar with. i ordered a new battery. if it was working after the drop then chances are that the batteries may be defective or something. if that doesnt work i may try a new charger. if i cant get this one going, ill probably just upgrade to the storm2 through verizon.
Offline  
Old 07-07-2010, 07:56 AM   #10 (permalink)
CrackBerry Addict
 
pshift's Avatar
 
Join Date: Jun 2008
Location: Right behind you!!!!!
Model: ...
OS: Android
PIN: N/A. Went To Android!
Carrier: Busy Signal :)
Posts: 590
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

It's doubtful that the battery is your problem. Sounds like a cracked connector on the mobo which will not allow you to charge. If you are eligible for an upgrade, go for it. You could do far worse than a new Storm 2
Offline  
Old 07-07-2010, 08:26 AM   #11 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

a cracked connector?! lol too bad i dont know what im looking at...id take it apart and fix whatever i could. i wonder if verizon would fix it even though its not covered on insurance. anyone know if they will repair it and how much it may cost?
Offline  
Old 07-07-2010, 09:02 AM   #12 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

..just had a couple things happen that haven't happened yet. the red light came on 3 times, about 7 seconds each time and then a white screen appeared with a battery and lightning bolt symbol. does this help pinpoint the problem anyone?
Offline  
Old 07-07-2010, 03:05 PM   #13 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Not that anyone is reading this anymore, but for the record, I have had the blackberry powered on and got to play with it a bit before it died again. im assuming it's definately the battery...or the charger. Hopefully, this helps someone who is having the same problem.
Offline  
Old 07-08-2010, 05:35 AM   #14 (permalink)
New Member
 
Join Date: Jul 2010
Location: Brisbane, Oz
Model: 9520
PIN: N/A
Carrier: vodafone
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the updates, i'm still reading, hopefully this site will populate with storm 2 posts if failures become more prevalent, which could lead to fixing mine, still drying in the bag of rice.
Regards, Spartanv12.
Offline  
Old 07-18-2010, 11:31 AM   #15 (permalink)
New Member
 
Join Date: Mar 2009
Model: 8700g
PIN: N/A
Carrier: T-mobile
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This thread is definitely alive to me. My sister's storm 2 is having the "red blinking light problem" you guys have described. I hope its just a battery issue. Any info would be appreciated. I might as well call Verizon to see what they suggest.
Offline  
Old 07-18-2010, 12:50 PM   #16 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, my problem came down to the charging port on my phone. I did search after search online and it came down to that. I ordered a new battery and it worked fine until the battery died. Now I'm getting the red flashing light again. My guess is it's so dead that it won't power on. I just had to leave mine plugged in for a VERY long time until finally it came on. Yesterday it charged all the way up, but today it's dead again and I'm having the issue with the red light. Anyway, pretty sure it's just the charging port, but I bought a new wall charger to give it a shot. If it doesn't work, I'm selling it on ebay again for parts and hopefully upgrading to the storm 2 or droid X. Good luck with your issue and definately give me an update when you get one.
Offline  
Old 07-18-2010, 10:47 PM   #17 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

my wall charger was in the mail today and as of this evening..my storm is working GREAT. charges when i plug it in..i dont have to work with it. its holding charge normally now too...so hopefully that was it. only problem now is it has cricket service...anyone know how to flash it to verizon??!?!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.