BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-20-2010, 12:43 PM   #1 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9550
PIN: N/A
Carrier: Vodafone
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't send sms to numbers with international notation

Please Login to Remove!

--- sending an sms works... but not with the international notation. Therefore I also cannot send a sms to other countries ---

I bought a 9550 in Indonesia (provider XL, prepaid with internet) and I'm using it now in The Netherlands via Vodafone, for the time being, without an internet subscription.

Current status info: v5.0.0.713 (Bundle 1206, Platform 4.2.0.323).

I installed (fresh after device wipe with BBsak): "9520AllLang_PBr5.0.0_rel834_PL4.2.0.220_A5.0.0.49 7_Vodafone_Netherlands"

Since the beginning of the gms era I use the international notation for all my phone numbers. But since I'm using the BB in the Netherlands via Vodafone I'm not able to send messages to numbers with the +31612345678 notation. When I use 0612345678 it works! So in fact... I can't send a sms messages to international numbers (so not only in the Netherlands with +31... but also not to Belgium +32 or to Indonesia with +62 etc...)

In the beginning some sms messages did not reach the recipient. But now all sms messages used with the +<int><tel> are not sent at all.

I have a new sim card, tried different software versions (also: "9550AMEA_PBr5.0.0_rel1020_PL4.2.0.275_A5.0.0.607" ) but no luck. Many accu pulls, resets, settings.... new software via BBsak... via Blackberry device manager... nothing changes.

I also tried a SIM card of someone else (Vodafone prepaid)... this gives the same effect.

The smart dialing settings does not change a thing.

Vodafone cannot help me. They have looked and initialized something. But for now I've to agree with them that it lookes like a software problem. The messages are probably not leaving the device at all. But how to test?

It was a risk to buy in Indonesia for a lot of things... but sending a sms should be standard and normal functionality. So I hope that someone knows what to do. And I can't image that this can be provider dependent.

Thanks for any help!

Stefan
Offline  
Old 07-20-2010, 01:04 PM   #2 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9500
PIN: N/A
Carrier: Airtel
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I got mine from Hong Kong & I'm using it in India - Thankfully with no problems now !
I had the very same problem & Smart Dial settings did help.
According to my understanding, Your problem can no more be classified as a software problem since you've re-installed the OS.
My advice is to try fiddling around with the settings & I'm sure you'll find the solution !

Best Regards ..
Offline  
Old 07-20-2010, 05:15 PM   #3 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9550
PIN: N/A
Carrier: Vodafone
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the answer... but I'm trying all kind of settings for more than a month now. I believe that something is wrong. Too bad is that I don't know anyone with the same device. I'm on the point to install the orginal device software. Downside is that I don't have the Dutch dictonary then. But I'm using it in English anyhow. Some translations are to literal... even the power button is translated... but we now what the power button is...
Offline  
Old 07-26-2010, 03:13 PM   #4 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9550
PIN: N/A
Carrier: Vodafone
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Gmail or Google Mobile Apps is "flushing"

I was in contact with Vodafona (provider). They saw that there are put 3 extra '1''s before the number... So I thought that maybe the smart dialing is doing this... so I set country on "unknown"... but nothing helped... and suddenly today I was able to send sms messages. (I installed something more in de mean time)...



To investigate if it has something to do with the smart dialing. I change "unknown" in The Netherlands (+31)... still able to send messages... a reboot (accu pull then)... now it's not working anymore...



Hmmm....



So the country in smart dialing back on "unknown".. no problem I use the international coding for all my contacts.... accu pull... still not working...



So.... nothing to do with these settings...



What I did in the mean time: install Google Apps and Gmail.... so frustrated that the sms it not working again, I'm going in the Google Mobile Apps and start Gmail....



Now I can send sms messages again !



What has this to do with it? Has something to be "flushed"?



Vodafone is not going to help me to find out what the blackberry is sending or what has changed. They say if the SIM works in another phone the problem is the Blackberry... have fun (not!)...



But... is this the solution... not really... but it helps me for now.
Offline  
Old 07-27-2010, 03:24 PM   #5 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9550
PIN: N/A
Carrier: Vodafone
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Only starting "Google Mobile Apps" fixes my SMS problem

Now I'm sure... when having problems with sending a sms, I can solve it by only starting "Google Mobile Apps".

What's this program doing with the BB? What's the connection?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.