BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-29-2009, 12:44 PM   #1 (permalink)
New Member
 
Join Date: May 2006
Location: Brooklyn, NY
Model: 9000
Carrier: Cingular
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default App Issue with OS 4.7.1.40 - RSA SecurID

Please Login to Remove!

Figured I'd repost this here so that anyone else who runs into this will know.

We've found an issue with the BB Tour and RSA's SecurID app for the BB. Confirmed the issue on two devices and versions 3.01 and 3.02 of the RSA app.

Basically, if the RSA app is installed on the the device, email's with attachments received by the device have the attachment appear normally, but the body text of the email shows up as a text file that you can't download or open. Removing the RSA app and resending the message corrects the issue.

We've reported it to RSA, and apparently they have not yet Validated 4.7.1.40 yet, so it'll probably require a new version.

So we'll see if TPTB want to deploy it without the RSA, or wait for a new version.
Offline  
Old 07-29-2009, 02:32 PM   #2 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8703e
PIN: N/A
Carrier: Verizon
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try sending the token using the PushToken utility. It is much more reliable than emailing, for me. No need to rename the token using the 'x-rimdevice-' prefix. RSA app needs to have the setting Listen for token set to yes.
Offline  
Old 07-29-2009, 02:56 PM   #3 (permalink)
Thumbs Must Hurt
 
ItsAllVerbatim's Avatar
 
Join Date: Oct 2005
Model: Tour
Carrier: Verizon
Posts: 141
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is not encouraging as..."entities" in the DC area want to roll out the camera-less flavor of the Tour as their issued handset/leash.

Hmm...not good at all.
Offline  
Old 07-30-2009, 08:22 AM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: May 2006
Model: 8320
Carrier: T-Mobile
Posts: 65
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

@BBWrangler -- How did you install the RSA app? Over the air or via Desktop Manager?

Also, did you prepend x-rimdevice when sending the token or no?
Offline  
Old 07-30-2009, 10:15 AM   #5 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8703e
PIN: N/A
Carrier: Verizon
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Using the browser on the handheld, go to www.rsa.com/bb302
Offline  
Old 07-31-2009, 11:56 AM   #6 (permalink)
New Member
 
Join Date: May 2006
Location: Brooklyn, NY
Model: 9000
Carrier: Cingular
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Our normal procedure is to install via Apploader/Desktop Manager, but the problem also happens if I download it directly from the the website.

To clarify. The problem happens as soon as the application is loaded on the Tour. It doesn't matter if a token is installed on the device or not.
Also, it doesn't appear to happen if you're not on a BES, as BIS emails did not exhibit the problem. That last bit threw us off for a bit, but being a BES shop, having it work on BIS setups is irrelevant for our situation.

If you have a Tour, and you're on a BES (BIS only need not try this), download the app from the link TonyG3 listed, then send yourself an email with a file attachment and any kind of text in the body.
What we're seeing is the attachment comes in just fine, but instead of the body of the email, you see a file icon with the words text/plain and what I'm guessing is the size if the message in bytes in parentheses.

Remove the app, resend the same message, and it should appear properly on the device. Note that the first message you sent won't ever look correct if it was received while the RSA app was installed.

Seeing as the RSA folks haven't validated the device or it's OS with their app, it's not unexpected that this sort of thing might happen, and we're hopeful they'll be able to get an updated version out soon.

The disparity between the Bold and 8830, combined with AT&T's lousy 3G service in our area (and the locked 2G/3G toggle on the Bold), is causing no end of grumbling from some of our users. And no, none of them want the Storm.
Offline  
Old 07-31-2009, 01:26 PM   #7 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8703e
PIN: N/A
Carrier: Verizon
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Good information Wrangler. I am able to get the token installed on a 9630 using the PushToken utility in the BB302 utils. I use a vbscript to simplfy the procedure. Let me know if you are interested.
Offline  
Old 08-04-2009, 02:46 PM   #8 (permalink)
New Member
 
Join Date: May 2006
Location: Brooklyn, NY
Model: 9000
Carrier: Cingular
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the offer TonyG3.
We're ok with emailing tokens, as our helpdesk occasionally has to do it for replacement devices, and the app itself works just fine, as does installing & using a token. Just the installing the app alone causes the problem with email on BES accounts.

We've been speaking to RSA, and they've been able to reproduce the problem with the Tour, as well as with OS 5.0, which they're testing, so it's kind of a big deal for them as well now. They're working with RIM to find out what's changed between the 4.7 on the Storm, and the 4.7 on the Tour or the 5.0 betas.

As it is, we deployed one of our Tours last week, and gave the user two of the old hard cards, as he's ok with using those for now until the BB RSA issue's resolved.

Still, lag and all, the Tour is a big enough leap past the 8830, that I can see it being popular once it "officially exists" here.
Offline  
Old 09-30-2009, 12:52 PM   #9 (permalink)
New Member
 
Join Date: Feb 2008
Model: 8830
PIN: N/A
Carrier: T-Mobile
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

RIM Engineering is currently investigating this bug.
BlackBerry email display problems when RSA Software Token 3.0.2 is installed.
RIM is tracking this internally as MKS233721


Fact RSA SecurID Software Token 3.0.2 for BlackBerry

Fact BlackBerry Tour

Symptom Problem occurs on at least these versions and later (as of August, 2009):

Curve 8900: 5.0.0.130

Bold 9000: 5.0.0.130

Storm 9530: 4.7.0.151, 5.0.0.140

Tour 9630: 4.7.1.40 (current version shipping with the Tour)




Symptom Email format / display becomes corrupted. Body of text can be missing or in an attachment that cannot be opened. Problem appears to be specific to email associated with BES (and not occur with a BIS email source).

Cause As of August 17th, 2009 RIM has acknowledged this is a Blackberry OS issue and is investicating a fix. RSA tracking under bugzilla 126836.

This issue at RIM can be tracked using this link https://www.blackberry.com/jira/browse/JAVAAPI-248
RIM is tracking this internally as MKS233721.

I would appreciate if someone can contact RIM for a device software update and post that information here. It would be helpful to all of us. I have noticed there is a device software update for Verizon phones on thier web site.
Offline  
Old 11-20-2009, 03:28 PM   #10 (permalink)
New Member
 
Join Date: May 2006
Location: Brooklyn, NY
Model: 9000
Carrier: Cingular
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just wanted to update this.
Since my last post, we were in contact with RIM and were provided with a beta OS to test that did in fact resolve this issue. It took roughly a month after we reported our test results to RIM, but Verizon's 11/19/09 release - Platform 4.1.0.81 App Version 4.7.1.61 - is the 1st official release to correct the problem.

I've tested it with the same device we initially discovered the problem on, and it does indeed fix the problem.

For us, this should allow us to actually offer the Tour to our users as an upgrade from the 8830, (nobody wanted/wants the Storm), without having to revert to the old credit card tokens we'd gone through the trouble of phasing out.

Again, this affects BES users, not BIS users, although I doubt any BIS users need the RSA app unless their firm allows it.

Hopefully the eventual official OS 5.0 releases will not break this again. The Storm 2 & Storm with OS 5.0 don't exhibit the issue, which is encouraging.
Offline  
Old 11-27-2009, 07:56 PM   #11 (permalink)
New Member
 
Join Date: Feb 2008
Model: 8830
PIN: N/A
Carrier: T-Mobile
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Email attachment display problem on BlackBerry Tour is resolved

Thank you BBWrangler for posting update on the fix for BlackBerry Tour.
I have heard from other administrators that they have received the fix from RIM. This fix is available now through all telephone vendors.

A fix is available for defect MKS233721 from RIM. Please contact your telephone vendor to obtain the fix for Blackberry Tour.

https://knowledge.rsasecurity.com/sc...olution=a46987

The above link requires a login account to log on to knowledge database.

Thank you
rdugg
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.