BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-25-2009, 10:36 PM   #1 (permalink)
New Member
 
Join Date: Oct 2009
Model: 9630
PIN: N/A
Carrier: Bell Mobility
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Call display

Please Login to Remove!

Hi there,
I have unlocked Verison Tour that I am using on Rogers network. My subscribsion includes call display feature because I have it on my other device. Everything works fine (phone, data) but for whatever reason everytime someone calls me I get "unknown number" displayed.
Anyone knows where to change this option?

Thanks...

Last edited by bb4ever62 : 11-25-2009 at 10:37 PM.
Offline  
Old 11-30-2009, 07:05 PM   #2 (permalink)
New Member
 
Join Date: Nov 2009
Model: 6930T
PIN: N/A
Carrier: Fido - Canada
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am having the -exact- same issue, only I'm on Fido. I called Customer Service to be sure but they said it was a problem with the phone's settings.

When I received a call from a landline, it shows the CID but not from a cell phone. It's extremely strange and no one can fix it for me.
Offline  
Old 03-01-2010, 11:27 PM   #3 (permalink)
New Member
 
Join Date: Mar 2010
Model: Tour
PIN: N/A
Carrier: Rogers
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am having the same issue with my new Tour on the Rogers network. I set my country code properly and confirmed that I have Caller ID with Rogers. All numbers come up as unknown number it seems, I uploaded my contacts from my SIM card.
Offline  
Old 03-02-2010, 10:40 AM   #4 (permalink)
No longer Registered.
 
Join Date: Feb 2010
Location: Colorado
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 46
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

That's strange and weird :O :(
Try moving your contacts from SIm to phone memory or simply refresh your system settings
Offline  
Old 03-26-2010, 01:49 PM   #5 (permalink)
New Member
 
Join Date: Mar 2010
Model: Tour
PIN: N/A
Carrier: Rogers
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just talked with Rogers, they say it is a re-occurring problem with unlocked phones. The only suggestion they had was to re-lock and unlock the phone again. Since I got my phone from e-bay and was not unlocked properly, I seem to be hooped. oh well.
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.