BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   General 9600 Series Discussion - Tour (http://www.blackberryforums.com/general-9600-series-discussion-tour/)
-   -   Sprint 9650 Problem (http://www.blackberryforums.com/general-9600-series-discussion-tour/237893-sprint-9650-problem.html)

steve17360 10-13-2010 12:40 AM

Sprint 9650 Problem
 
Hi, I have a 9650 from Sprint that has never been used with, or registered with the Sprint network. I am using it in Russia with MTS Russia, but the BIS service cannot detect the phone. I have done an SB Legacy restore and copied the service books from my 9700 to the 9650. I have also used an MSL code and changed the phone number on the device. I've tried to register the phone with BIS and sent the service books, but nothing helps, and there are no entries in Host Routing. An additional issue is that when I try to use the browser I get an error message that states that browsing is not part of my service plan - I have a full BIS data package with my carrier, and have had no issues with any other devices.

All this leads me to think that the device thinks its still on Sprint. Any help with resolving this issue would be greatly appreciated! Thanks.

MidnightDraven 10-13-2010 04:54 AM

Check, double check and triple check with the carrier [as many people as you can talk tp] to make sure they themselves have actually activated it correctly.
Just because you asked for the plan, and your paying for the plan, doesn't mean they've correctly set it up for you to use the plan.

Dubdub 10-13-2010 07:27 AM

Moved to a more appropriate section

You need a BB data plan to connect to email and all other RIM services. Does your carrier provide that? Make sure that the carrier has the correct IMEI/ESN/MEID and PIN for the device.

And please update your profile to indicate the current device model number that you are using. It says 8900 presently.

JSanders 10-13-2010 09:23 AM

Steve, can you try getting the service books extracted from another working BlackBerry device on MTS?

You can backup that working device, then use BBSAK to extract the service books and then load them to your device. Or, is that what you have already done?

If so, then I suspect this might be an issue of connectivity with your BIS account on MTS. Is that account setup already, you are sure? Can you login to it on your PC and create email push accounts? From there, you can click to send service books.

steve17360 10-14-2010 01:34 PM

Quote:

Originally Posted by JSanders (Post 1664231)
Steve, can you try getting the service books extracted from another working BlackBerry device on MTS?

You can backup that working device, then use BBSAK to extract the service books and then load them to your device. Or, is that what you have already done?

If so, then I suspect this might be an issue of connectivity with your BIS account on MTS. Is that account setup already, you are sure? Can you login to it on your PC and create email push accounts? From there, you can click to send service books.

Hi, yes I've done all of that, and I've used several other devices with the account with no issues. Usually if I change devices BIS recognises it immediately and offers to swap my account to the new device. With the 9650 BIS doesn't recognise that I've switched devices. Thanks.

steve17360 10-15-2010 05:40 AM

Quote:

Originally Posted by steve17360 (Post 1664625)
Hi, yes I've done all of that, and I've used several other devices with the account with no issues. Usually if I change devices BIS recognises it immediately and offers to swap my account to the new device. With the 9650 BIS doesn't recognise that I've switched devices. Thanks.

The issue seems to be that the device still appears to be "connected" to Sprint. Is there an way of "removing" it from Sprint? Thanks.


All times are GMT -5. The time now is 08:00 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.