BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-30-2010, 07:56 AM   #1 (permalink)
New Member
 
Join Date: Apr 2010
Model: 9700
PIN: N/A
Carrier: Vodacom
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 9700 loses BIS data when switching 3g to 2g

Please Login to Remove!

Hi,

Thanks in advance for any help....first post go lightly!

I've searched google, blackberry, crackberry etc and no one seems to have had this issue.

I can connect to my BIS and browse fine when I'm connected to the 3G service, as soon as the handset swaps to a GPRS or EDGE I lose all data - email and browsing. If the phone is limited to 2g only then rebooted, or signal off then back on again, 2g connects fine.

GPRS/EDGE is provisioned for, and indicates on the screen in capitals.

I've changed to a 64K sim card, problem still exists.

I've tried going to Host Routing Tables and Resending service books. I've done battery pulls, wipes and reinstall OS

At a loss as to what is causing this. To top it off, I can browse on WAP via GPRS/EDGE even when BIS isn't connecting on 2G.

I've spoken with Vodacom Advanced data team, and other than suggesting a replacement handset they have no ideas.

I'm running a BB 9700, V5.0.0.593, Platform 5.1.0.147. Supplied RIM factory unbranded and never locked.
Currently using a Vodacom SA 64K sim card.
Third party apps:

Vodafone Satnav
Google maps
Facebook
Application Centre
Blackberry app world.

Thanks again.
Offline  
Old 04-30-2010, 08:43 AM   #2 (permalink)
CrackBerry Addict
 
Join Date: Dec 2008
Location: Airport lounges and starbuxxx
Model: 9900
OS: 7.0.0.296
Carrier: Vodafone Business
Posts: 573
Post Thanks: 1
Thanked 5 Times in 4 Posts
Default

Had at least a dozen handsets with the issue and new SIMs were sent out by Vodafone. It solved the problem. But you've already done that.

Why don't you take the replacement handset the data team is offering?
Offline  
Old 04-30-2010, 08:57 AM   #3 (permalink)
New Member
 
Join Date: Apr 2010
Model: 9700
PIN: N/A
Carrier: Vodacom
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

My handset was self purchased so Ideally I'd rather not have to go through the hassle of sending it away. I've been told that it wouldn't be a new handset but a refurbished replacement I'd get back.Also not sure how it would work - my handset was purchased in the UK and I'm currently based in South Africa with work! is it an international warranty on them?

Do you think its worth trying another new sim? could it be that they only do 64K sims or should that be fine for the handset?
Offline  
Old 05-02-2010, 04:52 AM   #4 (permalink)
New Member
 
Join Date: Apr 2010
Model: 9700
PIN: N/A
Carrier: Vodacom
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here's another twist -

Got a Pay and go MTN sim card, paid for a 1 month BIS

Phone works and switches between 3g / 2G seamlessly.
That to me would indicate the handset is fine and its something with the network?

what could be preventing the switch on Vodacom?
Offline  
Old 05-02-2010, 05:11 AM   #5 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,710
Post Thanks: 15
Thanked 498 Times in 485 Posts
Default

I've had this happen. I didn't switch to 2G only. And I did alt-cap-del instead of battery pull. I was in a place where 3G reception is good in some spots and low to neglibile in others, and in 9700 has switched between 3G and 2G at this place at other times. Seems when the 3G reception would drop too low, it wouldn't switch; but I would get 2G after the soft reset. I haven't had the opportunity yet to see if that was just a fluke or not. I don't have 3G in my home location.
__________________
- Ira
Offline  
Old 05-02-2010, 08:35 AM   #6 (permalink)
BBF Moderator
 
Stinsonddog's Avatar
 
Join Date: Mar 2005
Location: Northern California
Model: 9700
PIN: Agaboobie
Carrier: AT&T
Posts: 5,518
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Me too. The handoff is just flakey. Sometimes when going on a long drive, I just put it on 2g and don't worry unless I know I need the GPS too.

Quote:
Originally Posted by aiharkness View Post
I've had this happen. I didn't switch to 2G only. And I did alt-cap-del instead of battery pull. I was in a place where 3G reception is good in some spots and low to neglibile in others, and in 9700 has switched between 3G and 2G at this place at other times. Seems when the 3G reception would drop too low, it wouldn't switch; but I would get 2G after the soft reset. I haven't had the opportunity yet to see if that was just a fluke or not. I don't have 3G in my home location.
__________________
Shortcuts Rule!! Download Link:[Stinsonddog's Blackberry Tips ] GET TORCHED
@ Stinsonddog
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.