BlackBerry Forums Support Community               

Closed Thread
LinkBack Thread Tools
Old 05-08-2010, 07:07 PM   #1 (permalink)
Thumbs Must Hurt
splnkr's Avatar
Join Date: May 2008
Location: KY
Model: 9700
Carrier: AT&T
Posts: 77
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Cannot send MMS +image; browsing slow...

Please Login to Remove!

I had this issue for the past few weeks. I try and attach an image to an MMS, and it tries to send for a few minutes, then I get the red "X" of death. No number of resends, even days later, will send the message down the pipe. I can receive MMS/picture message, however. SMS and email have been unaffected. And, my ability to brows the Internet was met with constant communication error messages. This went on for weeks in numerous areas. Reception was always great. I did numerous battery pulls, service book re-sends, and the like. Searched for several solutions, like deleting the MMS files (?) on the phone. Nothing worked.

AT&T, through my dealer, could also find no problem. Finally (spoiler alert!) I asked if my dealer could give me a new SIM card. PROBLEM SOLVED! This is the second time I have had to replace my SIM card. So far, both times, this has resolved my internet connectivity problem and, recently, my MMS issue.

Not sure what happened to the SIM, but thought I'd post this issue/solution for future reference.
C.G. Anderson
Beneath Kentucky

Copyright 2004-2016
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.