BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-12-2010, 01:32 PM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: May 2007
Model: 9800
OS: OS 6
PIN: N/A
Carrier: ATT Wireless
Posts: 98
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default phone is not detected as a USB Mass Storage Device when connected to PC

Please Login to Remove!

I had a very peculiar problem, I am on my third Bold 9700 and the third time, my PC simply didn't want to detect my Bold 9700 (nor did my Mac either).


After talking to ATT, then two rounds of RIM Support (with the usual install/deinstall trouble shooting - I don't blame, but it was very frustrating to wipe my phone 24hrs after I got it and I just had it the way I want it...to get it wipe again as part of the 101 trouble shooting)

Anyhow, after 4hrs or so....the solution was so simple, it brings tears to your eyes...

- View Document

I wanted to share this with everyone if for whatever reason the new phone simply didn't want to show up as a UBS Mass storage device. I am getting the feeling it is a device problem as the solution actually did a rom image change on the phone..

Good luck.
Offline  
Old 07-13-2010, 09:05 AM   #2 (permalink)
New Member
 
Join Date: Jan 2009
Model: 8110
PIN: N/A
Carrier: Vodafone UK
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you. This has bugged me for weeks on my phone
Offline  
Old 08-20-2010, 01:23 PM   #3 (permalink)
New Member
 
Join Date: May 2009
Location: Cancún, México
Model: 9700
OS: 5.0.0.862
PIN: N/A
Carrier: Telcel
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank You So So So So So Much!!! I Was Going Crazy !!!! God Bless You!
Offline  
Old 10-16-2010, 07:06 PM   #4 (permalink)
New Member
 
Join Date: Oct 2010
Model: 8120
PIN: N/A
Carrier: t-mobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi rontiu

I had the same problem that you had but mine is with an blackberry pearl 8120. My mac won't recognize the media card and It won't show up on my desktop, I read the document that you add to your post but I still can't find a solution to my problem my Product ID: 0x8001. and I thought I had to change it but I can't do anything with it and my very lost. Please let me know what you actually did so I can actually have my mac read that media card please.
Thanks a lot for your help
Offline  
Old 01-16-2011, 12:03 PM   #5 (permalink)
New Member
 
Join Date: Aug 2010
Model: 8300
PIN: N/A
Carrier: O2
Posts: 6
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: phone is not detected as a USB Mass Storage Device when connected to PC

For Mac users that are still baffled by this problem here is the fix I used:

1. Go to the document on the Blackberry site which is link mentioned above.

2. Toward the bottom it has a fix but says this does not work for a Mac. What it actually means is that you cannot instal the fix onto your BB from OS X. So, what I did, was to borrow a friends PC and download BB Desktop Managers and the calfix.exe fix on that. I opened Desktop Manager on the PC and then ran the calfix.exe which applied the fix to my BB.

3. I then connected the BB to my Mac via a USB it was immediately recognised as a Mass Storage Device (settings set to turned on) and the media card was accessible in BB Desktop Manager for Mac and in Finder. Further tests revealed it also worked with Missing Sync.

So the answer appears to be borrow a PC to load the patch onto your BB. Annoying that RIM can't be bothered to have provided OS X equivalent to calfix.exe. Anyway, a very frustrating problem easily solved by using your mates PC.

(BB Bold 9700 v5.0.0.862)

Last edited by thornrise : 01-16-2011 at 12:25 PM.
Offline  
Old 03-28-2011, 06:02 AM   #6 (permalink)
New Member
 
Join Date: Mar 2011
Model: 8520
PIN: N/A
Carrier: Virgin
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: phone is not detected as a USB Mass Storage Device when connected to PC

Hi Thornrise - I am having the same problem but when I follow the instructions my product ID is 0x8004 - I used calfix anyway for good measure but still no solution...my BB recognises the card but neither Pc nor Mac see the card when its in the BB. I tested it via the SD slot on laptop and it's recognised fine there - just can't see it via BB. Getting really frustrated with it now!!

JOVL - did you find a solution?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.