BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-22-2010, 06:27 AM   #1 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9700
PIN: N/A
Carrier: o2
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default GMail won't sync correctly

Please Login to Remove!

Hello there,

loving my new Bold 9700, got one problem though: When I receive an email on Gmail, and read on the computer, it still shows up as unread on the phone. That is really annoying.
IMAP is enabled and I don't really want to use the GMail application.

Any ideas?
Offline  
Old 07-22-2010, 06:31 AM   #2 (permalink)
BlackBerry Mensa
 
MidnightDraven's Avatar
 
Join Date: Jan 2009
Location: Chester,UK
Model: 9000
PIN: N/A
Carrier: Tesco Mobile
Posts: 9,481
Post Thanks: 2
Thanked 110 Times in 110 Posts
Default

BIS doesnt support full IMAP yet, even with gmail. Unless using the enhanced gmail plugin I believe.
__________________
~Midnight Draven

"That's it then. Cancel the kitchen scraps for lepers and orphans, no more merciful beheadings... and call off Christmas."
Offline  
Old 07-22-2010, 06:43 AM   #3 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9700
PIN: N/A
Carrier: o2
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by MidnightDraven View Post
BIS doesnt support full IMAP yet, even with gmail. Unless using the enhanced gmail plugin I believe.

I am using that plugin.

I can use POP also, I honestly don't care. I just want Push Email and correct syncing, otherwise I don't see the point.
Offline  
Old 07-22-2010, 09:44 AM   #4 (permalink)
Talking BlackBerry Encyclopedia
 
wu-wei's Avatar
 
Join Date: Jul 2007
Model: 9700
OS: Yes
PIN: A GADDA DA VIDA
Carrier: T-Mobile USA
Posts: 480
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

Ah, this old punching bag. I have been dealing with the frustrations of Gmail sync issues for far too long.

It really wouldn't be so frustrating if things hadn't worked just fine (for me, anyway) at one point in the past.

My only beef is having to delete messages in multiple places - phone and google inbox.

One of the hybrid OSes I had installed actually worked properly with google apps mail, but it still didn't work with regular gmail. I'm actually tempted to revert back to that OS again, just for that feature.

And the gmail plugin is virtually useless in my view.
Offline  
Old 07-22-2010, 10:32 AM   #5 (permalink)
BBF Moderator
 
akosnitzky's Avatar
 
Join Date: Jul 2005
Location: Southern Florida
Model: 9650
OS: 6.0.0.333
Carrier: Verizon BIS
Posts: 14,484
Post Thanks: 6
Thanked 7 Times in 7 Posts
Default

This is a work in process. I am finally able to delete on handheld and get it to reconcile which what yahoo had a few yrs ago
__________________
------
Follow @akosnitzky on Twitter

LET'S GO CANES!
Offline  
Old 07-22-2010, 12:00 PM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2007
Location: Central NJ
Model: 9900
OS: 7.1.0.284
PIN: nacle of creation
Carrier: ATT
Posts: 318
Post Thanks: 4
Thanked 8 Times in 8 Posts
Default

It does take a while for the messages to appear read on bb or be deleted after I read or deleted them on Gmail webmail, but at least it works. I do not use Outlook, just the web client.

I do not have the enhanced Gmail plug-in and set up my gmail for bb using the BIS website. I set it up the same way I did my work email - entered the incorrect password and was prompted to provide additional settings. Has been working since...
__________________
8703e>>> 8310>>> 8330>>> 8310>>> 9700>>> 9800>>> 9900>>> Z10 AND Playbook 64GB

Last edited by snhrph : 07-22-2010 at 12:10 PM.
Offline  
Old 07-22-2010, 12:09 PM   #7 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9700
PIN: N/A
Carrier: o2
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by snhrph View Post
It does take a while for the messages to appear read on bb or be deleted after I read or deleted them on Gmail webmail, but at least it works. I do not use Outlook, just the web client.

Same here. I only use GMail Webinterface, and BB GMail plugin. Nothing else.

But like I said: reading something on Webinterface won't make it marked read on BB.
Offline  
Old 07-22-2010, 12:12 PM   #8 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2007
Location: Central NJ
Model: 9900
OS: 7.1.0.284
PIN: nacle of creation
Carrier: ATT
Posts: 318
Post Thanks: 4
Thanked 8 Times in 8 Posts
Default

@DomBerry, read the second paragraph of my message.
__________________
8703e>>> 8310>>> 8330>>> 8310>>> 9700>>> 9800>>> 9900>>> Z10 AND Playbook 64GB
Offline  
Old 07-22-2010, 02:46 PM   #9 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Jan 2010
Model: 9630
OS: 5.0.0.591
PIN: N/A
Carrier: TBayTEL
Posts: 269
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by snhrph View Post
It does take a while for the messages to appear read on bb or be deleted after I read or deleted them on Gmail webmail, but at least it works. I do not use Outlook, just the web client.

I do not have the enhanced Gmail plug-in and set up my gmail for bb using the BIS website. I set it up the same way I did my work email - entered the incorrect password and was prompted to provide additional settings. Has been working since...
When you say "a while", how long exactly, because I have waited up to an hour at times and it still never completely syncs. The only time it works properly is if I mark it read or delete it from my Blackberry first. If I try and mark it as read, or delete it from Gmail inbox, it seemly never reconciles with my device.

Last edited by fratts : 07-22-2010 at 02:47 PM.
Offline  
Old 07-22-2010, 02:53 PM   #10 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2007
Location: Central NJ
Model: 9900
OS: 7.1.0.284
PIN: nacle of creation
Carrier: ATT
Posts: 318
Post Thanks: 4
Thanked 8 Times in 8 Posts
Default

Wirelessly posted

It varies. It could be about an hour, to a few hrs, to overnight.
I mostly read messages on bb and go to web client only when necessary, so not much of a deal for me.
__________________
8703e>>> 8310>>> 8330>>> 8310>>> 9700>>> 9800>>> 9900>>> Z10 AND Playbook 64GB
Offline  
Old 07-22-2010, 04:35 PM   #11 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9700
PIN: N/A
Carrier: o2
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by snhrph View Post
@DomBerry, read the second paragraph of my message.
What additional settings did you provide?
Offline  
Old 07-22-2010, 04:51 PM   #12 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2007
Location: Central NJ
Model: 9900
OS: 7.1.0.284
PIN: nacle of creation
Carrier: ATT
Posts: 318
Post Thanks: 4
Thanked 8 Times in 8 Posts
Default

Quote:
Originally Posted by DomBerry View Post
What additional settings did you provide?
Email server: imap.google.com and your user name.
__________________
8703e>>> 8310>>> 8330>>> 8310>>> 9700>>> 9800>>> 9900>>> Z10 AND Playbook 64GB
Offline  
Old 07-22-2010, 06:55 PM   #13 (permalink)
BlackBerryForums.com Super Moderator
 
SteveO86's Avatar
 
Join Date: Sep 2007
Location: Florida
Model: 9650
OS: 6.0.0.280
PIN: I heard it drop!
Carrier: VZW BIS
Posts: 6,534
Post Thanks: 0
Thanked 4 Times in 1 Post
Default

It's a tough thing to discuss.

From BB to Gmail, sync is perfect.

From Gmail to BB, it takes time but it is there, I think it sweeps through every 4 hours but do not quote me as I haven't even been able to pin it down yet.


Gmail contact sync has been working great form despite the initial head ache.
__________________
8830 -> 8330 -> 9550 -> 9650
Just think about how far BlackBerries have come from then till now... And what else is coming.

Follow me on Twitter
Offline  
Old 07-23-2010, 04:16 AM   #14 (permalink)
New Member
 
Join Date: Jul 2010
Model: 9700
PIN: N/A
Carrier: o2
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by snhrph View Post
It does take a while for the messages to appear read on bb or be deleted after I read or deleted them on Gmail webmail, but at least it works. I do not use Outlook, just the web client.

I do not have the enhanced Gmail plug-in and set up my gmail for bb using the BIS website. I set it up the same way I did my work email - entered the incorrect password and was prompted to provide additional settings. Has been working since...
I'm not being asked to provide additional settings, but to contact "Gmail.com" :|
Offline  
Old 07-23-2010, 04:49 PM   #15 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2007
Location: Central NJ
Model: 9900
OS: 7.1.0.284
PIN: nacle of creation
Carrier: ATT
Posts: 318
Post Thanks: 4
Thanked 8 Times in 8 Posts
Default

I gave you misleading directions - do NOT enter a passwrod at all, just the email address. Click Next. On the next screen you will see a message below:

The email address or password is incorrect, or we need more details to set up this email. Retype the information or provide additional settings.

Click on Provide Addidtional Settings. Email server is imap.gmail.com

Sorry for the confusion.
__________________
8703e>>> 8310>>> 8330>>> 8310>>> 9700>>> 9800>>> 9900>>> Z10 AND Playbook 64GB

Last edited by snhrph : 07-23-2010 at 05:37 PM. Reason: misspelled
Offline  
Old 07-23-2010, 05:02 PM   #16 (permalink)
Talking BlackBerry Encyclopedia
 
wu-wei's Avatar
 
Join Date: Jul 2007
Model: 9700
OS: Yes
PIN: A GADDA DA VIDA
Carrier: T-Mobile USA
Posts: 480
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

snhrph, that method used to work, but the latest BIS interface that I'm seeing (T-Mobile USA) does not allow you to leave a blank password. If you enter a gmail address, a pop-up directs you to input a valid password or contact gmail. There is no longer an option to add advanced settings for gmail addresses.

I have been able to use this method with google apps accounts (and those are the only ones that are syncing properly for me) but I just tried deleting and adding back my plain gmail account and got the same prompts reported by DomBerry.

[EDIT]

OK, I just went back and tried another way. I deleted the regular Gmail account. Then I added a new account, mistyped gmail as gmial and it gave me a link to 'provide additional settings'.

Once I was in there, I corrected the misspelling of gmail, listed the imap server, and I have the Advanced Settings options on my Gmail account again. Woohoo!

Let's see how the sync performs....

[/EDIT]

Last edited by wu-wei : 07-23-2010 at 05:11 PM. Reason: Tried another alternative, updated post
Offline  
Old 07-23-2010, 05:12 PM   #17 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2007
Location: Central NJ
Model: 9900
OS: 7.1.0.284
PIN: nacle of creation
Carrier: ATT
Posts: 318
Post Thanks: 4
Thanked 8 Times in 8 Posts
Default

Quote:
Originally Posted by wu-wei View Post
snhrph, that method used to work, but the latest BIS interface that I'm seeing (T-Mobile USA) does not allow you to leave a blank password. If you enter a gmail address, a pop-up directs you to input a valid password or contact gmail. There is no longer an option to add advanced settings for gmail addresses.

I have been able to use this method with google apps accounts (and those are the only ones that are syncing properly for me) but I just tried deleting and adding back my plain gmail account and got the same prompts reported by DomBerry.
Trying now...
__________________
8703e>>> 8310>>> 8330>>> 8310>>> 9700>>> 9800>>> 9900>>> Z10 AND Playbook 64GB

Last edited by snhrph : 07-23-2010 at 05:14 PM.
Offline  
Old 07-23-2010, 05:23 PM   #18 (permalink)
Talking BlackBerry Encyclopedia
 
wu-wei's Avatar
 
Join Date: Jul 2007
Model: 9700
OS: Yes
PIN: A GADDA DA VIDA
Carrier: T-Mobile USA
Posts: 480
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

And sync of my deleted items is functioning again.

Outstanding.

Today has officially become a good day.
Offline  
Old 07-23-2010, 05:29 PM   #19 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2007
Location: Central NJ
Model: 9900
OS: 7.1.0.284
PIN: nacle of creation
Carrier: ATT
Posts: 318
Post Thanks: 4
Thanked 8 Times in 8 Posts
Default

I tried to attach the screenshots of my BIS... Did not attach.

In any case, it does work.
__________________
8703e>>> 8310>>> 8330>>> 8310>>> 9700>>> 9800>>> 9900>>> Z10 AND Playbook 64GB
Offline  
Old 07-23-2010, 05:32 PM   #20 (permalink)
Talking BlackBerry Encyclopedia
 
wu-wei's Avatar
 
Join Date: Jul 2007
Model: 9700
OS: Yes
PIN: A GADDA DA VIDA
Carrier: T-Mobile USA
Posts: 480
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by snhrph View Post
I tried to attach the screenshots of my BIS... Did not attach.

In any case, it does work.
I can confirm that it does work as well. I edited my earlier post, but here's what I had to do:

1. Delete the existing Gmail account that wasn't syncing.

2. Add a new account, but provide a misspelled email address and no password.

3. When that add account fails, select the link to provide additional settings.

4. Fix the mistyped email to the correct Gmail address, provide password, and list imap.gmail.com as the server.

Voila! Deleted items are syncing again, and no awful plugin to deal with.
Offline  
The Following User Says Thank You to wu-wei For This Useful Post:
drbb917 (12-01-2010)
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.