BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-07-2010, 12:27 AM   #1 (permalink)
New Member
 
Join Date: Sep 2010
Model: 9700
PIN: N/A
Carrier: AT&T
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 9700 Water Damage, Please Help!

Please Login to Remove!

Hey, I dropped my Blackberry 9700 Bold in water. I shook it out and used it for the night, first some letters would not appear on the screen when I typed them, and the number of letters not working grew until it broke. I put it in rice for two days, now when I turn it on the red light comes on, the screen that says Blackberry with the load bar loads but never finishes before it shuts down and restarts the process. What should I do? Thanks a lot!
Offline  
Old 09-07-2010, 07:14 AM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,033
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

Most likely it is fried, especially if you kept using it after it hit the water.

Probably a bit late for you but: Got Your BlackBerry Wet? - BlackBerryFAQ
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 09-07-2010, 09:20 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2008
Model: Many
PIN: N/A
Carrier: T-Mobile and AT&T
Posts: 45
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

My BB didn't have water damage but it did reboot like you decribe in your post.

The BB would start to load and then as soon as it progresed to almost complete it would shut off. I put it on the charger and it booted normally after that. Funny thing was that it was showing 2 bars of battery before and when I attached it to the charger it showed that the battery was drained with 0 bars.
Offline  
Old 09-07-2010, 09:24 AM   #4 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,033
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

Peter, please update your profile to show the current device you are using. It helps us to know which device you are using if and when you have a question.

And it isn't considered good manners to hijack a thread. In your case, depending on the model, it might be a bad battery.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 09-07-2010, 05:40 PM   #5 (permalink)
New Member
 
Join Date: Oct 2009
Model: none
PIN: N/A
Carrier: at&t
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It sounds to me like you have to reload the OS on your BB. Open DM, plug in the 9700 and reload.

As an aside, my 9700 got wet about a month ago. At first, everything appeared normal, but then....ANTS! Sorry, couldn't resist.

Actually, everything now works except my camera. I'm lucky that's all that is bad. If anyone has any suggestions on how to get the camera to work again, I'd be all over that.
Offline  
Old 09-07-2010, 05:45 PM   #6 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,033
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

Quote:
Originally Posted by lighthouse84 View Post
It sounds to me like you have to reload the OS on your BB. Open DM, plug in the 9700 and reload.

As an aside, my 9700 got wet about a month ago. At first, everything appeared normal, but then....ANTS! Sorry, couldn't resist.

Actually, everything now works except my camera. I'm lucky that's all that is bad. If anyone has any suggestions on how to get the camera to work again, I'd be all over that.
Lighthouse, an OS reload most likely will not fix the OPs problem. And an OS reload or upgrade is not the answer to every problem.

If yours got wet, then you are very lucky, most do not survive.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 09-08-2010, 02:09 PM   #7 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2006
Location: Hollywood
Model: 9700
Carrier: AT&T
Posts: 68
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Worst thing you did was continue to use it that night. I dropped mine in the ocean and had to go down four feet to retrieve it. I immediately removed my battery. Then I gave it a bath in distilled water, changing out the water several times to ensure all the salt was out of there. I had it completely in distilled water for a couple of hours. Then I took it out and let it air dry for two weeks. After that I replaced the battery and it booted up and worked fine. I was advised to use distilled water by an electronics company who specializes in repairing police radios. They said the three most important things are 1) remove battery immediately 2) give it a distilled water bath even if you drop it in frssh water. Fresh water has minerals and chemicals that need to be removed also. 3) Do not attempt to restart until completely dry.
Offline  
Old 09-08-2010, 04:46 PM   #8 (permalink)
Thumbs Must Hurt
 
Join Date: Oct 2008
Model: 9800
PIN: N/A
Carrier: Orange CH
Posts: 70
Post Thanks: 3
Thanked 10 Times in 1 Post
Default

i would say that your keyboard is fried.

replace that there are sites like Cellular Nationwide Network - 3G, Sony, Panasonic, LG, SonyEricsson, Nokia, Tools, BlackBerry, that have it.
Offline  
Old 09-10-2010, 09:44 AM   #9 (permalink)
New Member
 
Join Date: Oct 2009
Model: none
PIN: N/A
Carrier: at&t
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Dubdub View Post
Lighthouse, an OS reload most likely will not fix the OPs problem. And an OS reload or upgrade is not the answer to every problem.

If yours got wet, then you are very lucky, most do not survive.
Actually, the OP's problem happened to me. It was a never ending do-loop where it kept trying to boot and then would stop and start over. Reloading the OS fixed it. Granted, I lost everything and then had to reload all my apps, but I'm not complaining.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.