BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   General 9900 Series Discussion - Bold Touch (http://www.blackberryforums.com/general-9900-series-discussion-bold-touch/)
-   -   Wifi problem with 9900 (http://www.blackberryforums.com/general-9900-series-discussion-bold-touch/259487-wifi-problem-9900-a.html)

crof 05-15-2012 10:53 AM

Wifi problem with 9900
 
Hey, my problem with my Blackberry 9900 is that I can connect to my wifi network and it works for about 2 or 3 pages of web browsing and then it just stops responding.

The 'outgoing arrow' flashes in the top right hand corner as if my blackberry is sending requests to my router but the 'incoming arrow' stops coming up and i get an 'unable to find the requested server.' message. There is no problem with my router etc as my laptop works perfectly over it.

It says that I am still connected to the network when this happens and if I disconnect and then reconnect again it does the same thing over and over.

The internet is fine when I use my 'mobile network' (i'm with O2 in the UK) so it is a wifi problem that just stops working after a couple of minutes.

Thanks in advance for any help or advice.

dc/dc 05-15-2012 10:56 AM

Re: Wifi problem with 9900
 
Does this happen on all WiFi networks?

crof 05-15-2012 11:07 AM

Re: Wifi problem with 9900
 
I've only tried it on one other in my sisters house and the same happened. Plus I let everyone else who comes into my house to connect to my network while they're here and they have had no problems.

stevew 05-16-2012 12:36 AM

Re: Wifi problem with 9900
 
Here's something I discovered after a year of after screwing around with what I thought was a bad device and / or WiFi setup.

On Wireless G and N...if you have a long WiFi (WPA2- PSK) password, the device will connect to WiFi but BIS/BES and Phone connections will not stay connected long and sometimes will not even connect at all.

The solution is simple if that's the case.

Setup a shorter password, or add a new SSID (if your router supports it) for a guest network with a shorter password. I had lots of issues with a 63-character password until I discovered this. No other devices had issues except this stupid Bold, but that's exactly what it was in the end...

I can replicate the problem at will.

iansky 07-11-2012 08:47 AM

Re: Wifi problem with 9900
 
I am on O2 and my home Wifi is talktalk, I had a similar problem and the phone said I was connected to the wifi and it showed up but would hang, disengage etc.
After resetting my router and trying the phone on other wifi networks where it worked, I discovered the issue was the router as it did not support my 9900 or my wifes 9360 both running 7.1 firmware.

My iPhone used to work perfectly as did my laptop with the old router so it was just the lack support for bandwidth and the new firmware.

I got a replacement router from Talktalk and everything is now working perfectly.

This may not be the cause but it could be worth exploring.

Good luck:smile:



Quote:

Originally Posted by crof (Post 1777719)
Hey, my problem with my Blackberry 9900 is that I can connect to my wifi network and it works for about 2 or 3 pages of web browsing and then it just stops responding.

The 'outgoing arrow' flashes in the top right hand corner as if my blackberry is sending requests to my router but the 'incoming arrow' stops coming up and i get an 'unable to find the requested server.' message. There is no problem with my router etc as my laptop works perfectly over it.

It says that I am still connected to the network when this happens and if I disconnect and then reconnect again it does the same thing over and over.

The internet is fine when I use my 'mobile network' (i'm with O2 in the UK) so it is a wifi problem that just stops working after a couple of minutes.

Thanks in advance for any help or advice.


dsigner 08-26-2012 08:23 AM

Re: Wifi problem with 9900
 
Quote:

Originally Posted by stevew (Post 1777775)
Here's something I discovered after a year of after screwing around with what I thought was a bad device and / or WiFi setup.

On Wireless G and N...if you have a long WiFi (WPA2- PSK) password, the device will connect to WiFi but BIS/BES and Phone connections will not stay connected long and sometimes will not even connect at all.

The solution is simple if that's the case.

Setup a shorter password, or add a new SSID (if your router supports it) for a guest network with a shorter password
. I had lots of issues with a 63-character password until I discovered this. No other devices had issues except this stupid Bold, but that's exactly what it was in the end...

I can replicate the problem at will.

Adding my experience..
I've had a similar issue and it's been resolved with by switching the router off for a few seconds, then switching it back on.

Granted you probably tried this first - but for anyone reading this thread for the first time, they may wish to try that first.

(I've also noted some other devices with flaky connectivity, e.g. laptop - so the problem points more towards the router being a problem than the phone).

Lilyberry 08-30-2012 09:07 PM

Re: Wifi problem with 9900
 
I am confronting with the same problem with the OP. Thanks for your discussion.:smile:


All times are GMT -5. The time now is 12:02 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.