BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-15-2012, 10:53 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2012
Location: Glasgow
Model: 9900
OS: Windows 7
PIN: N/A
Carrier: O2
Posts: 37
Post Thanks: 0
Thanked 1 Time in 1 Post
Default Wifi problem with 9900

Please Login to Remove!

Hey, my problem with my Blackberry 9900 is that I can connect to my wifi network and it works for about 2 or 3 pages of web browsing and then it just stops responding.

The 'outgoing arrow' flashes in the top right hand corner as if my blackberry is sending requests to my router but the 'incoming arrow' stops coming up and i get an 'unable to find the requested server.' message. There is no problem with my router etc as my laptop works perfectly over it.

It says that I am still connected to the network when this happens and if I disconnect and then reconnect again it does the same thing over and over.

The internet is fine when I use my 'mobile network' (i'm with O2 in the UK) so it is a wifi problem that just stops working after a couple of minutes.

Thanks in advance for any help or advice.
Offline  
The Following User Says Thank You to crof For This Useful Post:
Lilyberry (08-30-2012)
Old 05-15-2012, 10:56 AM   #2 (permalink)
Spam Reporter
 
dc/dc's Avatar
 
Join Date: Oct 2005
Location: IAD
Model: 6230
Carrier: Voicestream
Posts: 14,530
Post Thanks: 220
Thanked 345 Times in 311 Posts
Default Re: Wifi problem with 9900

Does this happen on all WiFi networks?
__________________
I h8 txtspk.
Offline  
The Following User Says Thank You to dc/dc For This Useful Post:
Lilyberry (08-30-2012)
Old 05-15-2012, 11:07 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2012
Location: Glasgow
Model: 9900
OS: Windows 7
PIN: N/A
Carrier: O2
Posts: 37
Post Thanks: 0
Thanked 1 Time in 1 Post
Default Re: Wifi problem with 9900

I've only tried it on one other in my sisters house and the same happened. Plus I let everyone else who comes into my house to connect to my network while they're here and they have had no problems.

Last edited by crof : 05-15-2012 at 11:09 AM.
Offline  
Old 05-16-2012, 12:36 AM   #4 (permalink)
BlackBerry Extraordinaire
 
stevew's Avatar
 
Join Date: Jan 2005
Location: Montreal
Model: Z10
OS: Latest...
Carrier: Koodo Mobile
Posts: 1,354
Post Thanks: 1
Thanked 52 Times in 48 Posts
Default Re: Wifi problem with 9900

Here's something I discovered after a year of after screwing around with what I thought was a bad device and / or WiFi setup.

On Wireless G and N...if you have a long WiFi (WPA2- PSK) password, the device will connect to WiFi but BIS/BES and Phone connections will not stay connected long and sometimes will not even connect at all.

The solution is simple if that's the case.

Setup a shorter password, or add a new SSID (if your router supports it) for a guest network with a shorter password. I had lots of issues with a 63-character password until I discovered this. No other devices had issues except this stupid Bold, but that's exactly what it was in the end...

I can replicate the problem at will.
__________________
Steve (Besadmin)

Previously owned:
At least 17+ different BB's since 1999 -- too many to list...
Offline  
The Following 2 Users Say Thank You to stevew For This Useful Post:
devnull (05-16-2012), Lilyberry (08-30-2012)
Old 07-11-2012, 08:47 AM   #5 (permalink)
New Member
 
Join Date: Jun 2012
Model: 9900
PIN: N/A
Carrier: O2
Posts: 7
Post Thanks: 1
Thanked 2 Times in 2 Posts
Default Re: Wifi problem with 9900

I am on O2 and my home Wifi is talktalk, I had a similar problem and the phone said I was connected to the wifi and it showed up but would hang, disengage etc.
After resetting my router and trying the phone on other wifi networks where it worked, I discovered the issue was the router as it did not support my 9900 or my wifes 9360 both running 7.1 firmware.

My iPhone used to work perfectly as did my laptop with the old router so it was just the lack support for bandwidth and the new firmware.

I got a replacement router from Talktalk and everything is now working perfectly.

This may not be the cause but it could be worth exploring.

Good luck



Quote:
Originally Posted by crof View Post
Hey, my problem with my Blackberry 9900 is that I can connect to my wifi network and it works for about 2 or 3 pages of web browsing and then it just stops responding.

The 'outgoing arrow' flashes in the top right hand corner as if my blackberry is sending requests to my router but the 'incoming arrow' stops coming up and i get an 'unable to find the requested server.' message. There is no problem with my router etc as my laptop works perfectly over it.

It says that I am still connected to the network when this happens and if I disconnect and then reconnect again it does the same thing over and over.

The internet is fine when I use my 'mobile network' (i'm with O2 in the UK) so it is a wifi problem that just stops working after a couple of minutes.

Thanks in advance for any help or advice.

Last edited by iansky : 07-11-2012 at 08:49 AM.
Offline  
The Following User Says Thank You to iansky For This Useful Post:
Lilyberry (08-30-2012)
Old 08-26-2012, 08:23 AM   #6 (permalink)
New Member
 
dsigner's Avatar
 
Join Date: Aug 2012
Model: 9900
PIN: N/A
Carrier: unknown
Posts: 3
Post Thanks: 0
Thanked 1 Time in 1 Post
Default Re: Wifi problem with 9900

Quote:
Originally Posted by stevew View Post
Here's something I discovered after a year of after screwing around with what I thought was a bad device and / or WiFi setup.

On Wireless G and N...if you have a long WiFi (WPA2- PSK) password, the device will connect to WiFi but BIS/BES and Phone connections will not stay connected long and sometimes will not even connect at all.

The solution is simple if that's the case.

Setup a shorter password, or add a new SSID (if your router supports it) for a guest network with a shorter password
. I had lots of issues with a 63-character password until I discovered this. No other devices had issues except this stupid Bold, but that's exactly what it was in the end...

I can replicate the problem at will.
Adding my experience..
I've had a similar issue and it's been resolved with by switching the router off for a few seconds, then switching it back on.

Granted you probably tried this first - but for anyone reading this thread for the first time, they may wish to try that first.

(I've also noted some other devices with flaky connectivity, e.g. laptop - so the problem points more towards the router being a problem than the phone).
Offline  
The Following User Says Thank You to dsigner For This Useful Post:
Lilyberry (08-30-2012)
Old 08-30-2012, 09:07 PM   #7 (permalink)
No longer Registered.
 
Join Date: Aug 2012
Model: 9900
PIN: N/A
Carrier: SMARTONE
Posts: 15
Post Thanks: 8
Thanked 0 Times in 0 Posts
Default Re: Wifi problem with 9900

I am confronting with the same problem with the OP. Thanks for your discussion.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Wifi problem with 9900
Thread Thread Starter Forum Replies Last Post
blackberry bold 9900 wifi help braincandyxxx BlackBerry Help 4 12-19-2011 10:26 AM
Help!! | Signal Reception Problem - 9900 user from the Philippines juma.jono General 9900 Series Discussion - Bold Touch 2 08-28-2011 11:05 PM
Wifi problem Foxglove General 9900 Series Discussion - Bold Touch 8 08-22-2011 06:51 PM
Bold WiFi Problem kllaus General 9000 Series Discussion - Bold 6 12-02-2009 04:42 AM
WiFi Problem dajawu General 9000 Series Discussion - Bold 11 04-21-2009 08:22 AM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.