BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-30-2007, 12:35 PM   #1 (permalink)
Knows Where the Search Button Is
 
cannondale0815's Avatar
 
Join Date: Feb 2005
Location: Singapore
Model: 8100
Carrier: SingTel
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default DST Issue -- Pearl on BES

Please Login to Remove!

I am located in the Eastern United States and work for a company with offices around the globe. My BB is activated on my company's BES. Since the DST change in the UK on Monday, my BB is screwed up in multiple ways:

- Some (not all) calendar entries now show up one hour earlier
- My BB time is showing one hour earlier than the actual time, even though it is set to EST

I initially thought that this had to do with the DST patch that I still had on my BB, but which wasn't required by my current firmware version anymore (I applied the newest T-Mobile firmware a week ago). So I re-installed the firmware yesterday and made sure to uncheck the DST patch (as it was only listed because it was already on my BB, it didn't come with the new FW version).

Still, this didn't help.

My company claims that it is not a problem on their end, as I am apparently the only person who complained about his.

My BB is a T-Mobile Pearl.

Any help appreciated.
Offline  
Old 10-30-2007, 03:00 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 8700g
PIN: N/A
Carrier: T-Mo
Posts: 36
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey, I'm no BB expert, but if you uncheck an app from the list when updating the device, I think that doesn't just exclude it from being installed, it will actually remove it.

I know some Pearl's need the DST patch and some don't (it's by the color...I guess the newer colors came out after the black and white ones?...but you should check to confirm).

Are you a US subsciber on international roaming? Did you try asking your phone support like AT&T or T-Mo? They're decent help.
Offline  
Old 10-30-2007, 03:19 PM   #3 (permalink)
Knows Where the Search Button Is
 
cannondale0815's Avatar
 
Join Date: Feb 2005
Location: Singapore
Model: 8100
Carrier: SingTel
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The problem was present with and without the DST patch. Also, my understanding is that the newer firmwares, regardless of how old the device is, include the DST patch automatically (in which cases it is also not listed separately in the applications list anymore).

I didn't call up T-Mobile yet, but somehow I doubt that their support team has the technological breath to understand this problem...
Offline  
Old 10-31-2007, 10:52 AM   #4 (permalink)
Knows Where the Search Button Is
 
cannondale0815's Avatar
 
Join Date: Feb 2005
Location: Singapore
Model: 8100
Carrier: SingTel
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, after digging into this a bit more, I have a theory:

The latest software version I am using already has the DST patch applied, and after I loaded it onto my Pearl the last time, I checked to make sure that the application list (under settings) doesn't have any reference to a separately installed DST patch. It didn't, which was good. Up to this point (before activation on my company's BES), all restored calendar entries showed up under the correct time.

Then when I activated my Pearl on my company's BES, it automatically added the TimezoneOtaPatcher application to my applications list. I am assuming this installation was done "Over the air" (hence the "Ota" in the name) by my company.

Now my theory is that, since my software version already had the patch included, this separate patch screws things up again.

Does that sound plausible? I am going to discuss this with my company's tech support next.
Offline  
Old 10-31-2007, 11:09 AM   #5 (permalink)
iPhone Convert
 
juwaack68's Avatar
 
Join Date: Oct 2005
Location: Tulip City - MI
Model: iP5
OS: 6.0.2
PIN: to beans
Carrier: I'm not
Posts: 13,875
Post Thanks: 3
Thanked 72 Times in 55 Posts
Default

What version OS do you have on your device? 4.2? If so, you may need to do this to fix it:

BlackBerry Technical Solution Center

I have a Sprint 8830 w/ 4.2 OS and had the same problem you're experiencing. I contacted RIM and they pointed me to this KB, which resolved the problem.
__________________
No longer a BES Admin, but it was fun while it lasted!
Offline  
Old 10-31-2007, 11:17 AM   #6 (permalink)
Knows Where the Search Button Is
 
cannondale0815's Avatar
 
Join Date: Feb 2005
Location: Singapore
Model: 8100
Carrier: SingTel
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the quick response. Unfortunately the link doesn't work for me, I am getting this error message:

"Sorry, your request could not be processed at this time."

Yes, I have the 4.2.1.107 OS.
Offline  
Old 10-31-2007, 11:20 AM   #7 (permalink)
iPhone Convert
 
juwaack68's Avatar
 
Join Date: Oct 2005
Location: Tulip City - MI
Model: iP5
OS: 6.0.2
PIN: to beans
Carrier: I'm not
Posts: 13,875
Post Thanks: 3
Thanked 72 Times in 55 Posts
Default

Well fiddlesticks! Here are the steps I followed:

My clock fell back
__________________
No longer a BES Admin, but it was fun while it lasted!
Offline  
Old 10-31-2007, 11:30 AM   #8 (permalink)
Knows Where the Search Button Is
 
cannondale0815's Avatar
 
Join Date: Feb 2005
Location: Singapore
Model: 8100
Carrier: SingTel
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for this. I went through it, but I doubt I will be able to get my company to remove my user account from the BES and then re-add it. They only do standard type of setups and rarely accommodate individual requests like this, as they are dealing with hundreds of BES users worldwide.

That said, if I could find a working link to that knowledge base article, perhaps they might entertain it.

Thanks for all your help.
Offline  
Old 10-31-2007, 11:42 AM   #9 (permalink)
iPhone Convert
 
juwaack68's Avatar
 
Join Date: Oct 2005
Location: Tulip City - MI
Model: iP5
OS: 6.0.2
PIN: to beans
Carrier: I'm not
Posts: 13,875
Post Thanks: 3
Thanked 72 Times in 55 Posts
Default

Let me look for it.....
__________________
No longer a BES Admin, but it was fun while it lasted!
Offline  
Old 10-31-2007, 11:47 AM   #10 (permalink)
iPhone Convert
 
juwaack68's Avatar
 
Join Date: Oct 2005
Location: Tulip City - MI
Model: iP5
OS: 6.0.2
PIN: to beans
Carrier: I'm not
Posts: 13,875
Post Thanks: 3
Thanked 72 Times in 55 Posts
Default

This is VERY interesting. Either the link to KB12570 has been removed or the article has been removed. I'm very curious why they got rid of it!

Here is a similar KB article:

BlackBerry Search Results
__________________
No longer a BES Admin, but it was fun while it lasted!
Offline  
Old 10-31-2007, 02:49 PM   #11 (permalink)
Knows Where the Search Button Is
 
cannondale0815's Avatar
 
Join Date: Feb 2005
Location: Singapore
Model: 8100
Carrier: SingTel
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wow, this must be the holy grail! The description matches, and I also tested it by setting my date/time manually to 11 March 2007, 2:01 AM, as described in the article. My BB allows me to do that, so according to the article, my DST table is messed up.

I forwarded this article to our support team. Hopefully they do the needful.

Thanks much!!!
Offline  
Old 10-31-2007, 03:25 PM   #12 (permalink)
Knows Where the Search Button Is
 
cannondale0815's Avatar
 
Join Date: Feb 2005
Location: Singapore
Model: 8100
Carrier: SingTel
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

juwaack68,

I love you man! Our BES folks got in touch with RIM and verified that the KB article is indeed a match for my problem. They are now going to run the DST repair tool that is mentioned in the article.

Once it is done, I'll report back.

Thank you so much! It drove me nuts earlier this year when I had the same problem during the last DST switch, but I couldn't find a solution back then.

-J
Offline  
Old 11-01-2007, 12:52 PM   #13 (permalink)
Knows Where the Search Button Is
 
cannondale0815's Avatar
 
Join Date: Feb 2005
Location: Singapore
Model: 8100
Carrier: SingTel
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

juwaack,

yes, this problem is fixed now. Thanks to your help and the prompt help of my company's BES admins, my DST problem is fixed after they ran the DST repair tool that is mentioned in the KB article.

Thanks again!
-J
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.