BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-09-2007, 05:18 PM   #1 (permalink)
BBFAQ Sysop
 
ricpac's Avatar
 
Join Date: Oct 2007
Location: Philippines
Model: 9700
OS: X 10.6
PIN: Alt+Shift+H
Carrier: GLOBE
Posts: 3,760
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question Does the IMAP-BIS combo really work like this?

Please Login to Remove!

folks: after going through a lot of reading on the Gmail IMAP thread out here and after trying it for myself, i am just as confused as ever w/ IMAP+BIS - so please assist me.

given: i am on BIS (unfortunately, still on 2.0), and have successfully set up my IMAPworkemail; 20 mins after i successfully set it up (note: i got a confirmation email on the BB once i completed the process), all the emails that were sitting on my inbox probably at the time i was setting it up got pushed to my BB.. could well be just beginners luck.

well anyway now here's my question: real-time push does not seem to work on IMAP huh? does RIM have a KB article on this? i tried sending me emails to my IMAPworkmail from my other web-based email accts and at certain times, 5 emails get pushed, some 10, some a little less than 3. i think probably at the time that it did the poll and stuff, how many new messages it sees on the IMAP server are about the same emails that it pushes to my BB. am i making sense at all?
Offline  
Old 11-09-2007, 06:57 PM   #2 (permalink)
Latino Hasta La Muerte
 
Join Date: Jan 2005
Location: Denville, NJ.
Model: 7250
OS: 4.1
PIN: G!!!
Carrier: Verizon
Posts: 9,035
Post Thanks: 51
Thanked 304 Times in 292 Posts
Default

I didn't think it would work at all with BIS 2.0. Later versions (2.3, 2.4) were supposed to add this support, among other things.
Offline  
Old 11-10-2007, 04:08 PM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Oct 2005
Model: 8220
Carrier: WiFi hotspot
Posts: 1,009
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Everyone who uses BIS 2 is on BIS 2.4, there is no BIS 2.0 left.

Real-time push email is not supported for IMAP. Your choices are blackberry email address, GMail or Yahoo email addresses. These do have real-time push email to blackberry.
Offline  
Old 11-10-2007, 04:34 PM   #4 (permalink)
BBFAQ Sysop
 
ricpac's Avatar
 
Join Date: Oct 2007
Location: Philippines
Model: 9700
OS: X 10.6
PIN: Alt+Shift+H
Carrier: GLOBE
Posts: 3,760
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

yup, i totally agree; just figured i'm on BIS 2.4; and after reading a lot about IMAP and integration with BIS, i give up; i already have yahoo and gmail set up fine; it's just too bad my IMAP work mail does not have forwarding coz my only other option initially was to have emails forwarded to my blackberry address and set up filters on BIS from thereon.

thanks all
Offline  
Old 11-10-2007, 05:22 PM   #5 (permalink)
Talking BlackBerry Encyclopedia
 
tobyw's Avatar
 
Join Date: Feb 2007
Location: UK
Model: 8100
Carrier: T-Mobile UK
Posts: 278
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (BlackBerry8100/4.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/123)

Imap was realtime push for a while when RIM was experimenting with IMAP IDLE. This was canned because some servers didn't support idle and concurrent connections causing long delivery delays. Hopefully this is a feature that will make a return in the future though.
Offline  
Old 11-10-2007, 11:10 PM   #6 (permalink)
BBFAQ Sysop
 
ricpac's Avatar
 
Join Date: Oct 2007
Location: Philippines
Model: 9700
OS: X 10.6
PIN: Alt+Shift+H
Carrier: GLOBE
Posts: 3,760
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

my hopes are up now, thanks tobyw
Offline  
Old 11-11-2007, 06:58 AM   #7 (permalink)
Latino Hasta La Muerte
 
Join Date: Jan 2005
Location: Denville, NJ.
Model: 7250
OS: 4.1
PIN: G!!!
Carrier: Verizon
Posts: 9,035
Post Thanks: 51
Thanked 304 Times in 292 Posts
Default

I've been whining at Apple to make their .Mac email support the IDLE command, so far to no avail. But there's a growing number of us doing the whining so who knows? Maybe they'll break down and write it in. The key would be to get Steve Jobs to use a Blackberry. Freakin' iPhone.
Offline  
Old 11-11-2007, 10:06 AM   #8 (permalink)
Talking BlackBerry Encyclopedia
 
tobyw's Avatar
 
Join Date: Feb 2007
Location: UK
Model: 8100
Carrier: T-Mobile UK
Posts: 278
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by rambo47 View Post
I've been whining at Apple to make their .Mac email support the IDLE command, so far to no avail. But there's a growing number of us doing the whining so who knows? Maybe they'll break down and write it in. The key would be to get Steve Jobs to use a Blackberry. Freakin' iPhone.
Trouble is, as it stands, even IMAP servers supporting IDLE and concurrent connections will not give instantaneous push e-mail as RIM pulled the support for this from BIS because of the potentially very long delays on non-compliant servers.
Offline  
Old 11-11-2007, 10:07 AM   #9 (permalink)
Talking BlackBerry Encyclopedia
 
tobyw's Avatar
 
Join Date: Feb 2007
Location: UK
Model: 8100
Carrier: T-Mobile UK
Posts: 278
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ricpac View Post
my hopes are up now, thanks tobyw
I wouldn't get too excited in the short term. Someone on another thread posted a link to the RIM KB article detailing features of BIS 2.5 and this isn't one of them... mind you, I don't think RIM advertised it when it was implemented a little while back, so perhaps it will make a re-appearance! We can hope though
Offline  
Old 11-11-2007, 10:16 AM   #10 (permalink)
CrackBerry Addict
 
DaBlackberryBoy's Avatar
 
Join Date: Jul 2006
Location: NUNYA
Model: 9850
PIN: URADUMAS
Carrier: Verizon
Posts: 669
Post Thanks: 0
Thanked 3 Times in 3 Posts
Default

I dont want to post complaints but I have TMo BIS with one GMail account in my BIS and one Yahoo SmallBiz account in my BIS, Yahoo coming through and GMail has not for the last two days in the good ol Land of Oz (Kansas). Anyone else experiencing no email being delivered? It is coming to my account via the web just not to my 8800...
__________________
DaBlackberryBoy
-- http://wardsmitchelljr.com --
Offline  
Old 11-11-2007, 11:07 AM   #11 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by DaBlackberryBoy View Post
I dont want to post complaints but I have TMo BIS with one GMail account in my BIS and one Yahoo SmallBiz account in my BIS, Yahoo coming through and GMail has not for the last two days in the good ol Land of Oz (Kansas). Anyone else experiencing no email being delivered? It is coming to my account via the web just not to my 8800...
Some slight delays with Gmail and google hosted domains but working on my BB.
Offline  
Old 11-11-2007, 11:32 AM   #12 (permalink)
BlackBerry Master
 
djm2's Avatar
 
Join Date: Jul 2007
Model: 9780
PIN: N/A
Carrier: T-Mobile
Posts: 4,637
Post Thanks: 29
Thanked 12 Times in 12 Posts
Default

Quote:
Originally Posted by DaBlackberryBoy View Post
I dont want to post complaints but I have TMo BIS with one GMail account in my BIS and one Yahoo SmallBiz account in my BIS, Yahoo coming through and GMail has not for the last two days in the good ol Land of Oz (Kansas). Anyone else experiencing no email being delivered? It is coming to my account via the web just not to my 8800...
Gmail seems fine here in MN.
Offline  
Old 11-11-2007, 04:51 PM   #13 (permalink)
BBFAQ Sysop
 
ricpac's Avatar
 
Join Date: Oct 2007
Location: Philippines
Model: 9700
OS: X 10.6
PIN: Alt+Shift+H
Carrier: GLOBE
Posts: 3,760
Post Thanks: 0
Thanked 0 Times in 0 Posts
Post

sent a quick note to my gmail and i don't think it's ever going to come through - it's been 5 mins since i clicked on send from the PC
Offline  
Old 11-11-2007, 04:54 PM   #14 (permalink)
BBFAQ Sysop
 
ricpac's Avatar
 
Join Date: Oct 2007
Location: Philippines
Model: 9700
OS: X 10.6
PIN: Alt+Shift+H
Carrier: GLOBE
Posts: 3,760
Post Thanks: 0
Thanked 0 Times in 0 Posts
Red face

Quote:
Originally Posted by tobyw View Post
I wouldn't get too excited in the short term. Someone on another thread posted a link to the RIM KB article detailing features of BIS 2.5 and this isn't one of them... mind you, I don't think RIM advertised it when it was implemented a little while back, so perhaps it will make a re-appearance! We can hope though
yes please, let's all hope; the reason why i got my BB was so i can get work email the soonest it touches our mailserver (w/o BES)
Offline  
Old 11-11-2007, 04:56 PM   #15 (permalink)
BBFAQ Sysop
 
ricpac's Avatar
 
Join Date: Oct 2007
Location: Philippines
Model: 9700
OS: X 10.6
PIN: Alt+Shift+H
Carrier: GLOBE
Posts: 3,760
Post Thanks: 0
Thanked 0 Times in 0 Posts
Post

gmail test message from PC: sent 6:45AM, received 6:53AM *8 mins; well at least it's working
Offline  
Old 11-11-2007, 05:09 PM   #16 (permalink)
BlackBerry Extraordinaire
 
Join Date: Oct 2005
Model: 8220
Carrier: WiFi hotspot
Posts: 1,009
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

GMail test message from office PC: sent 6:09PM received 6:09PM. Under 1 minute, more like under 30 seconds.

To exclude your PC and your ISP as the cause of delays, try sending email from blackberry, from your gmail address, to yourself at your gmail address.

Last edited by Berry One : 11-11-2007 at 05:11 PM.
Offline  
Old 11-12-2007, 04:31 AM   #17 (permalink)
BBFAQ Sysop
 
ricpac's Avatar
 
Join Date: Oct 2007
Location: Philippines
Model: 9700
OS: X 10.6
PIN: Alt+Shift+H
Carrier: GLOBE
Posts: 3,760
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question i think i'm confusing myself now

folks, when you reply to an email - you wouldn't be able to choose an address on the "send using" field, right? or is there something wrong with my 8320? a battery pull didn't fix it either; i also found out that you can only have control over the "send using" field when you forward a message. is this normal?

i figured this out yesterday when i set up replies-to an email sent from my IMAPworkemail to hit my @blackberry.net address for the push; set up IMAPworkemail on BIS to have "reply-to" to my @blackberry.net; sent an email to my boss with "send using" IMAPworkemail, boss replied to my @blackberry.net address (as expected) and when i replied to his email, i only found out a little later that t'was sent from my @blackberry.net address.

forwarding can surely fix this huh? because i can just set my incoming IMAPworkemails to forward to my @blackberry.net and reply from there; and i have to make sure that all replies from my @blackberry.net would have a reply-to showing my IMAPworkemail on the BIS setup page; that way, there shouldn't be any email directly pointing to my device address (save spam!)
Offline  
Old 11-12-2007, 04:51 PM   #18 (permalink)
BBFAQ Sysop
 
ricpac's Avatar
 
Join Date: Oct 2007
Location: Philippines
Model: 9700
OS: X 10.6
PIN: Alt+Shift+H
Carrier: GLOBE
Posts: 3,760
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

help?
Offline  
Old 11-14-2007, 08:11 PM   #19 (permalink)
Talking BlackBerry Encyclopedia
 
gameboy213's Avatar
 
Join Date: Oct 2007
Location: Los Angeles, CA
Model: 9630
OS: 4.7
PIN: N/A
Carrier: Sprint
Posts: 340
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Gmail is taking a long time for me as well.... and I am using Pop3 on it, as IMAP has had a ton of issues it seems.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.