BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-13-2005, 04:40 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2005
Model: 7510
Carrier: Nextel
Posts: 44
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Red light Blinks/Nothing on Screen

Please Login to Remove!

I have a BB 7510, my blackberry's red light blinks and there is nothing on the screen. The backlinght still turns on. Is it dead or what? I have restarted it, took out the battery but nothing helps. Any suggestions? Thanks in advance.
Offline  
Old 07-13-2005, 11:56 PM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2005
Location: Toronto, Canada
Model: 7510
Posts: 86
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

try charging it for a few hours, and then removing the battery for a minute
Offline  
Old 07-14-2005, 10:29 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2005
Model: 7510
Carrier: Nextel
Posts: 44
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you for the reply. Are you telling me to recharge the battery because you feel that my battery is dead or is it cause of another reason. Thanks
Offline  
Old 07-15-2005, 06:29 AM   #4 (permalink)
New Member
 
tomas's Avatar
 
Join Date: Jun 2005
Location: South Florida
Model: BOLD
OS: MS Vista
PIN: Ask me
Carrier: Cingular/AT&T
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This happen to my 7230, called tmo blackberry tech. An error 400 came up and they did not know how to fix it. So I got a replacement.
Offline  
Old 07-15-2005, 09:51 PM   #5 (permalink)
agr
Knows Where the Search Button Is
 
Join Date: Apr 2005
Posts: 19
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by dandamannyc
I have a BB 7510, my blackberry's red light blinks and there is nothing on the screen. The backlinght still turns on. Is it dead or what? I have restarted it, took out the battery but nothing helps. Any suggestions? Thanks in advance.
This happened to me when I attempted to install a software upgrade onto my 7520 unsuccessfully. The red light blinked constantly but the device did not turn on.

The solution for me was to connect the device to my computer and reinstall the operating system using the blackberry pc software (the same software used to backup/restore and install new apps onto your BB.) Even though my device didn't respond to human interaction, it did communicate with the computer. The computer's software detected that the device needed to have the OS reloaded and took care of that for me.

good luck
Offline  
Old 02-22-2006, 11:42 PM   #6 (permalink)
New Member
 
Join Date: Feb 2006
Model: 7520
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have the exact same problem with my 7520. 2 flashes and no action. i reinstalled the desktop software but its not ableto reinitialize the phone. it end the action and im stuck with nothing. im running out of ideas. got any?
Offline  
Old 02-22-2006, 11:43 PM   #7 (permalink)
New Member
 
Join Date: Feb 2006
Model: 7520
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 7520 blank

i have the exact same problem with my 7520. 2 flashes and no action. i reinstalled the desktop software but its not ableto reinitialize the phone. it end the action and im stuck with nothing. im running out of ideas. got any?
Offline  
Old 02-22-2006, 11:58 PM   #8 (permalink)
Thumbs Must Hurt
 
DanMan's Avatar
 
Join Date: Aug 2005
Location: Ottawa, ON Canada
Model: 8703e
PIN: 3015cb8b
Carrier: Telus Mobility
Posts: 134
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Have you tried installing the latest desktop software 4.1 and then downloading the 4.0 Handheld OS onto a different computer? Sometimes it might be as easy as trying a different USB port to get the unit to properly be recognized.
__________________
PIN:3015cb8b
Born of love...Betrayed by Fate!
Spawn
Telus Mobility
BB 8703e
Offline  
Old 02-23-2006, 01:39 AM   #9 (permalink)
New Member
 
Join Date: Feb 2006
Model: 7130e
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Same exact thing happened to mine!
Its crashed!
I had to get a replacement!
I guess it happens to a certain percentage of BB's
Offline  
Old 02-23-2006, 02:45 AM   #10 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2006
Location: LONG BEACH, CA
Model: 8350i
Carrier: ATT & Nextel
Posts: 195
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

If you have loaded the update..ensure you register your handheld via HRT in the Advance Options menu...happened to me to...and my chief...and my sgt...didn't need to get a new BB...
__________________
AL@N

7520.8700c.8310.8350i
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.