BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-28-2008, 09:01 PM   #1 (permalink)
BlackBerry Extraordinaire
 
Join Date: Oct 2007
Location: Los Angeles
Model: None
PIN: N/A
Carrier: ATT
Posts: 1,638
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default International sim in unlocked 8320 and can't send sms

Please Login to Remove!

Hope someone has figured out the solution for this.

I took my unlocked 8320 to Thailand and used a prepaid AIS sim card in it. Phone calls were fine but sending sms messages was a problem. Receiving worked just fine and it even identified the sender if I put the number without the country code in the address book. But sending worked just 1 time.

Cell numbers in Thailand have one extra digit in them, an 8 in the front. So dialing a landline number would be 0x-xxx-xxxx and a cell would be 08x-xxx-xxxx.

I had some numbers in my phone book with +66-8x-xxx-xxxx. Without the leading zero works for international texting and calling. On my Motorola Razr, it seems to handle sms just fine with the +66 in front or not.

On the 8320, I only got sms to work with the format 8x-xxx-xxxx, and just once at that. Surprisingly that was before I had tried changing the smart dialing settings. The reply came back as 08x-xxx-xxxx with the zero in front. Replying to that did not work and sending again a bunch of times without the zero did not work and nothing with +66 in front worked. After that, I tried changing smart dialing to +66 and number length to either 9 or 10 digits and again no luck.

Number formats I tried were:

08x-xxx-xxxx
8x-xxx-xxxx
+668x-xxx-xxxx
668x-xxx-xxxx

The error was something like "invalid protocol". After trying a bunch of different ways, I gave up, put the sim in my Razr and just used that.

I should note that AIS provides BB services there so the browser service books downloaded automatically. Of course no BB email, but I could use the web versions to check my emails. So that was a nice bonus. Having to use my Razr was disappointing since the browser is a lot worse and slower. I did carry the 8320 at times since open wifi is fairly easy to find.

Anyone know what settings should be changed?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.