BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-11-2008, 04:11 PM   #1 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: tmobile
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy randomly powering on and off

Please Login to Remove!

hey all. just a quick question... i have a blackberry 8320 from tmobile and with in the last week it started to power off randomly.. sometimes it does this while i am on a call, or trying to look up something.. when i try to power it back on it sits there and hour glasses then powers off again.. every once and a while it will stay on, but other times i have to plug it in.. when it does reboot it drains the battery.. what do you guys think. is it a battery issue or should i do a exchange on the phone.. i have only had it 6 months. blackberry message me...pin #241c12e7

Last edited by 1journie : 06-11-2008 at 04:12 PM.
Offline  
Old 06-11-2008, 04:14 PM   #2 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8700
PIN: N/A
Carrier: Vodafone
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

if you get to the bottom of this, please let me know as the exct same thing has been happening to me. i've had mine roughly 6 months too.
Offline  
Old 06-11-2008, 04:29 PM   #3 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: tmobile
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

i was told to wipe my phone and then back it up and download the updated software.which by the way took forever. it seem to be working fine, then it powered off again.. i am going to try a new battery next week when i get paid, hopefully that will work. i am glad to kno that i am not the only one with this issue
Offline  
Old 06-12-2008, 06:58 AM   #4 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8700
PIN: N/A
Carrier: Vodafone
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

any chance of an update when you get the new battery? i was thinking about doing the same but obviously if the problem persists i would rtaher save the expense.
Offline  
Old 06-12-2008, 04:55 PM   #5 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: tmobile
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

no problem on that one.. i called tmobile yesterday and ordered one. i should have it sometime next week.. its not doing it as much as it was.. but as i said when it powers off, i have to plug it in to restart most of the time, which tells me that the battery is pretty much fried.. i will let you kno
Offline  
Old 06-12-2008, 06:14 PM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2008
Model: 8330
PIN: N/A
Carrier: bell
Posts: 33
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

yeah, it smells to me like a battery issue. It would surprise me if it was a software/OS related...but what do i know...LOL
Offline  
Old 06-12-2008, 06:53 PM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2007
Model: 9700
Carrier: T-Mobile
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I was having the same issue for the past month and a half, and have had mine since it was released last September. After wiping and reinstalling, as well as changing the battery, the issue still persisted. I finally called T-Mo and they sent me a replacement. Just got the replacement a couple days ago, and so far so good.
Offline  
Old 06-13-2008, 05:45 AM   #8 (permalink)
Thumbs Must Hurt
 
ikasen's Avatar
 
Join Date: Jan 2007
Location: Las Vegas
Model: 8300
Carrier: AT&T
Posts: 158
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same problem. It was my battery. AT&T just gave me a new one for free as I only had the phone for 11 months and they said the warranty would cover it.
Offline  
Old 06-18-2008, 05:53 PM   #9 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: tmobile
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

well the verdict is back/. i got my replacement battery on \monday and fully charged it and have not had any other issues. what i suggest is contacting your carrier and ask to be transfered to the blackberry support and see if they can get you anew battery.. less stress there for me..
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.