BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-10-2005, 05:30 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Location: Frisco, TX
Model: 8830
Carrier: Sprint
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Missing Modules 6510/Nextel

Please Login to Remove!

I have installed IM+ & VeriChat with the same results. When I install the software it shows to be a successful install, when I try to launch the app on the blackberry I get the following error. "Error starting VeriChat: Module 'net_rim_bbapi_mailv2'

Then the application will not run.

Blackberry 6510/Nextel
Handheld Manager Version: 4.0.1.9
Desktop Manager Version : 4.0.1.10

I don't see the missing module on my handheld so I guess the question is where do I get the missing module from to make this thing work?

I use Exchange through an Enterprise Server and can access the internet via the NOL browser.

I searched the forums and couldn't figure it out, any help is appreciated.
Offline  
Old 08-10-2005, 05:55 PM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Jul 2005
Location: Canada
Model: 8700
Carrier: Rogers
Posts: 92
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

That module should be loaded on to the BB when you get it. I would recommend reinstalling the handheld software or upgrading to the latest one.
Offline  
Old 08-10-2005, 08:46 PM   #3 (permalink)
No longer Registered.
 
Dawg's Avatar
 
Join Date: Mar 2005
Location: Atlanta
Model: 8330
OS: 4.5.0.138
PIN: 31a6c9c9
Carrier: Verizon BIS
Posts: 13,963
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I bet it has to do with the latest OS download thats not available for the 6510
Offline  
Old 08-11-2005, 09:24 AM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Location: Frisco, TX
Model: 8830
Carrier: Sprint
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've had my BB for a couple of years and I believe the version that came on it was something like 2.6. So I upgraded to 4.0 yesterday and now am about to install 3.7. Once I have 3.7 on it maybe the file will exist, then maybe try 4.0 again.. I dunno. What's the best way to do the installs? Anything need to be removed prior to?
Offline  
Old 08-11-2005, 09:35 AM   #5 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,798
Post Thanks: 33
Thanked 441 Times in 381 Posts
Default

Download and install the latest handheld OS from Nextel
Execute the downloaded file
Locate and delete "Vendor.XML" from the C: drive; it will ensure that the new firmware is loaded
Connect the BB and start Desktop Manager. The upgrade process will backup the data, wipe the device, load the Java OS, load the applications, restart the BB, and reload the data backed up earlier.

That's about it!
Offline  
Old 08-11-2005, 10:03 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Location: Frisco, TX
Model: 8830
Carrier: Sprint
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks for the info.. didn't look like my missing module made it in version 3.7, i'm reinstalling 4.0 atm. I doubt this is going to work, is there a way to load individual .cod files to the bb?
Offline  
Old 08-11-2005, 10:25 AM   #7 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,798
Post Thanks: 33
Thanked 441 Times in 381 Posts
Default

Yes, but I don't think that's a good idea.

Better to find out why the module is missing.
Offline  
Old 08-11-2005, 10:32 AM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Location: Frisco, TX
Model: 8830
Carrier: Sprint
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

well, just tried this

javaloader.exe -usb load missingmodule.cod

it loaded it, now will it even start...

:->
Offline  
Old 08-11-2005, 10:41 AM   #9 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Location: Frisco, TX
Model: 8830
Carrier: Sprint
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

restarted, but now adding more missing modules... looks like none of the net_rim_bbapi modules were installed
Offline  
Old 08-11-2005, 10:54 AM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Location: Frisco, TX
Model: 8830
Carrier: Sprint
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

sweet, works now.. verichat does anyway.
Offline  
Old 08-11-2005, 11:04 AM   #11 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Location: Frisco, TX
Model: 8830
Carrier: Sprint
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well now If I use the Application Loader it wants to remove the API library... Any ideas why it wouldn't want the library on there? Could it be a corporate policy that my company uses?
Offline  
Old 08-11-2005, 03:27 PM   #12 (permalink)
No longer Registered.
 
Dawg's Avatar
 
Join Date: Mar 2005
Location: Atlanta
Model: 8330
OS: 4.5.0.138
PIN: 31a6c9c9
Carrier: Verizon BIS
Posts: 13,963
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

could very well be
Offline  
Old 08-11-2005, 08:22 PM   #13 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Location: Frisco, TX
Model: 8830
Carrier: Sprint
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

oh well, I was able to get everything working so no big deal.. actually learned a little bit about my blackberry. Pain though that when I use the app loader for anything I gotta reinstall the library manually.

thanks for the info
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.