BlackBerry Forums Support Community
              

Closed Thread
 
LinkBack Thread Tools
Old 09-02-2008, 01:38 PM   #41 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please Login to Remove!

I set the Sent Items label on my gmail mailbox and sent items from the BB get stored there - good. For those sent emails when replied to and deleted on the BB will stay stored there.

However emails not sent by the BB which are deleted on the BB only show up in All Mail. I haven't found the right label to create yet (thought Deleted Items would work). Anyone have a work around?
Offline  
Old 09-02-2008, 01:58 PM   #42 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Berrymedic20 View Post
Same here! Definitely not instantaneous, but definitely fast enough - I'm also getting like 20-30 seconds, with the occasional 1 or 2 minutes, with read status matching up. Fine by me!
Well my occasional email delays are up to 15 minutes..... maybe just IMAP-BIS growing pains.
Offline  
Old 09-02-2008, 11:01 PM   #43 (permalink)
Thumbs Must Hurt
 
Join Date: Jul 2008
Model: 8330
OS: 4.5.0.77
PIN: ch me, I must be dreaming
Carrier: Verizon
Posts: 157
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by whsbuss View Post
I set the Sent Items label on my gmail mailbox and sent items from the BB get stored there - good. For those sent emails when replied to and deleted on the BB will stay stored there.

However emails not sent by the BB which are deleted on the BB only show up in All Mail. I haven't found the right label to create yet (thought Deleted Items would work). Anyone have a work around?
When you delete a message from Gmail using IMAP, you're effectively removing the "Inbox" label from the message - you're archiving it. I don't think there is a way to actually delete messages on the server from the BB mail client when you're using a Gmail mailbox. That's the reason I went back to POP3 from IMAP - deleting from the handheld doesn't do what I want it to.

Edit - check the following thread: http://www.blackberryforums.com/gene...ml#post1084444
They may have a solution for you after all.

Last edited by UncleMike : 09-02-2008 at 11:13 PM.
Offline  
Old 09-03-2008, 06:16 AM   #44 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2007
Model: 8800
PIN: N/A
Carrier: AT&T
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Has anyone been able to confirm what's going on here? Is it a slow roll out of Imap Idle support? I still have not seen any new behavior on my phone. My server definetly supports imap idle w/ concurrent connections.
Offline  
Old 09-03-2008, 07:10 AM   #45 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Model: 9630
Carrier: Verizon
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I haven't been able to confirm anything yet, but a second Blackberry started to use IMAP idle on our server last night. This one is on T-mobile. (The first is on Verizon). The BIS server connects from a different IP on each Blackberry. Is it possible RIM is rolling out to their BIS servers slowly? We have made no changes to the BIS configuarations or our mail server. Imap idle started sponataneously.
Offline  
Old 09-03-2008, 07:44 AM   #46 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by dharari View Post
I haven't been able to confirm anything yet, but a second Blackberry started to use IMAP idle on our server last night. This one is on T-mobile. (The first is on Verizon). The BIS server connects from a different IP on each Blackberry. Is it possible RIM is rolling out to their BIS servers slowly? We have made no changes to the BIS configuarations or our mail server. Imap idle started sponataneously.
It seems like RIM is rolling out IMAP-IDLE support piece-meal. About 85% of the time my gmail IMAP email is delivered in almost realtime (within 30 sec). Then other times it takes a full 15 minutes. I've decided to go back to POP until IMAP-IDLE is 100% on their BIS servers.
Offline  
Old 09-03-2008, 07:47 AM   #47 (permalink)
GXX
Thumbs Must Hurt
 
Join Date: Jun 2007
Location: Metro NY
Model: 8330
OS: 4.5.0.131
Carrier: VZW
Posts: 87
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

When a server supports IMAP IDLE, it doesn't always mean you will get it instantly. There is still server processing, network traffic, etc. I've seen Gmail's servers process email slower at certain times, while other times it flies.

AFAIK, IMAP IDLE is working perfectly on my servers running Exim/Dovecot.
Offline  
Old 09-03-2008, 07:56 AM   #48 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by GXX View Post
When a server supports IMAP IDLE, it doesn't always mean you will get it instantly. There is still server processing, network traffic, etc. I've seen Gmail's servers process email slower at certain times, while other times it flies.

AFAIK, IMAP IDLE is working perfectly on my servers running Exim/Dovecot.
You make a good point. However when I am experiencing gmail IMAP delays for push, my outlook 2007 is following the gmail inbox (configured as IMAP) almost instantaneously. So I still think the BIS servers may play a part in partial push delays - IMO.
Offline  
Old 09-03-2008, 02:15 PM   #49 (permalink)
Thumbs Must Hurt
 
shampoo's Avatar
 
Join Date: Feb 2008
Location: Montreal Quebec
Model: 8330
Carrier: Telus
Posts: 112
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is Google still instant on IMAP for everyone ? Mine appears to have stopped as of 15:00 EST.

J
Offline  
Old 09-04-2008, 09:38 AM   #50 (permalink)
Talking BlackBerry Encyclopedia
 
funkyp56's Avatar
 
Join Date: Dec 2006
Model: iPhon
OS: 3.1.2
PIN: iPhones have no PIN
Carrier: AT&T
Posts: 257
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

works for me! gmail.com mac.com and me.com all work
__________________
BES 5.0.0.137 w/30 Users
Network Admin
Offline  
Old 09-04-2008, 02:15 PM   #51 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by shampoo View Post
Is Google still instant on IMAP for everyone ? Mine appears to have stopped as of 15:00 EST.

J
I tried using IMAP again for one of my gmail accounts and push is not working.
Offline  
Old 09-04-2008, 03:08 PM   #52 (permalink)
Thumbs Must Hurt
 
Join Date: Aug 2007
Model: 9530
OS: 4.7.0.148
PIN: N/A
Carrier: VZW
Posts: 119
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I figured out my imap email never getting to blackberry issue. I had most emails auto-labeled and set to skip the inbox. Didn't realized gmail uses them as actual folders since it doesnt with pop3. Also, i still have the 15-minute polling behavior on my gmail.
Offline  
Old 09-04-2008, 03:48 PM   #53 (permalink)
New Member
 
Join Date: May 2007
Model: 8330
PIN: N/A
Carrier: alltel
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No push of IMAP for me on Google Apps account and Alltel BIS.
Offline  
Old 09-04-2008, 05:01 PM   #54 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by cgfj View Post
No push of IMAP for me on Google Apps account and Alltel BIS.
And now my gmail IMAP is doing push again on VZW BIS. I guess we need to wait for RIM to officially announce IMAP push before we jump in with both feet.
Offline  
Old 09-04-2008, 06:55 PM   #55 (permalink)
BlackBerry Extraordinaire
 
Join Date: Oct 2005
Model: 8220
Carrier: WiFi hotspot
Posts: 1,009
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anyone other than GMail users? IMAP for GMail is not officially supported by RIM, your mileage may vary and results will differ. By extension, it applies to IMAP IDLE for GMail.
Offline  
Old 09-04-2008, 07:17 PM   #56 (permalink)
BBF Moderator
 
rachamphetamine's Avatar
 
Join Date: Mar 2008
Model: --
PIN: E SOL
Carrier: VZW
Posts: 3,117
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No IMAP idle on my school email account. Crossing my fingers that it'll show up someday soon.
Offline  
Old 09-04-2008, 07:44 PM   #57 (permalink)
BBF Moderator
 
akosnitzky's Avatar
 
Join Date: Jul 2005
Location: Southern Florida
Model: 9650
OS: 6.0.0.333
Carrier: Verizon BIS
Posts: 14,484
Post Thanks: 6
Thanked 7 Times in 7 Posts
Default

I am still seeing the normal 10 to 15 min delay. Is there something i need to do?
__________________
------
Follow @akosnitzky on Twitter

LET'S GO CANES!
Offline  
Old 09-04-2008, 10:13 PM   #58 (permalink)
Talking BlackBerry Encyclopedia
 
GrandMstrBud's Avatar
 
Join Date: Jul 2008
Model: 9780
PIN: 2075BBB4
Carrier: Carrier
Posts: 263
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by Berry One View Post
So not. For example, IDLE support may be disabled by IMAP mail server administrator.
How do I find out if our exchange server supports IMAP idle?

Last edited by GrandMstrBud : 09-04-2008 at 10:46 PM.
Offline  
Old 09-05-2008, 08:31 AM   #59 (permalink)
Talking BlackBerry Encyclopedia
 
AlexKidd's Avatar
 
Join Date: Apr 2007
Location: Louisville, KY
Model: 8300
PIN: N/A
Carrier: ▪T▪▪▪Mobile▪
Posts: 262
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've been a very long-time T-Mobile customer with BIS service. My server is Microsoft Exchange Server 2003 SP2 and am 100% sure it supports IMAP IDLE since I tested it by manually connecting with TELNET. I am not getting IMAP IDLE connections from BIS servers. I'm remote connected to the Exchange server and looking at IMAP logs and current network connections over "netstat" and nothing from RIM other than the standard 15-minute polling.

I logged into T-Mobile BIS, deleted my account and recreated the mailbox. Same thing.

I believe those users seeing their "about 2 minute" deliveries are just seeing the typical 15-minute poll with incremental ~4-minute poll as BIS's IMAP servers have always encountered.

--Kidd
__________________
"Jesus looked at them and said, "With man this is impossible, but not with God; all things are possible with God" (Mark 10:27)."
Offline  
Old 09-05-2008, 08:46 AM   #60 (permalink)
iPhone Mod!
 
zerog46's Avatar
 
Join Date: May 2007
Location: In a House
Model: 9650
Carrier: VZW Bold
Posts: 6,775
Post Thanks: 26
Thanked 10 Times in 10 Posts
Default

Same here I have tried this numerous times, and have not gotten anything close to instant delivery. I am just going to stick with the POP3.
__________________
Life is not holding a good hand. Life is playing a poor hand well.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Allen Bradley 1746-NT4 SLC 500 Thermocouple Input Module
$295.0
Allen Bradley 1746-NT4 SLC 500 Thermocouple Input Module pictureComark C28KIT Thermometer w/Probe Waterproof Thermocouple Digital
$89.1
Comark C28KIT Thermometer w/Probe Waterproof Thermocouple Digital pictureWatlow 23CJFUH060A G487788 0941 Thermocouple New (TB)
$39.99
Watlow 23CJFUH060A G487788 0941 Thermocouple New (TB) pictureWhite Rodgers H06E-36 Thermocouple 36" New Gas Pilot Light Control Emerson
$6.49
White Rodgers H06E-36 Thermocouple   36Thermocouple Meter Temperature Measurement Thermocouple Probe
$89.99
Thermocouple Meter Temperature Measurement  Thermocouple Probe picture






Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.