BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-16-2008, 09:34 AM   #1 (permalink)
rm3
New Member
 
Join Date: Sep 2008
Model: 8320
OS: v8.2.2
PIN: N/A
Carrier: T-Mobile
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 2 new Curves from T-Mobile but each is different

Please Login to Remove!

I purchased a Curve from T-Mobile a few weeks ago and love it. Even after dropping it in water it still works fine. We bought another one for my wife yesterday. The software version is the same on both 4.2.2.180 but there are lots of differences between the 2 units.

The first problem I noticed is that the new one only gives me 2 options for a web browser (T-Zones or Wi-Fi Browser) while the original one gives 3. The 2 I mentioned plus Internet Browser. I can only get the browser to work when I am near a Wi-Fi spot even though the phone says EDGE in capitals.

When I am near a Wi-Fi spot I can not get some of the web sites on the new BB that I can get on the original one.

Also, the original one gives me many more selections when I select Bookmarks. There is one called "Links" that includes links to CNN, Accuweather, ESPN and a few others as well as a setup option for Handango and Facebook. The original has something called WAP Bookmarks and the newer one does not.

When I select Maps on the new one I just get the green diagonal lines but the original shows me a map. There are more differences but these are the most obvious ones so far.

I will go back to the T-Mobile store but thought I would check here first as the advice is usually better here.

Thanks!

rm3
Offline  
Old 09-16-2008, 09:41 AM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Dec 2007
Model: 8830
OS: 4.5.0.101
PIN: N/A
Carrier: Sprint
Posts: 293
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do you have a blackberry plan on the second device? If you do, try to register the device (Options -> Advance Options -> Host Routing Table, there press the menu key and select Register Now)

Regards
Offline  
Old 09-16-2008, 09:42 AM   #3 (permalink)
Thumbs Must Hurt
 
moleman2k's Avatar
 
Join Date: Jul 2006
Location: Out East
Model: 9700
OS: 5.0
PIN: t of BEER!!!
Carrier: Telus
Posts: 148
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sounds like they didn't add a data plan to the new one. Call T-mobile and get a data plan added.
__________________
Moleman2k
BlackBerry Certified System Administrator (5.0)

(7290 -> 8700 -> 8120 -> 8310, with Robbers) -> (8130 -> 9530 -> 9700 w/ Telus)
Offline  
Old 09-16-2008, 09:59 AM   #4 (permalink)
BBF Moderator
 
rachamphetamine's Avatar
 
Join Date: Mar 2008
Model: --
PIN: E SOL
Carrier: VZW
Posts: 3,117
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by moleman2k View Post
Call T-mobile and get a data plan added.
Agreed, or log into My T-Mobile and add the plan there on her line.
Offline  
Old 09-16-2008, 02:13 PM   #5 (permalink)
rm3
New Member
 
Join Date: Sep 2008
Model: 8320
OS: v8.2.2
PIN: N/A
Carrier: T-Mobile
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the quick replies! I had a message from T-Mobile shortly after I turned on the phone and it said it was registered with the network but I still had the same issues. I was finally able to talk to BB support at T-Mobile and they said something about Service Books (?). They had me go to "Options" ;"Advanced Options";"Host Routing Table"; select Menu; Select "Register Now" and after a few minutes everything was just like my other BB.

Just like "jjmach" said!

rm3

Last edited by rm3 : 09-16-2008 at 02:14 PM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.