BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   General BlackBerry Discussion (http://www.blackberryforums.com/general-blackberry-discussion/)
-   -   BB Battery will not take a charge (http://www.blackberryforums.com/general-blackberry-discussion/15434-bb-battery-will-not-take-charge.html)

vinniet 09-15-2005 08:36 AM

BB Battery will not take a charge
 
Ok something strange here. My BB 7230 battery seems to not be able to take a charge. I woke up today and my BB was dead. When I plugged it in it came on but after being on for a hour it still says low battery. If I remove the USB connection it stays on which means it has some battery.

I also removed the battery and looked at the contacts and also re-seated the SIM card.

Can anyone think of anything else? I have never seen a batter die so quickly, there was no indications there was problems with the battery.

Thanks!

Workingmen 09-15-2005 08:46 AM

It may be a problem with the charger also.

Are you using a Blackberry charger and cable? Does the little electic bolt next to the battery charge level display come on and stay on when you plug in the charger?

I have tried several USB chargers (Car chargers and wall chargers with USB output) that are not capable of putting out enough amps and the charging signal would come on and go off after about 1 to 30 seconds.

kelvin 09-15-2005 09:06 AM

You may need to try different plugs and chargers. I used to be able to plug into my laptop and it would charge via USB. SInce they upgraded my laptop, this does not work. I use a wall plug now.

vinniet 09-15-2005 09:24 AM

Thanks everyone. I do have the lightning bolt so I know its taking a charge. It might be the PC but I have been doing this for year with the same PC and cable.

Actually after 1.5 hours I have one tick os its working but very slowly.

Do you think this indicates a bad battery. The battery still lasts about a week on a charge as when I got it.

VR6 09-15-2005 02:55 PM

make sure you have the drivers installed

c-taylor89 09-20-2006 11:06 AM

I have this exact same problem and it came outta no where. It isnt the battery becasue I put my battery in my dads 7290 and it charged up fine and held it.
someone please helP!

woody16.2 09-20-2006 01:39 PM

I had the same problem with a 7520. It is a hardware problem. If you take it to an authorized dealer they should replace the unit for $35.00.

Aroc 09-20-2006 09:44 PM

I had the same problem with a Nextel 7510. Any battery I put in it would either die immediately or within 20 minutes. It did this for two regular batteries (one of which was brand new) and an extended battery that I borrowed. All three batteries held an all day charge when used in a Cingular 7290 or a Nextel 7520.

I ended up swapping the 7510 for a 7520, since it was work provided (then later a cingular 8700c a month later).

Good luck. Maybe try the solution woody suggested?


All times are GMT -5. The time now is 07:05 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.