BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-22-2008, 06:58 PM   #1 (permalink)
New Member
 
Join Date: Nov 2008
Model: 8700c
PIN: N/A
Carrier: cingular
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BB 8700c SIM problems

Please Login to Remove!

Today I recieved the 8700c that I ordered off of ebay. I know the risk involved but don't have the money to buy a brand new phone and just wanted a phone with the keyboard/no camera and organizer/somewhat sorta all in one in a way.

Well the phone has no issues except maybe a little cosmetic wear. The phone was tested and works (supposedly) and is guaranteed or else I can return it.

Well so I open the package up, and stick my sim in, and just like any other cingular phone, I expected it to work. It didn't. It says Please Insert SIM, and the signal bar says SOS.

It did this same thing with my ex husband sim, when he gave me his sim to try and his is close to new. I went to the ATT/Cingular store. The sales woman, she tried out two sims (one that the store uses to test phone with) and her's.

All times is said please insert SIM. Now does this sound like more of an issue with the phone and I need to return it?

Right now its plugged in and right after I plugged it in to finish charging, I got 5 bars of service, got excited and it dropped and went back to SOS.

I have done a complete swipe, and have also tried unlocking the phone with the code I got from cingular this afternoon. It didn't work. Its still locked by ATT/Cingular. I was trying the unlock just to make sure it wasn't that issue.

Any ideas anyone??? Should I just return the phone and save the headache?
Offline  
Old 11-22-2008, 09:22 PM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,036
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

Return it
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 11-23-2008, 08:11 AM   #3 (permalink)
New Member
 
Join Date: Nov 2008
Model: 8700c
PIN: N/A
Carrier: cingular
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I forgot to note, I don't know if this makes a difference.

In the SIM Card screen/Main Screen:

only reason I am trying to make this work, is I drive across country in three days and need a reliable phone. My current phone dies randomly.

(I can't post pictures. )

So is there a way to enable the SIM function and Network Subset/Provider which are both disabled.

I am assuming the reason its not registering a SIM card is because the SIM function is disable.
Offline  
Old 11-23-2008, 08:39 AM   #4 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,036
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

I think you just answered your own question. You need a reliable phone. This one obviously is not. My advice is to spend the money and buy a phone at ATT if reliability is your biggest concern.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.