BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-13-2009, 03:24 PM   #1 (permalink)
Thumbs Must Hurt
 
shampoo's Avatar
 
Join Date: Feb 2008
Location: Montreal Quebec
Model: 8330
Carrier: Telus
Posts: 112
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Formatting of Plain Text Emails

Please Login to Remove!

Hi,

I have curve 8330 running 4.5 and I have a question regarding how Blackberry handles plain text emails.

The problem I am having is the formatting of plain text emails is horrible. Words wrap in all the wrong places. I did some digging and the problem is that mail clients that send me mail, soft line break at about 72 chars. This follows the RFC on email.

Because of the width of the screen, the Blackberry will have to soft line break itself at about 40 or so characters . The problem is that the Berry should not break on those softbreaks left by the MUA at 72 chars. It should realize that the line has already been wrapped to fit its screen and skip the line feed left by the original MUA (mail client) at 72 characters.

The end result is I get emails that look like:

This is a test of the emergency broadcast
system alarm. In the event
of an actual alarm, polce will be dispatched
to settle a score..

Note the second line. "Of an" should have made that line. But because the sender's MUA threw in a soft line feed (and you can see it if you view the entire source of the mail the line ends with a "=20", it breaks again at 72 chars when really, it shouldn't. It wrapped at 40. There is now a newline. The counter starts at 0. But it doesn't in this case and it line wraps again at about 32 (40+32 = 72).

It's even worse when quoting characters ">" are used. A complete mess ensuses.

My blackberry seems to refuse to follow the format=flow mime type: http://www.ietf.org/rfc/rfc2646.txt This mimetype was designed for devices who's screen width's are less then 72 characters.

So what exactly is the problem ? Why is my Blackberry not formatting text paragraphs correctly ? Is it ignoring the format=flow mime type ? Are the sending client's at fault ?

Thanks

J

Last edited by shampoo : 02-13-2009 at 03:30 PM.
Offline  
Old 03-09-2009, 07:52 PM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Aug 2005
Location: Denver, CO
Model: 9930
Carrier: Sprint
Posts: 78
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

I have similar issues, but slightly different: My emails go out like this:

This is a test of the emergency broadcast system alarm. In the event of an actual alarm, police will be dispatched to settle a score..

Even when I hit return in my emails, they don't show up in the receivers email...

Any ideas?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.