BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-20-2009, 11:40 PM   #1 (permalink)
adz
New Member
 
Join Date: Mar 2009
Model: 7520
PIN: N/A
Carrier: Nextel
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BlackBerry 7520 507 Error -Tried Everything....

Please Login to Remove!

BlackBerry
This is exactly what I tried so far:

1) Installed Desktop Manager 4.7 from the Blackberry Website
2) Installed OS version 4.1.0.534 from the "Software Download for Nextel Communications Inc." download page for the 7520
3) Connected BB to computer. It shows the hourglass for around 5-6 seconds, and gives a 507 error.
4) I went to update. It asked me for the password, which I entered.
5) It asked which software to install. I just chose BB 3.1 System Software, Core apps and phone (version 4.1).
6) Connection to ROM (almost instantaneous, Erasing Applications (around 20 secs), Loading system software (around 20 secs), Waiting for device initialization (15 secs), the 507 error appears, uploading RAM image, connection to boot ROM (hangs for around 10 seconds)

And I get an error "A fatal error has occurred while updating your device's software. Please try again"

OK...so I tried to use Jl_Cmdr 1.9.1.
1) Press the key to continue
2) Y my bb has a password, entered password
3) Pressed 4 for wipe. Y I want to continue, typed blackberry. 1 second later goes back to that screen. 507.
4) Tried the Update again. Same exact thing happened as above.

Then I tried this on my other comp (my current one runs windows 7, the other runs xp). Same thing happened...Tried doing that fix....disabled power off on all the hubs

1. On your computer, click Start > Settings > Control Panel.
2. In the Control Panel, double-click the System icon. The System Properties window opens.
3. Click the Hardware tab of the System Properties and click Device Manager.
4. In the Device Manager, double-click Universal Serial Bus Controllers.
5. Right-click the first USB root hub, and click Properties.
6. In the Properties window, click the Power Management tab.
7. Clear the Allow the computer to turn off this device to save power check box.
8. Repeat for all other USB root hubs.
9. Restart your computer.


After that I went into C:\Program Files\Common Files\Research In Motion\AppLoader and did:

loader.exe /nojvm

went through the screens...and I noticed a few things:
1) Where it said "Blackberry 4.1 System Software" the action was UPDATE
2) Even though I just selected the bare minimum (phone, system software, core apps) it gave an error "This device does not have sufficient storage..."
3) Tried doing loader.exe (without /nojvm). It did the same thing as with the desktop manager...but now gave an error "

Unable to communicate with the radio hardware. Please ensure that a charged battery is installed in the device and try the loading operation again. [P:0x0000000F]"

Interesting huh...

So what do you recommend I do?
Offline  
Old 03-21-2009, 08:42 AM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,020
Post Thanks: 54
Thanked 778 Times in 740 Posts
Default

Error 507 is no OS, I think. Try to wipe the device using Jl_cmdr (see the FAQ for more info). Then use DM 4.2 SP2/SP3 rather than DM 4.7 Make sure you are downloading and installing a 7520 OS and delete the vendor.xml file before you install it.

And be patient as it runs. Could take an hour or longer.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 03-21-2009, 11:55 AM   #3 (permalink)
adz
New Member
 
Join Date: Mar 2009
Model: 7520
PIN: N/A
Carrier: Nextel
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks for the quick response

This is what I did (on my Windows 7 Comp):
1) Uninstalled old Desktop Manager and Device software
2) Restarted
3) Downloaded and installed Desktop Software v4.2 SP2 without Media Manager (English) from the website (this btw took a CONSIDERABLY longer time than it did before...don't know whether that plays a role in anything)
4) Downloaded and Installed BlackBerry Handheld Software v4.1.0.534
5) Used Jl_Loader to wipe the blackberry (which btw took <2 seconds :( + around a 10 second restart...)
6) Deleted Vendor.xml from C:\Program Files\Common Files\Research In Motion\AppLoader
7) Used Application Loader Wizard to update the blackberry (read radio software configuration took around 20 seconds, selected only the default components, erasing applications around 15, loading system software around 10, waiting for device initialization around to (507 screen...), connecting to boot ROM (around 10) )
8) error: Unable to communicate with the radio hardware. Please ensure that a charged battery is installed in the device and try the loading operation again. [P:0x0000000F]

so I went on my xp comp...
Followed exact same procedure...and minus the 20 second reading radio software config it went exactly the same way...

Then (only on the XP Computer):
1) uninstalled BlackBerry Handheld Software v4.1.0.534 and Desktop Software v4.2 SP2 without Media Manager (English)
2) Decided to give it one last shot and installed Desktop Manager 4.5.0 B17 Multilanguage - Without Media Manager
4) Asked me to restart, so I restarted
4) Installed BlackBerry Handheld Software v4.1.0.534
5) Wiped using Jl_Loader (again took < 2 seconds....)
6) Deleted C:\Program Files\Common Files\Research In Motion\AppLoader\Vendor.xml
7) Followed the same exact procedure and before (same exact timing, screens and whatnot showed) aaand fatal error

Well I am completely out of ideas
Offline  
Old 03-21-2009, 12:12 PM   #4 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,020
Post Thanks: 54
Thanked 778 Times in 740 Posts
Default

First of all, don't use Windows 7. That is still in beta and is most likely part of your problem.

Is the OS you are trying to install an OS for the 7520 and did you delete the vendor.xml file after installing it on your PC?
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 03-21-2009, 04:11 PM   #5 (permalink)
adz
New Member
 
Join Date: Mar 2009
Model: 7520
PIN: N/A
Carrier: Nextel
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

tried it on xp and yes I did delete vendor.xml
Offline  
Old 03-25-2009, 07:46 PM   #6 (permalink)
adz
New Member
 
Join Date: Mar 2009
Model: 7520
PIN: N/A
Carrier: Nextel
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

any other ideas?
Offline  
Old 03-27-2009, 01:20 PM   #7 (permalink)
BlackBerry Extraordinaire
 
Join Date: Jan 2005
Model: Many
Carrier: Sprint
Posts: 1,475
Post Thanks: 0
Thanked 6 Times in 5 Posts
Default

upgrade to the 8350i
Offline  
Old 03-27-2009, 01:37 PM   #8 (permalink)
BlackBerry B Boy
 
jeremyckitching's Avatar
 
Join Date: Apr 2007
Model: 9700
OS: 5.0.0.415
PIN: 215BE1F8
Carrier: T-Mobile U.S.A.
Posts: 4,243
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by southwestcomm View Post
upgrade to the 8350i


Even though it isn't a resolution, I think this is a good recommendation. It looks as though you have tried almost everything.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.