BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-13-2009, 06:53 AM   #1 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8820
PIN: N/A
Carrier: OneCall
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation HELP ME! My BlackBerry won't read my sim card!

Please Login to Remove!

I bought a nearly not used BB 8820 in mint condition some time ago, and since I use a Mac, I don't get to update the device.

I had the software version 4.22, but wanted to upgrade to 4.5. So I connected it to Windows, trough vmware fusion on my Mac, and updated to 4.5.

After the 4.5 update, the BB won't read my sim card! I tried various things, as downgrading as far as I could (to an earlier version of 4.5), but that didn't work out. I could only get the SOS signal, and the phone does NOT ask for PIN code. I have tried various sim cards, also from different carriers than mine.

I was scared that it might had become locked, but when I went to Settings, and then Sim Card, typed MEPD, everything was "Deactivated". So it's not locked, right?

I'm living in Norway, and using an Norwegian carrier.

Hope you guys can help me out!

Last edited by superslurt : 06-13-2009 at 06:54 AM.
Offline  
Old 06-13-2009, 08:08 AM   #2 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Wirelessly posted (9530; (I'm mobile) MF231; 35h)

Are you positive that you are placing the SIM card in corectly?

An upgrade would not disable the SIM. Try a new SIM.

Last edited by JSanders : 06-13-2009 at 08:10 AM.
Offline  
Old 06-13-2009, 08:46 AM   #3 (permalink)
BlackBerry Master
 
dankarlinski's Avatar
 
Join Date: May 2007
Model: 1
Carrier: 1
Posts: 3,391
Post Thanks: 1
Thanked 2 Times in 2 Posts
Default

Wirelessly posted (My Bold)

Yes. Check to make sure it is in properly. The sim reading is done on the ROM level which is not touched when upgraded. This is very weird
Offline  
Old 06-13-2009, 09:20 AM   #4 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8820
PIN: N/A
Carrier: OneCall
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah, I know it's pretty weird.

I ordered a new sim card, but that didn't have any effect. I used one of my buddies sim card, but that didn't work either.

I've put it in both ways, just to be sure.

Thanks for replies guys! I was hoping there was an easy fix that I just couldn't figure out myself, but it sounds like it just might get a little tricky...

Last edited by superslurt : 06-13-2009 at 09:23 AM. Reason: spelling
Offline  
Old 06-13-2009, 03:56 PM   #5 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

try plugging it in
Offline  
Old 06-13-2009, 07:01 PM   #6 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8820
PIN: N/A
Carrier: OneCall
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Plug it into what? The computer? Nothing special happens.
Offline  
Old 06-16-2009, 11:17 AM   #7 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8820
PIN: N/A
Carrier: OneCall
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Not anybody who know what might fix this?
Offline  
Old 06-16-2009, 11:19 AM   #8 (permalink)
Stuck In The '70's Mod
 
ndub33's Avatar
 
Join Date: Feb 2006
Location: The 'burbs east of Seattle.
Model: 9810
Carrier: T-Mobile
Posts: 7,599
Post Thanks: 0
Thanked 4 Times in 4 Posts
Default

Have you tried the SIM in a different device? Good way to tell if the problem is the SIM or the BlackBerry.
__________________
1st Step in Troubleshooting: Do you have a BlackBerry Data Plan?
2nd Step in Troubleshooting: Pull the Battery.
Offline  
Old 06-16-2009, 11:33 AM   #9 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8820
PIN: N/A
Carrier: OneCall
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The sim works, it's entirely new, and works in all the phones I tested it with. But thanks for the try though
Offline  
Old 06-16-2009, 12:18 PM   #10 (permalink)
BlackBerry Extraordinaire
 
CO_BBTechie's Avatar
 
Join Date: Jul 2007
Location: Denver
Model: 8310
Carrier: AT&T
Posts: 2,044
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I wonder if the OP used an older beta OS that was blamed for "frying" sim cards? You might try to downgrade, or use a different 4.5 version. What version of 4.5 do you have now?
__________________
Treat your password like your toothbrush. Don't let anybody else use it, and get a new one every six months.
Clifford Stoll
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.