BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-20-2009, 06:18 AM   #1 (permalink)
New Member
 
Join Date: Aug 2009
Model: 9500
PIN: N/A
Carrier: Vodafone
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default issues with brand new storm

Please Login to Remove!

one of my buttons fell off on my old storm , i got a new one but when im trying to charge it through usb , ive just realised its working but theres no display on the screen. my phone just rang and i just recieved a message , but theres no display what so ever.

any ideas , i really need help.
Offline  
Old 08-20-2009, 06:43 AM   #2 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,911
Post Thanks: 59
Thanked 241 Times in 180 Posts
Default

the screen is black or what?
Offline  
Old 08-20-2009, 06:45 AM   #3 (permalink)
New Member
 
Join Date: Aug 2009
Model: 9500
PIN: N/A
Carrier: Vodafone
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

yeah , the screen is pure black , but the red at the top is flashing as in like a message.

it's weird.
Offline  
Old 08-20-2009, 07:17 AM   #4 (permalink)
Thumbs Must Hurt
 
btushar's Avatar
 
Join Date: Apr 2008
Location: India
Model: 9900
PIN: 27E9A046
Carrier: Vodafone
Posts: 61
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

have you tried battery pull?
__________________
Tushar
http://www.anjane.com - Blackberry PIN Exchange Service
Offline  
Old 08-20-2009, 07:34 AM   #5 (permalink)
New Member
 
Join Date: Aug 2009
Model: 9500
PIN: N/A
Carrier: Vodafone
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

yeah , its the first thing i tried.

the blackberry strom is a piece of crap.
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.