BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-30-2009, 11:43 PM   #1 (permalink)
New Member
 
Join Date: Dec 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem installing Blackberry App World on 8900 using OS v5.0.0.90-T-Mobile

Please Login to Remove!

I just got a replacement blackberry and started off fresh and downloaded OS v5.0.0.90 on my T-Mobile 8900 and the download installed fine except I having downloading some things like Blackberry App World, Bloomberg, Shazam and Google Voice. However no problem with ESPN or Worldmate. I get the error Uncaught exception: java.lang.ClassCastException and Error starting net_rim_bb_appworld: Class 'net.rim.device.api.ui.toolbar.ToolbarButton Field' not found.

When I reboot the phone I am getting the following errors:

uncaught exception: java.lang.illegalArgumentException
uncaught excetpion: java.lang.Error

When I updated the phone I deleted the vendor file and anything having to do with T-Mobile.

What am I doing wrong? I am so frustrated with this! Any help will be greatly appreciated.

Thanks

Offline  
Old 12-31-2009, 01:36 PM   #2 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: 10.010219
PIN: No Pin just a Tack
Carrier: at&t
Posts: 8,225
Post Thanks: 40
Thanked 570 Times in 565 Posts
Default

As reported by RIM. It may be that the APP is not compatible with the OS level or the APP download was corrupt

Uncaught exception: java.lang.ClassCastException

Clicking OK allows the BlackBerry smartphone to continue to function.

This is a previously reported issue that has been escalated internally to our development team. No resolution time frame is currently available
__________________
If someone helps, tell them by clicking the Thanks button


9810 BES
Z10 on BES
9700 BIS
Offline  
Old 01-01-2010, 11:46 AM   #3 (permalink)
New Member
 
Join Date: Dec 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by tsac View Post
As reported by RIM. It may be that the APP is not compatible with the OS level or the APP download was corrupt

Uncaught exception: java.lang.ClassCastException

Clicking OK allows the BlackBerry smartphone to continue to function.

This is a previously reported issue that has been escalated internally to our development team. No resolution time frame is currently available
Thanks for your reply. Would either upgrading or downgrading to a different version help? I really miss my apps.

Thank you
Offline  
Old 01-01-2010, 02:14 PM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2009
Location: SoCal
Model: 9700
OS: 5.0.0.423
PIN: N/A
Carrier: T-Mobile USA
Posts: 185
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Any reason you're using 5.0.0.90??? 5.0.0.411 has been leaked for the 8900 and is much more stable. I believe BB App World works on it too.
__________________
Personal: T-Mobile USA Bold 9700 | 5.0.0.423
Work: ATT Wireless Bold 9000 | 4.6.0.304
Past: 8900, 8830, 8700c, 7100t, 7520, 7230, 7750, 6750
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.