BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-13-2005, 01:18 PM   #1 (permalink)
New Member
 
Join Date: Dec 2005
Model: 7250
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default can't turn on

Please Login to Remove!

this past weekend my bb 7250 apparently got into a funk. after turning it off in the usual fashion, i am unable to turn it on again usuing the "backlight display" button as i have since buying it this spring.

in fact the only way that i can get it to turn on, is to open the back, take out the battery, and put it back in. this seems to power it up right away.

i am concerned that i am going to lose data at some point if this continues.

have i accidently activated some type of "protection" that i need to turn off?? is my battery going dead?? what??

it works absolutely fine otherwise.

any help is greatly appreciated.
Offline  
Old 12-13-2005, 03:15 PM   #2 (permalink)
CrackBerry Addict
 
nb_mitch's Avatar
 
Join Date: Jul 2005
Location: Bentonville, Arkansas
Model: 8310
Carrier: AT&T
Posts: 678
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I would sync it up to your pc before you loose anything, can't help with the problem though.
__________________
Mitch
8310 / New Beetle / 2006 Triumph Daytona 675 / Give Kids the World
Me @ GKTW on my D675
Offline  
Old 12-13-2005, 04:38 PM   #3 (permalink)
New Member
 
Join Date: Dec 2005
Model: 7250
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

did that first thing this morning, just in case.
Offline  
Old 12-15-2005, 03:20 AM   #4 (permalink)
Zro
CrackBerry Addict
 
Zro's Avatar
 
Join Date: Mar 2005
Model: 8800
Carrier: Rogers
Posts: 597
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is going to sound really stupid, but when the BlackBerry is powered on, does the Backlight key work properly?

Try reloading the handheld software, it could be OS related.

Zro
Offline  
Old 12-15-2005, 10:07 AM   #5 (permalink)
New Member
 
Join Date: Dec 2005
Model: 7250
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes, the key works properly otherwise. in fact, everything functions normally once it's on. i thought that it might be the battery, but even the battery life seems to be normal when once on, so i'm guessing that's not the case.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.