BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-30-2010, 12:24 AM   #1 (permalink)
CrackBerry Addict
 
hyedipin's Avatar
 
Join Date: Jul 2007
Model: 9700
PIN: N/A
Carrier: T-Mobile 2001-2007, AT&T 8/26/07 ->
Posts: 640
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default Desktop Manager insists Remove or Downgrade

Please Login to Remove!

I just upgraded to DM 5.0, and I was trying to check the applications but it is giving me only option to Downgrade or Remove for BBM and Windows Live Messenger. It does not let me Keep as it does everything else.
Do I have to downgrade or remove then install these two again?
__________________
Z30, AT&T
Offline  
Old 01-30-2010, 04:47 AM   #2 (permalink)
BlackBerry Master
 
Motorcycle Mama's Avatar
 
Join Date: May 2008
Model: 9930
OS: 7.1.0.163
PIN: N/A
Carrier: Verizon
Posts: 4,351
Post Thanks: 0
Thanked 249 Times in 240 Posts
Default

Yes.
Offline  
Old 01-30-2010, 01:52 PM   #3 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: 10.010219
PIN: No Pin just a Tack
Carrier: at&t
Posts: 8,225
Post Thanks: 40
Thanked 570 Times in 565 Posts
Default

Upgrade
__________________
If someone helps, tell them by clicking the Thanks button


9810 BES
Z10 on BES
9700 BIS
Offline  
Old 01-30-2010, 03:12 PM   #4 (permalink)
CrackBerry Addict
 
hyedipin's Avatar
 
Join Date: Jul 2007
Model: 9700
PIN: N/A
Carrier: T-Mobile 2001-2007, AT&T 8/26/07 ->
Posts: 640
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

Wirelessly posted

I already have the latest. If I continue I either have to remove or downgrade. After I do this, It will probably do the same thing again. I really don't want to do this everytime I try to install something via DM.
How can I fix it?
__________________
Z30, AT&T
Offline  
Old 01-30-2010, 03:45 PM   #5 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: 10.010219
PIN: No Pin just a Tack
Carrier: at&t
Posts: 8,225
Post Thanks: 40
Thanked 570 Times in 565 Posts
Default

Aparently this issue is known and RIM has posted the following in their support site.

"This is a previously reported issue that has been escalated internally to our development team. No resolution time frame is currently available."

This is a standard message RIM states when they have no clue. It may be as simple as fully deleting the DM and replaceing it. I would also remove ALL software on the PC that applys to the Blackberry. Maybe a complete replacement will help.

Good Luck
__________________
If someone helps, tell them by clicking the Thanks button


9810 BES
Z10 on BES
9700 BIS
Offline  
Old 01-30-2010, 04:21 PM   #6 (permalink)
CrackBerry Addict
 
hyedipin's Avatar
 
Join Date: Jul 2007
Model: 9700
PIN: N/A
Carrier: T-Mobile 2001-2007, AT&T 8/26/07 ->
Posts: 640
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

Wirelessly posted

Can't I just remove those from PC? Where are they stored?
__________________
Z30, AT&T
Offline  
Old 01-30-2010, 04:27 PM   #7 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: 10.010219
PIN: No Pin just a Tack
Carrier: at&t
Posts: 8,225
Post Thanks: 40
Thanked 570 Times in 565 Posts
Default

They should be seen in the control panel in the remove /Add software program. They load as standard software in the PC. Also do a complete remove on anything Blackberry or RIM. Also delete the directories if any stragglers remain. Then reload all new software that YOU DOWNLOAD new. Do not use any old software you may have on your PC.
__________________
If someone helps, tell them by clicking the Thanks button


9810 BES
Z10 on BES
9700 BIS
Offline  
Old 01-30-2010, 04:44 PM   #8 (permalink)
CrackBerry Addict
 
hyedipin's Avatar
 
Join Date: Jul 2007
Model: 9700
PIN: N/A
Carrier: T-Mobile 2001-2007, AT&T 8/26/07 ->
Posts: 640
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

Wirelessly posted

I am not talking about DM. I am referring to windows messenger and BBM that cam with DM 5.0 which are outdated....
__________________
Z30, AT&T
Offline  
Old 01-30-2010, 05:29 PM   #9 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: 10.010219
PIN: No Pin just a Tack
Carrier: at&t
Posts: 8,225
Post Thanks: 40
Thanked 570 Times in 565 Posts
Default

They are integrated you must do as above.
__________________
If someone helps, tell them by clicking the Thanks button


9810 BES
Z10 on BES
9700 BIS
Offline  
Old 01-30-2010, 07:29 PM   #10 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,679
Post Thanks: 4
Thanked 96 Times in 71 Posts
Default

What is the app that it's asking you to downgrade or remove? I usually go in and remove the .cod's for that app or edit the .alx file. Then DM treats it as a wirelessly installed application. It typically happens for BlackBerry Messenger and Documents to Go. But it's an easy fix for any app.

Last edited by John Clark : 01-30-2010 at 07:31 PM.
Offline  
Old 01-30-2010, 08:22 PM   #11 (permalink)
CrackBerry Addict
 
hyedipin's Avatar
 
Join Date: Jul 2007
Model: 9700
PIN: N/A
Carrier: T-Mobile 2001-2007, AT&T 8/26/07 ->
Posts: 640
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

Wirelessly posted

It is BBM and Windows Live Messenger. All I wanted to do was to install one new application, but it is not letting me do that since I cannot choose Do Nothing (Keep It).
Why doesn't it just read and display what's ok my BB? Where did it get these old versions?
__________________
Z30, AT&T
Offline  
Old 01-30-2010, 08:33 PM   #12 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,679
Post Thanks: 4
Thanked 96 Times in 71 Posts
Default

The reason it happens is because you've upgraded those apps to a version newer than is contained in the OS installed on your PC. RIM needs to come up with a fix. However, you can fix it yourself by doing the following:

For WLM:

Navigate to the following folder (your device and OS version may vary from what I have listed here in italics:

C:\Program Files\Common Files\Research In Motion\Shared\Loader Files\8900-v4.6.1.310_P4.2.0.127

Rename WindowsLiveMessenger.alx to WindowsLiveMessenger.old (if you can't see the extension go to the menu above and go to Tools >Folder Options >View and uncheck "Hide extensions for known file types")

For BBM there is no dedicated .alx file in that folder. What I do is go to the Java folder located in the same directory as above and delete/rename/move (your choice whether you want to move, rename or delete them) the following .cod files:

net_rim_bb_qm_peer_resource_en.cod
net_rim_bb_qm_peer.cod

There may be other _peer cod's with different language extensions (en=english) and if you have other languages installed, make sure you delete/rename/move those too.

You could also remove/delete/rename the .cod's for WLM too in that list rather than renaming the .alx file for it. Either method will work, though.

Then after you do this, run DM again and DM should see those apps as wirelessly installed apps and DM will keep them and you can do your installation.
Offline  
Old 01-30-2010, 09:10 PM   #13 (permalink)
CrackBerry Addict
 
hyedipin's Avatar
 
Join Date: Jul 2007
Model: 9700
PIN: N/A
Carrier: T-Mobile 2001-2007, AT&T 8/26/07 ->
Posts: 640
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

Wirelessly posted

Thank You John,
I will try that as soon as I get home, and will report back.
__________________
Z30, AT&T
Offline  
Old 01-31-2010, 12:53 PM   #14 (permalink)
CrackBerry Addict
 
hyedipin's Avatar
 
Join Date: Jul 2007
Model: 9700
PIN: N/A
Carrier: T-Mobile 2001-2007, AT&T 8/26/07 ->
Posts: 640
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

John, I don't have
C:\Program Files\Common Files\Research In Motion\Shared this folder.

Also, It keeps asking me to update device software:

Should I do this first?
__________________
Z30, AT&T
Offline  
Old 01-31-2010, 12:59 PM   #15 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,679
Post Thanks: 4
Thanked 96 Times in 71 Posts
Default

I would download and manually install the 5.0.0.296 (current) software to your PC. Then manually run loader.exe (found in C:\Program Files\Common Files\Research In Motion\AppLoader) to install your app after following my instructions above.

The above screenshot shows the Desktop Manager's automatic update feature which I don't use.
Offline  
Old 01-31-2010, 01:17 PM   #16 (permalink)
CrackBerry Addict
 
hyedipin's Avatar
 
Join Date: Jul 2007
Model: 9700
PIN: N/A
Carrier: T-Mobile 2001-2007, AT&T 8/26/07 ->
Posts: 640
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

I am already running 5.0.0.296
__________________
Z30, AT&T
Offline  
Old 01-31-2010, 01:18 PM   #17 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,679
Post Thanks: 4
Thanked 96 Times in 71 Posts
Default

I know that. However, you need to have it also installed on the computer so that you can edit the files as I described.
Offline  
Old 01-31-2010, 01:22 PM   #18 (permalink)
CrackBerry Addict
 
hyedipin's Avatar
 
Join Date: Jul 2007
Model: 9700
PIN: N/A
Carrier: T-Mobile 2001-2007, AT&T 8/26/07 ->
Posts: 640
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by John Clark View Post
I know that. However, you need to have it also installed on the computer so that you can edit the files as I described.
Oh I see, the last one I had was the update for my wife's 8900, which I uninstalled. AT&T website only has 5.0.0.645 now. Do you happen to know where I can download the .296?
__________________
Z30, AT&T
Offline  
Old 01-31-2010, 01:23 PM   #19 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,679
Post Thanks: 4
Thanked 96 Times in 71 Posts
Default

Not off the top of my head. You may have to search multiple carrier's sites for it or look back through the latest OS sticky threads here on the forum. You can always update to the latest, then edit the files after that. I recommend using the latest OS you can find, anyway.
Offline  
Old 01-31-2010, 01:50 PM   #20 (permalink)
CrackBerry Addict
 
hyedipin's Avatar
 
Join Date: Jul 2007
Model: 9700
PIN: N/A
Carrier: T-Mobile 2001-2007, AT&T 8/26/07 ->
Posts: 640
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

Alright, in that case, I will just update to the latest one from AT&T. Thanks again.
__________________
Z30, AT&T
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.