BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-04-2010, 10:12 AM   #1 (permalink)
New Member
 
Join Date: Mar 2010
Location: manila
Model: 8320
PIN: 213ca41b
Carrier: smart
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy HELP! My BB just died. no LED. nothing on screen

Please Login to Remove!

i'm using a bb 8300 curve, was using it earlier tonight then when i was about to use it again and bbm someone, screen was black, no led lights flashing. the batt was almost drained when i got home so i charged it. thinking it was a batt problem, i took batt out and put it on my other bb, the 8520. batt worked well. tried putting it back to the 8300 but there was nothing. called help desk and they said it could be hardware prob. but i didnt drop the phone, didnt do nothing. was working perfectly before i put it aside. not sure whats wrong or what couldve happened. its just DEAD. Help anyone?!
Offline  
Old 03-04-2010, 12:58 PM   #2 (permalink)
Thumbs Must Hurt
 
unclefester's Avatar
 
Join Date: Nov 2008
Location: Phoenix, AZ
Model: 8320
PIN: N/A
Carrier: T-Mobile
Posts: 125
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Welcome to the forums.

Did the phone sustain any water damage that could have caused it to stop working? Even very moist air can cause water damage
__________________
8520(black), 8320(sunset), 8310(red), 8100(black), 8220(black)
Offline  
Old 03-05-2010, 12:28 AM   #3 (permalink)
New Member
 
Join Date: Mar 2010
Location: manila
Model: 8320
PIN: 213ca41b
Carrier: smart
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi unclefester (nice user name) actually there was no damage whatsoever. i didnt even drop it. naturally ive dropped the phone accidentally a couple of times before but nothing to this effect. i tried plugging it to my pc this morning and it still didnt work. have brought it to the phone company for repair already but even they are not sure what the problem is. they told me if they can't do anything it would have to be sent all the way to canada :(
Offline  
Old 03-05-2010, 01:54 AM   #4 (permalink)
Thumbs Must Hurt
 
unclefester's Avatar
 
Join Date: Nov 2008
Location: Phoenix, AZ
Model: 8320
PIN: N/A
Carrier: T-Mobile
Posts: 125
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

That's a really interesting problem... I'm not sure how i would go about solving that, other than maybe contacting your service provider and asking for a replacement phone if it is still under warranty or if you have insurance
__________________
8520(black), 8320(sunset), 8310(red), 8100(black), 8220(black)
Offline  
Old 03-08-2010, 12:12 PM   #5 (permalink)
New Member
 
Join Date: Mar 2010
Model: 8330
PIN: N/A
Carrier: verizon
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

same thing happened to me. it just quit one day. i have the 833o. had to go to the verizon store on a day when it was a blizzard outside! now this phone refuses to ring, no matter what i do.

the store seemed very familiar with the problem with it just quitting. they gladly replaced it with a refurbished piece of crap, but i lost all my contact info. (REMINDER TO EVERYONE, BACK UP YOUR CONTACTS)

so my advice is just take it back. but make sure you get a NEW phone, not a refurbished one.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.