BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-21-2010, 12:22 PM   #1 (permalink)
New Member
 
Join Date: Mar 2010
Model: 9500
PIN: N/A
Carrier: storm
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default my storm won't turn on help!!!

Please Login to Remove!

hi, i've had the BB storm for 10days and i noticed the screen kept freezing when i was texting, i realized this was due to not deleting any of my messages but before i could delete any the phone froze for about 10 minutes so i removed the battery as instructed waited 30 seconds put it back in and now it won't turn on at all! do any of you know how to fix this or have had this problem yourselves?

thanks
Offline  
Old 03-21-2010, 12:26 PM   #2 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,695
Post Thanks: 15
Thanked 498 Times in 485 Posts
Default

Wirelessly posted

Try removing the battery again and wait a good minute. Sometimes, it has been reported, it has been the 2nd or 3rd battery pull that sorts things out. Give it a try before looking at other solutions.
__________________
- Ira
Offline  
Old 03-21-2010, 12:32 PM   #3 (permalink)
New Member
 
Join Date: Mar 2010
Model: 9500
PIN: N/A
Carrier: storm
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks a lot it worked after about the 10th time of trying.
Offline  
Old 03-21-2010, 12:34 PM   #4 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,695
Post Thanks: 15
Thanked 498 Times in 485 Posts
Default

Wirelessly posted

Excellent!

Really, though, not 10 times?
__________________
- Ira
Offline  
Old 03-21-2010, 12:45 PM   #5 (permalink)
New Member
 
Join Date: Mar 2010
Model: 9500
PIN: N/A
Carrier: storm
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

yeah about ten times the phone came back on and turned off again, dont know what to do
Offline  
Old 03-21-2010, 12:50 PM   #6 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,695
Post Thanks: 15
Thanked 498 Times in 485 Posts
Default

Wirelessly posted

Have you exposed it to moisture? Even a sweaty pocket is known to cause problems.

Have you dropped it?

Barring hardware problems, consider wiping the device and reinstalling the device software.

Find the two articles on using JL_CMDER at blackberryfaq.com. Use that to wipe.

See the sticky post on latest OS for your model blackberry. Follow the instructions carefully to reinstall the device software.
__________________
- Ira
Offline  
Old 03-21-2010, 12:54 PM   #7 (permalink)
New Member
 
Join Date: Mar 2010
Model: 9500
PIN: N/A
Carrier: storm
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thank you i'll have a look into it
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.