BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-23-2010, 02:01 PM   #1 (permalink)
New Member
 
SecretSix's Avatar
 
Join Date: Jun 2010
Model: 8530C
PIN: N/A
Carrier: Sprint
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Issues At Hand...

Please Login to Remove!

First off, hello to everyone and thank you in advance should you be able to help me...I joined these forums in an effort to fix a problem I had but 20 minutes ago with my BB..

For some odd reason it wont turn on the conventional way of simply clicking the red button and the scroll wont click on anything i select.

I removed the battery and reinserted, and that's the only way it turns on and the scroll button wont click on anything still...someone give me a sign...and thanks again.

P.S. Its a Curve 8530..
Offline  
Old 06-23-2010, 03:02 PM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,033
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

Did you drop it or get it wet?

Is this a new device still under warranty?
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 06-23-2010, 05:48 PM   #3 (permalink)
New Member
 
SecretSix's Avatar
 
Join Date: Jun 2010
Model: 8530C
PIN: N/A
Carrier: Sprint
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Dubdub View Post
Did you drop it or get it wet?

Is this a new device still under warranty?
I might've gotten it wet a tad cleaning the screen off with some windex..and yes its fairly new (had it going on a month)
Offline  
Old 06-23-2010, 06:19 PM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Dec 2006
Model: I747
OS: 4.1.1
Carrier: at&t
Posts: 2,340
Post Thanks: 43
Thanked 117 Times in 107 Posts
Default

If you got the contacts for the trackball and/or keys wet, that could explain what you are experiencing.
__________________
The Search tool and BlackBerryFAQ answer many questions.
Offline  
Old 06-23-2010, 06:56 PM   #5 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,730
Post Thanks: 15
Thanked 500 Times in 487 Posts
Default

Wirelessly posted

The Windex was a bad move. Not saying for sure that's what directly led to your problem, just that it wasn't wise and could be a factor.

Also, about liquid damage, be aware that people report things as slight as a sweaty pocket or a foggy bathroom or locker room as causing problems.

What you describe fits the symptoms of liquid damage.
__________________
- Ira
Online  
Old 06-23-2010, 07:14 PM   #6 (permalink)
Knows Where the Search Button Is
 
nickabis's Avatar
 
Join Date: Jun 2010
Model: 99999
Carrier: don't know
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does the trackball feel like its moving or not? If all else fails, take it back to you provider and say its faulty.
Offline  
Old 06-23-2010, 08:22 PM   #7 (permalink)
BlackBerry Master
 
Motorcycle Mama's Avatar
 
Join Date: May 2008
Model: 9930
OS: 7.1.0.163
PIN: N/A
Carrier: Verizon
Posts: 4,351
Post Thanks: 0
Thanked 249 Times in 240 Posts
Default

Quote:
Originally Posted by nickabis View Post
Does the trackball feel like its moving or not? If all else fails, take it back to you provider and say its faulty.
There's a GREAT idea. Encourage people to commit FRAUD. Wow.
Offline  
Old 06-23-2010, 08:23 PM   #8 (permalink)
BlackBerry Extraordinaire
 
Join Date: Dec 2006
Model: I747
OS: 4.1.1
Carrier: at&t
Posts: 2,340
Post Thanks: 43
Thanked 117 Times in 107 Posts
Default

I was just about to say the same MM.

smfh
__________________
The Search tool and BlackBerryFAQ answer many questions.
Offline  
Old 06-23-2010, 08:42 PM   #9 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: 10.010219
PIN: No Pin just a Tack
Carrier: at&t
Posts: 8,308
Post Thanks: 43
Thanked 583 Times in 578 Posts
Default

It's a tad defective and the water indicator is more than likely triggered.

Nice nickabis, this site is for honest lawful responses not fraud suggestions..
__________________
If someone helps, tell them by clicking the Thanks button


9810 BES
Z10 on BES
9700 BIS
Online  
Old 06-24-2010, 09:16 AM   #10 (permalink)
BlackBerry Extraordinaire
 
TXLady's Avatar
 
Join Date: Mar 2007
Location: San Antonio, TX
Model: 9650
Carrier: Sprint
Posts: 1,067
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by SecretSix View Post
I might've gotten it wet a tad cleaning the screen off with some windex..and yes its fairly new (had it going on a month)
Basic electronics 101: Never ever spray any thing directly on the device. If you feel the need to use a cleaning spray, spray it lightly on a cleaning cloth first.
__________________
Personal: iPhone on AT&T
Work: BB 9650 on Sprint
Offline  
Old 06-25-2010, 08:22 PM   #11 (permalink)
Knows Where the Search Button Is
 
nickabis's Avatar
 
Join Date: Jun 2010
Model: 99999
Carrier: don't know
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I apologize for not explaining further, I did not intend to make it sound like fraud. I had this same issue with my 9000. I had it in a pocket of shorts on the floor of the bathroom while I showered. When I tried to use it, the trackball wouldn't click and when I'd hit the call button, it would type an "A". I called at&t and talked about my situation. They had me check the water mark, it was ok. It was still under warranty and I had insurance on it. I had to mail it out and the sent a replacement. Again, I am sorry for making it sound like it was fraud. I do not agree with fraud.
Offline  
Old 06-25-2010, 08:28 PM   #12 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: 10.010219
PIN: No Pin just a Tack
Carrier: at&t
Posts: 8,308
Post Thanks: 43
Thanked 583 Times in 578 Posts
Default

better!!
__________________
If someone helps, tell them by clicking the Thanks button


9810 BES
Z10 on BES
9700 BIS
Online  
Old 06-25-2010, 08:36 PM   #13 (permalink)
Knows Where the Search Button Is
 
nickabis's Avatar
 
Join Date: Jun 2010
Model: 99999
Carrier: don't know
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Perfect! Sorry again, I hope no one was to offended with my mistake. I'll try to be more descriptive next time!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.