BlackBerry Forums Support Community               

Closed Thread
LinkBack Thread Tools
Old 06-26-2010, 02:52 AM   #1 (permalink)
New Member
Join Date: Jun 2010
Model: Storm
Carrier: Vodafone
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Need help using data plan in India

Please Login to Remove!

Hi guys,
First off gr8 forum..thnx in advance for any help on this matter.

I bought a used unlocked Verizon BB storm from the US.
I started using a Vodafone India sim card in India.
I can make voice calls, and SMS's with no issues.
I activated my BIS account on Vodafone India but I can't use any data plans.

Once I switched my Sim card with a friend who has a BB and also uses Vodafone India. Amazingly, with my Sim card in his phone, the BIS was working and with his SIm Card in my phone, the BIS was also working.

But once we switched back, it was not working on my phone.
I tried calling the person whom I bought the phone from, but she didn't know what the issue was.

Any help would be greatly appreciated!!
Old 06-26-2010, 06:59 AM   #2 (permalink)
Talking BlackBerry Encyclopedia
Join Date: Nov 2008
Model: 9630
Carrier: Verizon
Posts: 252
Post Thanks: 0
Thanked 0 Times in 0 Posts

Wirelessly posted

Do you have a data plan?
Old 06-26-2010, 07:33 AM   #3 (permalink)
BlackBerry Master
Motorcycle Mama's Avatar
Join Date: May 2008
Model: 9930
Carrier: Verizon
Posts: 4,351
Post Thanks: 0
Thanked 249 Times in 240 Posts

And have you loaded the service books?
Old 06-26-2010, 08:22 AM   #4 (permalink)
BlackBerry God
aiharkness's Avatar
Join Date: Jul 2005
Location: Florida Panhandle
Model: BBPP
OS: 10.3.2
Carrier: T-Mobile USA
Posts: 13,844
Post Thanks: 18
Thanked 517 Times in 501 Posts

Wirelessly posted

So, the long story short is ...

OP has a blackberry data plan (correct?). And friend also has a blackberry data plan.

OP does not have blackberry data service with OP's SIM in OP's blackberry, but does have blackberry data with OP's SIM in friend's blackberry; and also blackberry data on OP's blackberry with friend's SIM.

Is that it?
First, how are you defining BIS service? Do you have GPRS, EDGE, etc in all caps, i.e. does the blackberry indicate you are connecting to the RIM network? What exactly did you do to test?

My first thought is to agree with the others, partly. I would remove the battery, then remove the SIM and inspect it. Look for grime or corrosion. Make sure it is correctly inserted and fully seated in place when installed. Then replace the battery. Then resend service books, and then test again.
- Ira
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Copyright 2004-2014
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.