BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-25-2010, 05:37 AM   #1 (permalink)
New Member
 
Join Date: Oct 2010
Model: 8520
PIN: N/A
Carrier: Vodafone
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 8520 not using wifi

Please Login to Remove!

Hi, I've been a BB user for a while. Finally decided to go with the 8520 after the pearl, curve, bold, storm, storm2 and bold 2 in the last 3 years. Figured that if i have to keep spending on a buggy phone that will stop working, might as well get a cheap one. I was very happy with the basic functionality of the phone including wifi. Recently I noticed slower browsing and realised that the wifi logo on the home screen is no longer highlighted. in the manage connections screen, it gives me the name of the network (whether at home, office, or my friend's place) and shows the name in green. Then the place where a green tick should be on the right, there is a white hyphen (-). I have an unlimited data plan and dont have any other issues, but the wifi problem makes no sense to me. I've deleted all networks, restored to default wifi settings and added the networks back again, but to no avail. Also changed the connection setting to "prompt before connecting". i get a prompt to connect, but the same issue. My default browser is "hot spot browser" as suggested in some other posts.
I've been through a lot of forums but havent found anything similar, although some iphones seem to have a similar problem which is fixed by changing to a "WEP hex" password option. this is not the same for BB (cause you dont have that option) and also all the routers had "PSK" as the password option, which needless to say works fine with all other machines (mac, pc, wireless printers, media drives etc). Also the wifi has stopped working without any change in settings. very frustrated with this new issue.

here is the report from my wifi diagnostics test:

-----


Wi-Fi
Current Profile: manu
SSID: manu
AP MAC Address: 00:02:CF:A7:52:6D
Security Type: Pre-Shared Key (PSK)
Association: Successful
Authentication: Successful
Local IP Address: 192.168.1.36
Signal Level: -75 dBm
Connection Data Rate: 54 Mbps
Status: Network acquired
Authentication Failure Reason:
Network Type: 802.11b/g
Network Channel: 11
Pairwise Cipher: TKIP
Group Cipher: TKIP
Gateway Address: 192.168.1.1
DHCP: Successful
Primary DNS: 202.149.208.92
Secondary DNS: 202.149.208.11
DNS suffix:
Subnet Mask: 255.255.255.0
Server Domain Suffix:
Certificate: Not Applicable
Software Token: Not Applicable
L3 Auth:

VPN
Current Profile:
Concentrator Address:
Contact: N/A
Authentication: N/A
Secure Device IP:
Status: VPN profile is not found.
Resolving Concentrator: N/A
Concentrator IP:
Primary DNS:
Secondary DNS:
DNS Suffix:
Secure Subnet Mask:
Retry at:
Session Lifetime:
Re-login at:
Failed Login Attempts: 0
Certificate:
Software Token:

BlackBerry Infrastructure
Address Used:
IP Used:
Connecting: Error
Authenticating router: N/A
Authenticating server: N/A
Last Contact At:
Attached Thumbnails
8520 not using wifi-photo-3.jpg  8520 not using wifi-photo-4.jpg  8520 not using wifi-photo-5.jpg  

Last edited by manivnderkohli : 10-25-2010 at 05:38 AM. Reason: more information
Offline  
Old 10-25-2010, 09:08 AM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Dec 2006
Model: I747
OS: 4.1.1
Carrier: at&t
Posts: 2,340
Post Thanks: 43
Thanked 117 Times in 107 Posts
Default

Quote:
Originally Posted by manivnderkohli View Post
BlackBerry Infrastructure
Address Used:
IP Used:
Connecting: Error
Authenticating router: N/A
Authenticating server: N/A
Last Contact At:
Looks like you don't have a Blackberry BIS data plan on your account with vodafone.
__________________
The Search tool and BlackBerryFAQ answer many questions.
Offline  
Old 10-25-2010, 05:36 PM   #3 (permalink)
New Member
 
Join Date: Oct 2010
Model: 9700
PIN: N/A
Carrier: Vodafone
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well put manivnderkohli,

I have EXACTLY the same problem on my Vodafone (UK) 9700.

This started today at around 8 am.

I have BIS and if I am on the mobile network itself (2G & 3G) then messages pour through as normal. If I turn the mobile network off I have exactly the same wireless behaviour you have described:

I have an Error connecting to Blackberry Infrastructure.

I have been using my BB on wireless without any trouble for months. This has started today and nothing at my end has changed.
Offline  
Old 10-25-2010, 10:12 PM   #4 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: 10.010219
PIN: No Pin just a Tack
Carrier: at&t
Posts: 8,402
Post Thanks: 43
Thanked 596 Times in 589 Posts
Default

Carriers require a blackberry Data plan not a Cell data plan. Most large carriers detect a BB without one and add it. when the right plan is on the account then it is generally a service book issue and resending them usually helps.

This is from RIM. It may help.
Overview

When attempting to browse to a web site on the BlackBerry smartphone, the following error is displayed:

This is a Wi-Fi service. Please ensure your device has an active Wi-Fi connection and try again.

Cause 1

The default browser configuration has been set to Wi-Fi Browser or Hotspot Browser but only a mobile network is currently active.

When the default browser configuration is specified as Internet Browser or BlackBerry Browser, the browser automatically switches depending on how the smartphone is connected (for example, the Wi-Fi® Browser will automatically be used if the smartphone connects successfully to a Wi-Fi network). If the default browser is set to Wi-Fi Browser or Hotspot Browser, it will only browse with a Wi-Fi connection.

Cause 2

The appropriate service books are not present on the smartphone.

Resolution 1

To resolve this issue, change the default browser configuration to Internet Browser or BlackBerry® Browser. To perform this, complete the following steps:

From the Home screen of the BlackBerry smartphone, go to Options > Advanced Options > Browser.
Change the value of the field Default browser configuration to Internet Browser or BlackBerry Browser.
Press the Menu key, and click Save.
Resolution 2

Register the smartphone to the host routing table to have the appropriate service books pushed down. For instructions on how this is done, see KB00510.

Should the same message still be displayed after registering the smartphone, contact your wireless service provider for assistance.
__________________
If someone helps, tell them by clicking the Thanks buttonî


9810 BES
Z10 on BES
9700 BIS
Offline  
Old 10-26-2010, 06:22 AM   #5 (permalink)
New Member
 
Join Date: Oct 2010
Model: 9700
PIN: N/A
Carrier: Vodafone
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have an active BIS data plan. When I am on the GSM network my BIS data plan functions as normal.

From yesterday - when I am on wifi with GSM turned off (and data services ON) my BB will recognise the wifi but not connect to BlackBerry Infrastructure.

This must be becasue of something changing at Vodafone's end. Nothing has changed at my end.
Offline  
Old 10-27-2010, 05:30 AM   #6 (permalink)
New Member
 
Join Date: Oct 2010
Model: 9700
PIN: N/A
Carrier: Vodafone
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have tried a full downgrade to software 5.1.0.153 - over wifi I could still not connect to Blackberry Infrastructure.

I then upgraded back to 5.0.0.862 and still I cannot connect to Blackberry Infrastructure via wifi
Offline  
Old 10-31-2010, 04:52 AM   #7 (permalink)
New Member
 
Join Date: Oct 2010
Model: 9700
PIN: N/A
Carrier: Vodafone
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

manivnderkohli - did you find a solution to this?

Mine still doesn't work....
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.