BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-31-2010, 11:53 PM   #1 (permalink)
New Member
 
Join Date: Oct 2010
Model: 8830
PIN: N/A
Carrier: Vodafone
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Unique problem with BB8830

Please Login to Remove!

I use an unlocked World Edition BlackBerry 8830. I recently upgraded the OS to v4.5 from v4.2. I am using GSM.

I am facing the following problems:
1. In place of Operator logo, I get the message Activation Required
2. I am able to make/receive calls and SMS. However, the data services (BBM, Email, Internet) do not work. I try and register the handset with the operator and nothing happens.
3. If I put another SIM in the handset t works fine.
4. If I put my SIM in another handset it works fine.
5. If I put my SIM in my handset, it doesn't work!

Any idea why this may be happening?
Offline  
Old 11-01-2010, 12:21 AM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,035
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

1. For the "Activation Required" please use the search feature. This might work, but it is for a 9530:

If you are using an unlocked Verizon Storm and have "Activation Required" on your home screen or your phone number displays incorrectly, Dial # # 000000 (Send). In the Menu add your phone number and select save. The device will reboot and activate.

2. For data services, you need a BB data plan. Not sure what Voda calls it however. Perhaps one of our UK members will be along shortly to provide some help.

3 - 5. Have you activated the device with your SIM inserted?
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 11-01-2010, 04:27 PM   #3 (permalink)
New Member
 
Join Date: Oct 2010
Model: 8830
PIN: N/A
Carrier: Vodafone
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Angry

I am already subscribed to a Data Plan. The problem occured when the OS was upgraed to v4.5 from v4.2.







Quote:
Originally Posted by Dubdub View Post
1. For the "Activation Required" please use the search feature. This might work, but it is for a 9530:

If you are using an unlocked Verizon Storm and have "Activation Required" on your home screen or your phone number displays incorrectly, Dial # # 000000 (Send). In the Menu add your phone number and select save. The device will reboot and activate.

2. For data services, you need a BB data plan. Not sure what Voda calls it however. Perhaps one of our UK members will be along shortly to provide some help.

3 - 5. Have you activated the device with your SIM inserted?
Offline  
Old 11-01-2010, 05:46 PM   #4 (permalink)
BlackBerry Master
 
Motorcycle Mama's Avatar
 
Join Date: May 2008
Model: 9930
OS: 7.1.0.163
PIN: N/A
Carrier: Verizon
Posts: 4,351
Post Thanks: 0
Thanked 249 Times in 240 Posts
Default

Did you resend the Service Books after you did the update?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.