BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   General BlackBerry Discussion (http://www.blackberryforums.com/general-blackberry-discussion/)
-   -   Adding third party jar to JDE (Java Development Environment) (http://www.blackberryforums.com/general-blackberry-discussion/28178-adding-third-party-jar-jde-java-development-environment.html)

octavian 03-09-2006 01:35 PM

Adding third party jar to JDE (Java Development Environment)
 
Hi,

I'm developing an application in JDE 4.0.2.188
and it requires a third party xml jar.
For compiling/building it, I added the path to that jar by doing this:
- right mouse click on teh name of the project (located at the top of jtree -- left pane in JDE)
- then select "Properties"
- in the Properties window, select Build tab and enter the full path including the name of the jar in the text box called "Imported jar files"

The app compiles/builds ok, it can find the jar
But when I try to run it in the JDE simulator, it says it cannot find it !

It gives this error:
Module 'kxml2-min-2.2.2' not found.Error starting <appName>: Module 'kxml2-min-2.2.2' not found.

Because of this, I guess , I could not also load it on the device.
I need help, please !

whsbuss 03-09-2006 02:00 PM

Quote:

Originally Posted by octavian
Hi,

I'm developing an application in JDE 4.0.2.188
and it requires a third party xml jar.
For compiling/building it, I added the path to that jar by doing this:
- right mouse click on teh name of the project (located at the top of jtree -- left pane in JDE)
- then select "Properties"
- in the Properties window, select Build tab and enter the full path including the name of the jar in the text box called "Imported jar files"

The app compiles/builds ok, it can find the jar
But when I try to run it in the JDE simulator, it says it cannot find it !

It gives this error:
Module 'kxml2-min-2.2.2' not found.Error starting <appName>: Module 'kxml2-min-2.2.2' not found.

Because of this, I guess , I could not also load it on the device.
I need help, please !

Unrelated question -> how do you simulate the 8700 in the JDE?


All times are GMT -5. The time now is 12:27 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.