BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-09-2006, 12:35 PM   #1 (permalink)
New Member
 
Join Date: Mar 2006
Model: 7200
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Adding third party jar to JDE (Java Development Environment)

Please Login to Remove!

Hi,

I'm developing an application in JDE 4.0.2.188
and it requires a third party xml jar.
For compiling/building it, I added the path to that jar by doing this:
- right mouse click on teh name of the project (located at the top of jtree -- left pane in JDE)
- then select "Properties"
- in the Properties window, select Build tab and enter the full path including the name of the jar in the text box called "Imported jar files"

The app compiles/builds ok, it can find the jar
But when I try to run it in the JDE simulator, it says it cannot find it !

It gives this error:
Module 'kxml2-min-2.2.2' not found.Error starting <appName>: Module 'kxml2-min-2.2.2' not found.

Because of this, I guess , I could not also load it on the device.
I need help, please !

Last edited by octavian : 03-09-2006 at 12:57 PM.
Offline  
Old 03-09-2006, 01:00 PM   #2 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by octavian
Hi,

I'm developing an application in JDE 4.0.2.188
and it requires a third party xml jar.
For compiling/building it, I added the path to that jar by doing this:
- right mouse click on teh name of the project (located at the top of jtree -- left pane in JDE)
- then select "Properties"
- in the Properties window, select Build tab and enter the full path including the name of the jar in the text box called "Imported jar files"

The app compiles/builds ok, it can find the jar
But when I try to run it in the JDE simulator, it says it cannot find it !

It gives this error:
Module 'kxml2-min-2.2.2' not found.Error starting <appName>: Module 'kxml2-min-2.2.2' not found.

Because of this, I guess , I could not also load it on the device.
I need help, please !
Unrelated question -> how do you simulate the 8700 in the JDE?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.