BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-05-2005, 09:25 AM   #1 (permalink)
CrackBerry Addict
 
Join Date: Aug 2004
Model: 950
Carrier: robbers
Posts: 909
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Cannot send e-mail from blackberry? Can't auto-more? Read:

Please Login to Remove!

This is being put here for the record. I expect others with this problem to *search* and find this thread:

If you are having the following symptoms:

* You can recieve mail on your blackberry
* When sending mail you get a red X, and cannot figure out what's wrong
* When you try to view a large message, 'more' or 'auto more' fails to deliver any additional message
* You have noticed the error "TRANSACTION ERROR - DECRYPTION ERROR'

You will probably be in the same boat I found myself in. Here is what's wrong, and how to fix it:

* I encountered this problem with the redirector only.
* I use Outlook 2003 for my mail client

Your encryption key is the likely cause of the problem. The encryption key is stored in two locations, once on the Blackberry by means of Web Client or Desktop service books. The second location is on your PC in a database (if you use the redirector).

You could try deleting these service books and re-sending them to you. You could also try creating a new encryption key usign the redirector's advanced functions.

You may have been like me and tried reinstalling your OS, deleting the relevant encryption key service books, generating new keys, and it still did not work...

You may have also tried removing/reinstalling the desktop software. Perhaps you took it further and recieved instructions for a manual uninstall (deleting all files, temp directories, shared files, and registry keys!) which did not solve the problem..

The solution if you have to go this far: dbclean.exe. Rim support has a file that is designed to solve this problem, it searches your MAPI profiles on your hard disk (for redirector or BES) and removes the encryption key.

From there, the next time you connect your blackberry to the desktop manager software it will ask to generate a new key automatically, and off you go. You may be required to re-set your blackberry filters or other redirector settings.

This was the ONLY way i could solve my problem and i went 2 MONTHS without being able to send mail through my redirector. However, i had capability through web-client the entire time..

To get dbclean.exe i would call your service provider, or RIM support (if you have tsupport) and tell them this is the solution to this problem. If that fails, go to rim directly, tell them your desperate and your provider won't help you as they are unaware of the solution.

Thirdly, you could PM me and i could send you the file... this was a nasty problem and I dread having anyone else go through this..

- headtailgrep
Offline  
Old 02-05-2005, 10:19 AM   #2 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
I expect others with this problem to *search* and find this thread
:D
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 02-05-2005, 04:22 PM   #3 (permalink)
Retired BBF Moderator
 
Mark Rejhon's Avatar
 
Join Date: Aug 2004
Location: Ottawa, Ontario, Canada
Model: Bold
Carrier: Rogers
Posts: 4,870
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Good information. Thanks!

If you know of any other threads that has similiar problem reports, or a specific troubleshooting FAQ somewhere, let me know and I`ll add a hyperlink to this thread.

It`s a relatively obscure problem, but definitely a useful contribution (like my problems with the Home Address not synchronizing properly, while Work Address does -- it was a known BlackBerry Desktop 4.0 field mapping issue that needed to be manually fixed, if installing on top of Desktop 3.6)
__________________
Thanks,
Mark Rejhon
Author of XMPP extension XEP-0301:
www.xmpp.org/extensions/xep-0301.html - specification
www.realjabber.org - open source
Offline  
Old 02-05-2005, 08:28 PM   #4 (permalink)
CrackBerry Addict
 
T-Roy's Avatar
 
Join Date: Jan 2005
Model: 8800
Carrier: Darth Vader
Posts: 704
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

My users that have had this problem sometimes can just wipe the service books to fix it, sometimes regenerating an enc. key, sometimes dbclean, sometimes apploading, sometimes using javaloader to wipe the handheld... Its not clear cut that dbclean is the only resolution.
Offline  
Old 02-05-2005, 09:01 PM   #5 (permalink)
CrackBerry Addict
 
Join Date: Aug 2004
Model: 950
Carrier: robbers
Posts: 909
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No, but i am just trying to STOP my case from EVER happening again.

all this does is add to the pool of knowledge.. this being the free pool of knowledge.. RIM has a big one but you have to pay for it =)
Offline  
Old 02-16-2005, 10:37 AM   #6 (permalink)
New Member
 
Join Date: Feb 2005
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Success!

You can't make up how frustrating this problem is, and how simple this forum made it to fix! Worth every second I've spent here. Why the heck don't the tier 2 folks read this?

THANKS to all who have me up and running!
Offline  
Old 02-16-2005, 11:42 AM   #7 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by headtailgrep
RIM has a big one but you have to pay for it =)
actually, its not much different than the free knowledge base. a few articles here, a few articles there, a few thousand dollars spent.
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 02-16-2005, 04:24 PM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Dec 2004
Posts: 43
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Cannot send e-mail from blackberry? Can't auto-more? Rea

Quote:
Originally Posted by headtailgrep
To get dbclean.exe i would call your service provider, or RIM support (if you have tsupport) and tell them this is the solution to this problem. If that fails, go to rim directly, tell them your desperate and your provider won't help you as they are unaware of the solution.

Thirdly, you could PM me and i could send you the file... this was a nasty problem and I dread having anyone else go through this..
- headtailgrep
... or look here: http://www.pdastreet.com/forums/show...threadid=44521
Offline  
Old 02-26-2005, 05:29 PM   #9 (permalink)
Jg
New Member
 
Join Date: Feb 2005
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Cannot send e-mail from blackberry? Can't auto-more? Rea

Quote:
Originally Posted by ldblf2
Quote:
Originally Posted by headtailgrep
To get dbclean.exe i would call your service provider, or RIM support (if you have tsupport) and tell them this is the solution to this problem. If that fails, go to rim directly, tell them your desperate and your provider won't help you as they are unaware of the solution.

Thirdly, you could PM me and i could send you the file... this was a nasty problem and I dread having anyone else go through this..
- headtailgrep
... or look here: http://www.pdastreet.com/forums/show...threadid=44521
Running dbclean.exe on my XP system crashes the dbclean app (the one downloaded from the link mentioned) ... hence, still having the same problem :(
Offline  
Old 03-01-2005, 06:12 PM   #10 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2005
Model: 9900
Carrier: Rogers
Posts: 62
Post Thanks: 1
Thanked 3 Times in 2 Posts
Default Here is my expriences

Ran db clean and now I can receive email BUT lost my wireless calender and cannot receive messages cause I get a decryption failure. Now what?!?!?
Offline  
Old 03-01-2005, 06:37 PM   #11 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2005
Location: Mount Prospect IL
Posts: 112
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Cannot send e-mail from blackberry? Can't auto-more? Rea

Quote:
Originally Posted by Jg
Running dbclean.exe on my XP system crashes the dbclean app (the one downloaded from the link mentioned) ... hence, still having the same problem :(
RIM told me to run the app in compatibility mode -- set it to Windows 2000. Worked for me.
Offline  
Old 03-01-2005, 09:14 PM   #12 (permalink)
Jg
New Member
 
Join Date: Feb 2005
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Cannot send e-mail from blackberry? Can't auto-more? Rea

Quote:
Originally Posted by WolfKeeper
Quote:
Originally Posted by Jg
Running dbclean.exe on my XP system crashes the dbclean app (the one downloaded from the link mentioned) ... hence, still having the same problem :(
RIM told me to run the app in compatibility mode -- set it to Windows 2000. Worked for me.
I had to turn off "Cached Exchange Mode" on the profile, then dbclean.exe run perfectly. Everything works well now.

Thanks for the help, everyone.
Offline  
Old 03-01-2005, 11:44 PM   #13 (permalink)
Thumbs Must Hurt
 
chuy's Avatar
 
Join Date: Feb 2005
Location: Austin, Texas
Posts: 91
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I\'m not a newbie to BB, but a newbie to redirector. I want to use it on my comp at home for personal email, and run webclient for my work email, because my home comp is on all the time. But, I\'ve been told that it only works with an exchange email address (or notes, etc.)

Do all you guys have exchange addresses? Or am I just going about this wrong? I have a POP email through my ISP, run win2k, and use outlook as my PIM.
%D0ASo, theoretically, this will work in my case? Is that what I understand?

Posted wirelessly from a BlackBerry using wap.BlackBerryClub.com
Offline  
Old 03-08-2005, 04:00 PM   #14 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2005
Model: 7130e
Carrier: Verizon
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default The dreaded red X

Thanks to all who contribute.

Can't even imagine how long this one would have taken on the phone with
"Support" ......

dbclean did the trick!
Offline  
Old 05-03-2005, 10:15 PM   #15 (permalink)
WNO
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2005
Model: 8100
Carrier: TMO
Posts: 303
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Great thread, thanks for everyone's efforts! For the purpose of "completeness," I'll mention in this thread that, as someone mentioned in another thread, dbclean seems (at least for some users, like me) to work better when the Desktop Manager is running. But, after running dbclean, I had to exit/restart the Desktop Manager for the changes to take effect.
Offline  
Old 08-07-2005, 06:48 AM   #16 (permalink)
Thumbs Must Hurt
 
ABuehrlen's Avatar
 
Join Date: Feb 2005
Model: 8320
Carrier: T-Mobile
Posts: 66
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

hey i have a 7510 and cant send or recieve messages at all. I did a service book copy to get the browser on my blackberry and cant get the service books from the webclient to resend so i can fix the issues. im NOT using enterprise sever. im using web clinetor redirector option in desktop. Is there anything you can suggest? can you send me dbclean.exe if you think that will help. I really miss my email.

Thanks
ABuehrlen
__________________
___________________
Blackberry 8320 Curve Through T-Mobile w/ Jabra 250v
Offline  
Old 08-11-2005, 07:04 AM   #17 (permalink)
Thumbs Must Hurt
 
ABuehrlen's Avatar
 
Join Date: Feb 2005
Model: 8320
Carrier: T-Mobile
Posts: 66
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

nevermind i fixed the issue all is cool
__________________
___________________
Blackberry 8320 Curve Through T-Mobile w/ Jabra 250v
Offline  
Old 09-07-2005, 04:03 PM   #18 (permalink)
CrackBerry Addict
 
Join Date: Aug 2004
Model: 950
Carrier: robbers
Posts: 909
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I see now that RIM in release notes for Desktop Software 4.0.1.x has acknowledged and fixed this error.

(4.0 Sp1)
Offline  
Old 09-08-2005, 12:53 PM   #19 (permalink)
New Member
 
Join Date: Sep 2005
Model: 7150
Carrier: verizon
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks for the post headtailgrep. after you run the dbclean you need to stop the redirector and manager then start them again. worked like a charm.
Offline  
Old 09-27-2005, 11:03 AM   #20 (permalink)
New Member
 
Join Date: Sep 2005
Model: 7520
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default more difficulties

Another Newbie here.
I've been following this thread and another in this forum about the "Decryption failure" issue and have tried the various suggestions (including dbclean), but I'm still having problems. We have a BES running against Groupwise 6.5.4 and one admin machine with the Desktop software (version 4.01) that was used to setup the handhelds. It ran fine for two weeks - I upgraded to sp2 on the BES and changed the IT policy last Wednesday and the handhelds (6) haven't been receiving email since. I even tried running the Blackberry app on the server to generate a new Trusted Key. I can send a test message from the BES to a handheld - they are just not receiving email (and Browser) even though I can see the BES login to Groupwise if I restart it.
Any ideas gratefully appreciated!!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.