BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-03-2006, 12:18 PM   #1 (permalink)
New Member
 
Join Date: May 2006
Model: 7520
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Outlook Calendar not syncing

Please Login to Remove!

newbie here
my calendar is not syncing up
well, when an entry in Outlook is made, my BB calendar updates right away
when an entry in my BB calendar is made, it is not updating my Outlook calendar. everything else syncs up fine. I send an email from my BB, it shows up in my Outlook sent box right away. Add a contact in my BB, it show right away. Any assistance would be appreciated.
We're using Outlook 2003 and running BES 4.1

Many Thanks
Offline  
Old 05-03-2006, 12:30 PM   #2 (permalink)
Thumbs Must Hurt
 
bobelliottjr's Avatar
 
Join Date: Jan 2006
Location: Atlanta, GA
Model: 7520
PIN: 4011A2D7
Carrier: Nextel
Posts: 123
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Go to settings and setup with your system administrator to do an enterprise activation.
__________________
Bob Elliott

Quote:
My Blackberry 7520, I never leave home without, it is my office on the move ...
Offline  
Old 05-03-2006, 12:36 PM   #3 (permalink)
New Member
 
Join Date: May 2006
Model: 7520
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thats already been done. the senior admin, i'm a junior admin, he has already checked and all checks out fine. is there a certain setting that would need to be checked?
Offline  
Old 05-04-2006, 01:13 PM   #4 (permalink)
ec9
New Member
 
Join Date: Apr 2006
Location: Boston, Mass
Model: 8800
Carrier: Cingy
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

make sure the wireless sync option is enable on the bb I had the same issue

go to calander and hit the options menu
Offline  
Old 05-04-2006, 01:34 PM   #5 (permalink)
CrackBerry Addict
 
Andi's Avatar
 
Join Date: May 2005
Location: Chicago
Model: 9700
OS: 6.0.0.448
Carrier: T-Mobile
Posts: 549
Post Thanks: 0
Thanked 4 Times in 4 Posts
Default

Search for one way calendar sync - there is a suggested fix in that thread

We had the same issue with most of our users - the permissions (I think that is in the one way calendar sync thread) were set correctly but the other fix has to do with the cdo.dll files on the BES and Exchange - once I got the server guys to make them match up we were good.
Offline  
Old 06-11-2006, 09:17 PM   #6 (permalink)
New Member
 
Join Date: May 2006
Model: 7100i
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Andi
Search for one way calendar sync - there is a suggested fix in that thread

We had the same issue with most of our users - the permissions (I think that is in the one way calendar sync thread) were set correctly but the other fix has to do with the cdo.dll files on the BES and Exchange - once I got the server guys to make them match up we were good.
I'm having similar trouble, everything syncs up, contacts, notes, emails - except calendar won't sync at all. Tried re-installing BES, wiping and 're-activating' handheld. Nothing works, what are the specifics on the .dll issues? All this worked fine when BES was installed on our Exchange server. Had to move BES to another box (XP) and now, no calendar! Talked to BB support and went through KB to insure proper rights on BESAdmin account, still nothing. Any help is appreciated.

Thanks
Offline  
Old 05-14-2007, 08:25 AM   #7 (permalink)
New Member
 
Join Date: May 2007
Model: 8103
PIN: N/A
Carrier: verizon
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default what may be causing it

I know this thread is over a year old, but if you google "blackberry not synching with Outlook calendar" you might end up here. From my experience, this is the result of at least one but up to all of the following being true:

1) cdo.dll is not registered. This page from BB tells you which version of cdo.dll matches which version of mapi32 matches which version of Exchange. Very handy:

BlackBerry Search Results

2) CDO.dll is registered in the wrong folder. DO NOT COPY AND REGISTER IT IN SYSTEM32 FOLDER. Register it (regsvr32 cdo.dll) in the Bin folder under the Exchange folder. To check where it is registered, ref the following article:

BlackBerry Search Results

If it is registered in the incorrect location, re-register and restart the Dispatcher service.

3) Here was my problem: Service account has incorrect rights in Exchange. Our service account was a member of the domain admins group. You may think that will ensure the account has adequate permissions in Exchange, but you'd be wrong. In Exchange 2003, domain admins are by default denied the right to Send As and Receive As, a right which the blackberry service account MUST have. You'll either need to remove the blackberry service account from domain admins, or adjust the exchange permissions accordingly. If you need additional info on doing that, let me know.

Hope this helps.
Offline  
Old 08-08-2007, 12:14 AM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2006
Model: 8310
Carrier: AT&T
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Our IT dept replaced my 8700c due to bad wireless radio, so I just got the new 8700c and noticed that calander entries I creat on my desktop outook 2007 are not syncing to the blackberry and well as entries made on bb calender are not syncing to desktop outlook. However, if some one else sends me a meeting invite, I can accept on either desktop outlook or bb and the appt will show up in both bb and desktop outlook. This sounds like something specific with my desktop outlook. Also, other bb users in our company are not having any issues. IT guys are scratching their heads on this one. Any thoughts they can try?
Offline  
Old 08-09-2007, 02:14 AM   #9 (permalink)
Thumbs Must Hurt
 
flat7's Avatar
 
Join Date: Jul 2005
Location: Phoenix, AZ
Model: 8900
OS: 5.0.0.900
Carrier: T-Mobile
Posts: 68
Post Thanks: 3
Thanked 0 Times in 0 Posts
Default Unable to complete request.

I've had no problems syncing my 8100 with Outlook 2007 since I got it earlier this year. Tonight I got the above message while trying to sync with Desktop Manager. I have been travelling for a month through many time zones, this was the first time I've tried to sync since returning home. Apparently the intellisync config file has been corrupted. I found the solution below which worked for me after trying several others; wanted to share it and hopefully save someone some time.

Unable to complete request error
Offline  
Old 08-09-2007, 05:30 AM   #10 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8100
PIN: N/A
Carrier: Vodafone
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Help

adamshattuck, I have done what you said but i'm still getting the same error, any other ideas?
Offline  
Old 08-10-2007, 01:24 AM   #11 (permalink)
Thumbs Must Hurt
 
flat7's Avatar
 
Join Date: Jul 2005
Location: Phoenix, AZ
Model: 8900
OS: 5.0.0.900
Carrier: T-Mobile
Posts: 68
Post Thanks: 3
Thanked 0 Times in 0 Posts
Default

Have you tried re-installing Desktop Manager, making sure you have the latest version?
Offline  
Old 11-28-2007, 07:30 AM   #12 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8703
PIN: N/A
Carrier: verizon
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 8700 and outlook 2007

I am also having an issue with my 8700 updating my outlook 2007 calendar through cellular connection. I get updated appointments on my bb from outlook but not the other way.

We use bes and we have exchange 2007.

nearly everyone in my company uses bb's of various models and all on verizon.

I and one other guy use the 8700, he hasn't mentioned any issues.

Any advice?
Offline  
Old 11-28-2007, 02:22 PM   #13 (permalink)
New Member
 
Join Date: May 2007
Model: 8103
PIN: N/A
Carrier: verizon
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by geostream View Post
adamshattuck, I have done what you said but i'm still getting the same error, any other ideas?
Sorry for the late reply, but I don't get on this site that often.

Please explain in full the issue you're having (appointments created in Outlook not synching to blackberry, or vice versa, or both..), what version of BES, Exchange, etc... and I'll do my best!

later
Adam
Offline  
Old 11-28-2007, 02:26 PM   #14 (permalink)
New Member
 
Join Date: May 2007
Model: 8103
PIN: N/A
Carrier: verizon
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by don bennett View Post
I am also having an issue with my 8700 updating my outlook 2007 calendar through cellular connection. I get updated appointments on my bb from outlook but not the other way.

We use bes and we have exchange 2007.

nearly everyone in my company uses bb's of various models and all on verizon.

I and one other guy use the 8700, he hasn't mentioned any issues.

Any advice?
1) Do your contacts (and everything else) synch wirelessly? Add one on your blackberry and see if it shows up in Outlook.

2) Is the other guy running Office 2007 as well?


Adam
Offline  
Old 12-04-2007, 12:37 PM   #15 (permalink)
New Member
 
Join Date: Dec 2007
Model: 8100
PIN: N/A
Carrier: Rogers
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am having the same issues. I am the BES administrator for our company. I have verified the CDO.dll registration and version. I have confirmed that MAPI.dll is also present on the BES Server. I have also confirmed that the service account has full admin rights to the exchange server (had to add that) and restarted the exchange store.

It was working fine until a short time ago. any other idea's?
We are running Exchange 2003 on Windows Server 2003 Enterprise
Bes 4.1 on Server 2003 Standard.

Last edited by stony29 : 12-04-2007 at 12:57 PM.
Offline  
Old 12-04-2007, 02:04 PM   #16 (permalink)
New Member
 
Join Date: May 2007
Model: 8103
PIN: N/A
Carrier: verizon
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

1) cdo.dll is registered in the Bin subfolder under the Exchsrvr folder, correct?

2) Do appointments made/edited in Outlook not synch to the blackberry, or vice versa, or both?

3) Any notable errors in the Application Event Log on the blackberry server?

4) re-register cdo.dll and re-start the BES dispatcher service...
Offline  
Old 12-04-2007, 05:09 PM   #17 (permalink)
New Member
 
Join Date: Dec 2007
Model: 8100
PIN: N/A
Carrier: Rogers
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

1) confirmed cdo.dll registered at c:\program files\exchsrvr\bin
2) cdo.dll and mapi.dll same version as on exchange server.
3) Appointments made in outlook sync to blackberry. Appointments made in blackberry do NOT sync to outlook
4) event view error: [BIPPe] WARNING: Using default BIPP shared Secret (source: ExchangeConnector EventID: 20000)
5) tried shutting down all blackberry services, un registering cdo.dll, re-registering cdo.dll and starting service.

All the above have resulted in no change. no users are able to create calendar items on their blackberry devices and have them appear in outlook.
Offline  
Old 12-06-2007, 12:29 PM   #18 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2006
Location: Mexico
Model: Torch
OS: 7.0
Carrier: Telefonica Movistar
Posts: 84
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem.

I run this BB tool on the BES and tell me this:

[MAPI_SUBSYSTEM]

MAPI32.DLL: Unable to find MAPI32.DLL version information!
EMSMDB32.DLL: Unable to find EMSMDB32.DLL version information!
CDO.DLL: 6.5.7638.2 (C:\WINNT\system32\cdo.dll)

Where is supposed to have to be the MAPI32 and EMSMDB32 files on the BES?
Offline  
Old 12-11-2007, 12:29 PM   #19 (permalink)
New Member
 
Join Date: Dec 2007
Model: 8100
PIN: N/A
Carrier: Rogers
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What BB tool did you run to get that information?

I run this BB tool on the BES and tell me this:

[MAPI_SUBSYSTEM]

MAPI32.DLL: Unable to find MAPI32.DLL version information!
EMSMDB32.DLL: Unable to find EMSMDB32.DLL version information!
CDO.DLL: 6.5.7638.2 (C:\WINNT\system32\cdo.dll)

Where is supposed to have to be the MAPI32 and EMSMDB32 files on the BES?
Offline  
Old 12-12-2007, 03:18 PM   #20 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2006
Location: Mexico
Model: Torch
OS: 7.0
Carrier: Telefonica Movistar
Posts: 84
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It calls "Blackberry configuration check"
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.