BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-12-2006, 02:25 PM   #1 (permalink)
jsf
Thumbs Must Hurt
 
Join Date: Jul 2005
Location: New York, NY
Model: 8820
Carrier: AT&T
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unable to run Switch Device Wizard

Please Login to Remove!

I just got my 8100 today, and I upgraded BB Desktop Manager to 4.2 with the CD in the box. I rebooted & launched and tried to run the Switch Device Wizard, and got a Visual C++ Runtime error, saying abnormal program termination. I made sure I upgraded from the latest 4.2 version on the BB website too.

Has anyone seen this before?
__________________
Jordan
http://www.uselessandillinformed.com
Offline  
Old 09-12-2006, 02:36 PM   #2 (permalink)
Retired BlackBerryForums.com Moderator
 
d_fisher's Avatar
 
Join Date: Oct 2005
Location: Columbus, OH
Model: 9700
OS: SID 6.7
Carrier: AT&T
Posts: 4,455
Post Thanks: 0
Thanked 2 Times in 1 Post
Default

I would suggest performing a clean uninstall/install of BDM. I can launch it without any problems.
__________________
Doug

Remember, please try searching first!

Need a screenshot? ... Like JavaLoader?
Try using BBscreen .....Use JL_Cmder!
or BBScreenShooter!

[SIGPIC][/SIGPIC]
Offline  
Old 09-12-2006, 02:38 PM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Jul 2006
Model: Nope
Carrier: Nope
Posts: 151
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

When you get that error, can you move that error message out of the way and let us know where it exactly stops if it gives you a progress bar.
Offline  
Old 09-12-2006, 04:46 PM   #4 (permalink)
jsf
Thumbs Must Hurt
 
Join Date: Jul 2005
Location: New York, NY
Model: 8820
Carrier: AT&T
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've done a full clean uninstall/re-install, and I'm getting this error.

What I've discovered is that I get it whenever I click on *anything* in the Desktop Manager, so what I'm wondering is this: What's the Windows OS requirement for 4.2? Is it WinXP? My company is still on Win2K, and I wouldn't be surprised if that was hosing this. Just a thought.

Any other ideas?
__________________
Jordan
http://www.uselessandillinformed.com
Offline  
Old 09-12-2006, 09:31 PM   #5 (permalink)
Thumbs Must Hurt
 
Join Date: Jul 2006
Model: Nope
Carrier: Nope
Posts: 151
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do you get this error with the BlackBerry connected to the computer or disconnected from the computer?
Offline  
Old 09-13-2006, 11:13 AM   #6 (permalink)
jsf
Thumbs Must Hurt
 
Join Date: Jul 2005
Location: New York, NY
Model: 8820
Carrier: AT&T
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mischief007
Do you get this error with the BlackBerry connected to the computer or disconnected from the computer?
Same result either way...

If the device is disconnected, I get the runtime error as soon as I click on any icon (E-mail Settings, etc). If the device is connected, I get the runtime error as soon as I enter the BB password.
__________________
Jordan
http://www.uselessandillinformed.com
Offline  
Old 09-13-2006, 01:04 PM   #7 (permalink)
jsf
Thumbs Must Hurt
 
Join Date: Jul 2005
Location: New York, NY
Model: 8820
Carrier: AT&T
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Desktop Manager 4.2 issues

So, the subject (which I don't think will change on the main article) is now better suited as Desktop Manager 4.2 issues... This has nothing to do with the Switch Device Wizard.

I've done multiple uninstalls/reinstalls of the DM software, the latest being a reboot --> uninstall --> reboot --> reinstall --> reboot, with the same result.

I've tried it with my 7100 plugged in, with my 8100 plugged in, and with no device plugged in. I'm getting Visual C++ runtime errors every time.
__________________
Jordan
http://www.uselessandillinformed.com
Offline  
Old 09-13-2006, 02:05 PM   #8 (permalink)
jsf
Thumbs Must Hurt
 
Join Date: Jul 2005
Location: New York, NY
Model: 8820
Carrier: AT&T
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The latest here is that my co-worker went out & bought an 8100 today also, and he's having the exact same C++ runtime issue that I am.

I'm thinking more and more that the issue is with the build on our laptops.
__________________
Jordan
http://www.uselessandillinformed.com
Offline  
Old 09-13-2006, 08:02 PM   #9 (permalink)
CrackBerry Addict
 
Join Date: May 2005
Location: Golden, CO US
Model: 9700
Carrier: ATT
Posts: 684
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This happened to me when I installed 4.2 without uninstalling 4.1 first. When you uninstall, make sure that "c:\program files\research in motion\blackberry" and c:\program files\common files\research in motion" are actually deleted. Note that the common files directory contains any updated firmware you might have. Also delete any shortcuts you might have copied to other folders.
Offline  
Old 09-13-2006, 08:15 PM   #10 (permalink)
jsf
Thumbs Must Hurt
 
Join Date: Jul 2005
Location: New York, NY
Model: 8820
Carrier: AT&T
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by RemyJ
This happened to me when I installed 4.2 without uninstalling 4.1 first. When you uninstall, make sure that "c:\program files\research in motion\blackberry" and c:\program files\common files\research in motion" are actually deleted. Note that the common files directory contains any updated firmware you might have. Also delete any shortcuts you might have copied to other folders.
Good thoughts, and at this point we've tried them all. In fact, I spent a few hours today being kicked around escalations through 3 different levels of TMo tech support, and then they sent me up to RIM themselves.

At this point, RIM is asking their engineers to attempt to replicate the issue, but everything right now points to it possibly be an incompatibility between Desktop Manager 4.2 and the BES version we're running (2.2.4.6). The RIM tech couldn't say for sure, but we're talking as-new-as-it-gets for DM and pretty old for BES. I've scoured the DM documentation though, and nowhere does it list minimum BES versions required. On this path (and hoping to skip ahead of the up to 72 hours RIM said they'd take to get back to me), I posted in the BES forum here to see if anyone knows.

What I know is this: We've tried DM 4.2 on multiple PC's at our office, with 4 different BB handhelds, and scores of uninstalls/reinstalls (including wiping out registry keys), and if we try the BES install it crashes. If we try the BIS install, the app seems to work.
__________________
Jordan
http://www.uselessandillinformed.com
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.