BlackBerry Forums Support Community               

View Poll Results: Do you use these tools?
only BBScreenShooter 45 26.32%
only BBScreenStream 7 4.09%
both BBScreenShooter and BBScreenStream 41 23.98%
have no use for them 63 36.84%
did not work for me 15 8.77%
Voters: 171. You may not vote on this poll

Closed Thread
 
LinkBack Thread Tools
Old 07-04-2008, 07:36 AM   #101 (permalink)
Thumbs Must Hurt
 
oppitronic's Avatar
 
Join Date: Aug 2006
Location: Frankfurt, Germany
Model: 9000
Carrier: T-Mobile Germany
Posts: 84
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please Login to Remove!

Wirelessly posted

Are you on a bes?
There are default it policies that disable the screenshot feature.
Your admin needs to enable that in order for javaloader to retrieve a screenshot.
Offline  
Old 07-04-2008, 08:15 AM   #102 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8800
PIN: N/A
Carrier: FT
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I am on a BES. I changed the value for Security Policy Group > Allow screen shot capture to True (normally it should be the default value!!!), resent the IT Policy and then ran javaloader again and it is working fine now for the 8820.
Many thanks!!!
Delphine
Offline  
Old 07-09-2008, 07:02 AM   #103 (permalink)
Thumbs Must Hurt
 
lamonicaj's Avatar
 
Join Date: Apr 2008
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 116
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

With the assistance of oppitronic , I was able to get both BBScreenShooter & BBScreenStream working. Thank you so much & I will definitely be spreading the word.

Finally an app that works independently of my blackberry!!!
Offline  
Old 08-08-2008, 08:32 AM   #104 (permalink)
Thumbs Must Hurt
 
oppitronic's Avatar
 
Join Date: Aug 2006
Location: Frankfurt, Germany
Model: 9000
Carrier: T-Mobile Germany
Posts: 84
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello again,

it's been some time, but finally I was able to fix a problem in BBScreenStream with javaloader hanging when used with OS 4.5 devices.

You can just update existing versions using the built-in updater.
Or get it from my homepage oppitronic.[net|de]

If you have problems getting the javaloader set up, just drop me a PM.

Michael
Offline  
Old 09-04-2008, 09:52 AM   #105 (permalink)
New Member
 
KenBerry's Avatar
 
Join Date: Apr 2008
Model: 8703e
PIN: N/A
Carrier: Sprint
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by oppitronic View Post
Hi,

does anyone already have a 8830 and has tested bbscreenshooter against it?
Or just the "javaloader.exe -u screenshot" command?
It was reported to me that it does not work.
Anyone with the same or different experience?

Michael
This is a little out of date to reply to, but I have an 8830 an I keep getting the following error:

It seems there is no BlackBerry connected to the USB port or the Desktop Manager is not installed.

Connect a BlackBerry and try again or cancel.


It actually happens for both 8830s and 8703es.

All os above 4.1; xp machine; unlocked handhelds; Sync just fine via the Desktop Manager. I have used the javaloader to wipe and reinstall the OC on a number of BBs. Increased the connecttimeout to 255.

The best I can come up with is to try different javaloaders; I just found my original installer (JavaLoader_Installer_31.7.0.73.exe), I'm going to guess that ain't the right one.

VERY annoying, this sounds like a great utility. Right now all I want is a capture of the pesky activation Briefcase - but more comes easily to mind.

Anybody else run into this?

Last edited by KenBerry : 09-04-2008 at 09:58 AM.
Offline  
Old 09-04-2008, 10:00 AM   #106 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,681
Post Thanks: 4
Thanked 96 Times in 71 Posts
Default

Did you try using JL_Cmder for screenshots?
Offline  
Old 10-09-2008, 08:32 AM   #107 (permalink)
New Member
 
Join Date: Jul 2007
Model: 8800
PIN: N/A
Carrier: Cingular
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I use Rove Mobile Viewer
Offline  
Old 10-09-2008, 01:32 PM   #108 (permalink)
Thumbs Must Hurt
 
oppitronic's Avatar
 
Join Date: Aug 2006
Location: Frankfurt, Germany
Model: 9000
Carrier: T-Mobile Germany
Posts: 84
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi folks,

I meanwhile got my BOLD and have updated the screenshooter so it works with the latest device without problems.

Here again the download links:
(it seems a few were not able to find them and asked)

oppitronic.[net|de]
oppitronic.[net|de]

To enable the rememberPassword feature edit the .ini file and set
rememberPassword =1
(my tool stores the password somewhat encrypted in the ini file)

For legal reasons I can't distribute the javaloader.exe together with the tool.

Greetings
Michael
Offline  
Old 10-16-2008, 03:32 AM   #109 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2005
Model: 9000
Carrier: O2 UK
Posts: 22
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

BB Screen Shooter v1.6.2b prompts me for my PIN, I enter it & it produces a screengrab which is completely white.

The odd thing is I used it on a pre-release evaluation Bold & it worked fine, but it doesn't work with my production Bold with OS 4.6.0.162.

JL_Commander v1.9.1 & BBScreen v1.1 work fine with my Bold but their UI isn't as quite as friendly as BBScreenShooter.

DMTelf
Offline  
Old 10-16-2008, 06:14 AM   #110 (permalink)
Thumbs Must Hurt
 
oppitronic's Avatar
 
Join Date: Aug 2006
Location: Frankfurt, Germany
Model: 9000
Carrier: T-Mobile Germany
Posts: 84
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a BOLD 4.6.0.126 and it works for me.
Basically all screenshot tools for the BB do exactly the same, they use javaloader to get a screenshot. My ScreenShooter only wraps a GUI around the command line tool. So I can't understand why that happens.
The "white screen" is normal under certain circumstances and should appear even when you use the command line tool itself when:
-you have encryption enabled
-your BB is locked
-when the screen is dark or the BB is holstered
That phenomenon exists since Blackberry introduced transparency and shades in their themes.

Michael
Offline  
Old 10-16-2008, 09:39 AM   #111 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2005
Model: 9000
Carrier: O2 UK
Posts: 22
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by oppitronic View Post
I have a BOLD 4.6.0.126 and it works for me.
Basically all screenshot tools for the BB do exactly the same, they use javaloader to get a screenshot. My ScreenShooter only wraps a GUI around the command line tool. So I can't understand why that happens.
The "white screen" is normal under certain circumstances and should appear even when you use the command line tool itself when:
-you have encryption enabled
-your BB is locked
-when the screen is dark or the BB is holstered
That phenomenon exists since Blackberry introduced transparency and shades in their themes.

Michael
Given what you've said, I don't understand why JL_Commander & BBScreen works, whereas yours doesn't even when they use the same version of javaloader.exe

Offline  
Old 10-16-2008, 09:57 AM   #112 (permalink)
Thumbs Must Hurt
 
oppitronic's Avatar
 
Join Date: Aug 2006
Location: Frankfurt, Germany
Model: 9000
Carrier: T-Mobile Germany
Posts: 84
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

@dmtelf: Me not either, sorry
My BOLD works, my friends BOLDs work.
Something must be different. You seem to have a more recent Firmware, but I can't really work on that problem as long as I can't replicate it.
Offline  
Old 01-19-2009, 10:15 AM   #113 (permalink)
Thumbs Must Hurt
 
oppitronic's Avatar
 
Join Date: Aug 2006
Location: Frankfurt, Germany
Model: 9000
Carrier: T-Mobile Germany
Posts: 84
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Another update, version 1.65a, should work with the STORM as well.
Sorry I just don't find the time anymore to make good progress on these tools.
oppitronic.[net|de]
Offline  
Old 02-13-2009, 10:45 AM   #114 (permalink)
New Member
 
Join Date: Dec 2008
Model: 8300
PIN: N/A
Carrier: Fido
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just want to say thank you for your amazing contribution!
Offline  
Old 02-19-2009, 07:16 PM   #115 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8330
PIN: N/A
Carrier: Verizon
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Password not working

I was trying to get a screen shot from my 8330 and first it said the password was (wrong I had never set one) so I left the field blank. I then added a password just see if it would work and I could not get it to connect. Any thoughts?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

LinkBacks (?)
LinkBack to this Thread: http://www.blackberryforums.com/general-blackberry-discussion/52303-screenshots-blackberry-display.html
Posted By For Type Date
Stinsonddog's Blackberry Tips Links This thread Refback 11-29-2006 07:59 AM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.