BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-11-2006, 01:37 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Twin Cities, MN
Model: 8703
Carrier: Verizon, Nextel, AllTel, UScellular, AT&T
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Angry 7520 Contact menu in address book is slow

Please Login to Remove!

Clicking on a contact takes 10-12 seconds for the menu to appear. I have worked on this issue for about 16 hours, which includes several hours on the phone with Nextel and a trip to the local service center.
Background:
I support about 150 bb's in an enterprise environment. We have a BES running version 4.x which integrates with our exchange 2000 server. Some phones are Verizon and others are Nextel. All phones sync wirelessly with the BES.
Problem:
When I open the address book and click on a contact from a Nextel 7520 phone it takes about 10-12 seconds for the menu to appear. This is occurring on any of the three Nextel 7520 phones that I have activated (via enterprise activation) over the course of the last two weeks.
Action Taken (to no avail):
You name it, I've tried it. These procedures have been performed at least four times on three different 7520 phones while using two different user accounts (meaning two different SIM chips). I have removed the users from the BES waited at least 15 minutes and then added them back in. I have wiped the handhelds, performed a hard reset (take out battery hold down power button for 30 seconds), performed a master radio reset (take out battery again), registered host routing table, performed enterprise activation. Activation completes without error. After activation I hold LG LG and clear the cache. Once complete I have about 460 MS Outlook contacts in the address book and >18M of free memory. Everything works great on the blackberry, but when I open the address book and click on any of the 460 contacts it is taking about 10-12 seconds for the menu to appear. While waiting the blackberry is basically locked up and rendered useless. In addition to all of this, I have reloaded the latest OS on each of the three phones. Once this didn't work I installed the blackberry desktop manager (BBDM) on another PC and tried to load the OS from there...same problem still. I downloaded the latest version of the BBDM and tried loading the OS again. Still 10-12 seconds for the contact menu to appear after clicking on a contact contained in the address book. GrrRrr!
More Background:
Maybe you're thinking it is slow due to the number of contacts. I do not believe this to be the case because we have other 7520's holding >1,400 contacts and it takes about 1sec for the menu to appear. The reason I am activating these new replacement phones is due to the fact that the users' original 7520 phones either fell apart (from field use over the course of a year or two) or stopped working properly. Two of the three phones I have worked with are replacement/refurbished phones from Nextel and the third is a used phone from an ex-employee. On Monday I should have a brand new phone that I ordered to test with.
What I'm considering:
I'm thinking about calling Nextel to move one of the two accounts over to a new SIM and then go through my routine again. Other than trying that I have no more ideas. Since the users have had a blackberry in the past they find 10-12 seconds for the contact menu to appear completely unacceptable. Hopefully I am on the right track here. Any help or ideas would be very much appreciated!

Last edited by Known1 : 11-12-2006 at 09:34 PM.
Offline  
Old 11-13-2006, 09:25 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Twin Cities, MN
Model: 8703
Carrier: Verizon, Nextel, AllTel, UScellular, AT&T
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb

Update:
Today the new 7520 arrived. I took the SIM that I have been using and placed it in the new phone. I set the data/time and performed a master radio reset and removed the battery then reinserted. I then registered the host routing table and performed enterprise activation. Guess what, when I clicked on a contact in the address book it still took 10-12 seconds for the menu to appear. I then turned off the radio antenna and clicked on a contact to no avail...still 10-12 seconds. I then removed every single thing I could from the service book and voila! it took less than 1 second to get the contact menu to appear. Tomorrow I plan to try and figure out exactly which of the service book entires is causing this problem. Apparently the latest OS for the 7520 is the problem (or at least one of the service books that Nextel is pushing out). I'll continue to keep everyone up to date on this issue.
Offline  
Old 11-14-2006, 11:14 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Twin Cities, MN
Model: 8703
Carrier: Verizon, Nextel, AllTel, UScellular, AT&T
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Smile

Update:
AT LAST A FIX! Today I was able to determine exactly which service book causes this issue in OS 4.1.0.241 (latest greatest). I called Nextel and spoke with their level 2 support and was told that this bug had yet to be reported. Ryan is the REP I spoke with and he stated that he is going to report this right away. Essentially by removing this service book (which is supposed to be on the phone according to Ryan) the only thing I will miss out on is the ability to send text msgs. I can still use PIN and bb messenger, but can't send "traditional" text messages. (Which for any bb user is no biggie.) When I asked if I would be able to receive any "traditional" text messages he stated that he is not sure and would hate to give me a wrong answer. For us, being without "traditional" text messaging is not going to cause any problems. I will post the exact name of the service book tomorrow along with details on how to remove this POS service book.
ps: Thanks Nextel for pushing crap to our phones any time we register host routing table.
Offline  
Old 11-15-2006, 08:12 AM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Twin Cities, MN
Model: 8703
Carrier: Verizon, Nextel, AllTel, UScellular, AT&T
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The Final Solution:
I hope my several hours of work on this issue will save other people some major headaches. Provided you are running OS 4.1.0.241 you will have a service book named "Nextel MMS Transport [WPTCP]", get rid of it and this problem is solved. To remove the service book go to Options, Advanced Options, Service Book. Once in the service book section, simply highlight the service book mentioned above and click delete. If you want to get this service book back all you need to do is perform a register now function in the Host Routing Table option within Advanced Options.
Offline  
Old 11-15-2006, 01:51 PM   #5 (permalink)
Thumbs Must Hurt
 
dlautman's Avatar
 
Join Date: Sep 2005
Location: USA
Model: 9000
OS: 5.0.0.509
Carrier: AT&T
Posts: 93
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default

nice!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.