BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-23-2007, 04:02 PM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Jul 2006
Location: East Providence, RI
Model: 8830
Carrier: Sprint
Posts: 51
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Possible solution for missing "Keep Appointments" setting...

Please Login to Remove!

First, here is the story:

(and forgive the length, but I need to start from the beginning...)

I have a user that has an 8800, and she uses Desktop Manager to sync a Public Calendar only, everything else is wireless. Ever since she got the 8800, it has been asking to delete items older than 60 days everytime she connects it to her system. After over 6 hours on the phone with Blackberry support, wiping the unit, reactivating the unit, and even reinstalling the Blackberry OS software on the unit (almost 1 hour there...), this mysterious "Keep Appointments" setting was nowhere to be found. We also have a BES that I had used a policy to turn off Wireless Calendar Sync.

So, again I was called to the client to try to figure this out. I again wiped the unit, and held off on the Enterprise Activation, because maybe the BES was to blame, even though the Blackberry techs said no... and it still wasn't there... I even created a blank IT Policy to see if Wireless Calendar sync was to blame... so as I was getting my butt enlarged by my client I thought of something... I finally saw that I had an option for Wireless Sync in the Calendar settings... and I decided to turn it on (being that we NEVER sync the calendars wireless, what did I have to lose...)... and to my amazement...

THE "KEEP APPOINTMENTS" SETTING APPEARED!!!!!!!

I checked the default setting, and yes, it was set to "60 days". I changed it to "Forever" and confirmed the change. Just to check if the setting stuck, I disabled Wireless sync on the unit, waited a minute, and the "Keep Appointments" was gone, which I figured... so I waited, then re-enabled Wireless sync, and the "Keep Appointments" was back... I checked it, and it was still set to "Forever", so it didn't change.

I then changed the date on the unit five days ahead, because that would usually trigger the Desktop Manager to delete the items... and I did it 8 times, wating 1 to 10 minutes between each, and it worked EVERY TIME!!!!!

Now, my client hasn't called me to tell me that it is not working again, but she might be away, and to be honest... I am AFRAID to call!!! I have been dealing with this for over 2 weeks, and even losing sleep over it because it was driving me CRAZY!!!!!!!!!

So.... if possible, for all of you that are having problems, try enabling wireless calendar sync and see if it appears. I am hoping that this works for SOMEBODY since Blackberry tech couldn't figure it out, and I am still waiting for a call back from Blackberry tech support because they had to escalate my case up a few levels, and this was Monday... they said they would call back within 24 hours... yea, right!!!!

So please let me know if this helps anyone, I am SOOOOO curious if this is the magic fix to this issue....

Thanks all!!!!


Ken Jancef
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.