BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-22-2007, 01:26 PM   #1 (permalink)
New Member
 
Join Date: Jun 2007
Model: Pearl
PIN: N/A
Carrier: AT&T
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy i have a problem..please help!

Please Login to Remove!

I just bought a Pearl from AT&T..I have activated the new sim card it came with and have charged the battery (the light is green)..the screen becomes bright but there is no display..i'm not even sure if the phone is on or not. is there something wrong with the phone? or is there something i'm not doing correctly? Please help!!
Offline  
Old 06-22-2007, 01:29 PM   #2 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,703
Post Thanks: 4
Thanked 112 Times in 79 Posts
Default

It should turn on. I would take it back.
Offline  
Old 06-22-2007, 01:31 PM   #3 (permalink)
CrackBerry Addict
 
Join Date: Jun 2007
Location: New Jersey
Model: 8330
PIN: 35AABF91
Carrier: Verizon
Posts: 834
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jmkriege View Post
I just bought a Pearl from AT&T..I have activated the new sim card it came with and have charged the battery (the light is green)..the screen becomes bright but there is no display..i'm not even sure if the phone is on or not. is there something wrong with the phone? or is there something i'm not doing correctly? Please help!!
take the phone back immediately
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.