BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-27-2007, 04:19 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Model: 8300
Carrier: AT&T
Posts: 42
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Sudden instant IMAP delivery...

Please Login to Remove!

As of the last day or so, I've been getting my IMAP mailbox messages through Cingular/ATT BIS instantly without the usual delay associated with the fifteen minute polling of POP and IMAP accounts. Was there a software upgrade done or is there a particular reason this might be happening (not that it's a negative, I'm delighted it's happening).

My email provider is Fusemail and it's an IMAP4 system, AT&T BlackBerry service.

Thanks.
Offline  
Old 07-27-2007, 05:49 AM   #2 (permalink)
BlackBerry B Boy
 
jeremyckitching's Avatar
 
Join Date: Apr 2007
Model: 9700
OS: 5.0.0.415
PIN: 215BE1F8
Carrier: T-Mobile U.S.A.
Posts: 4,243
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

There was another thread where someone on Verizon's network was saying the same thing. I wonder if there was some sort of update.
Offline  
Old 07-27-2007, 06:31 AM   #3 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Not working for me. Setup a new IMAP account on our servers and its still delayed by up to 15 mins.
Offline  
Old 07-27-2007, 06:35 AM   #4 (permalink)
No longer Registered.
 
Dawg's Avatar
 
Join Date: Mar 2005
Location: Atlanta
Model: 8330
OS: 4.5.0.138
PIN: 31a6c9c9
Carrier: Verizon BIS
Posts: 13,962
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jeremyckitching View Post
There was another thread where someone on Verizon's network was saying the same thing. I wonder if there was some sort of update.
actually there are two other threads
Offline  
Old 07-27-2007, 06:51 AM   #5 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Dawg View Post
actually there are two other threads
Really? Can you post the links.
Offline  
Old 07-27-2007, 06:59 AM   #6 (permalink)
No longer Registered.
 
Dawg's Avatar
 
Join Date: Mar 2005
Location: Atlanta
Model: 8330
OS: 4.5.0.138
PIN: 31a6c9c9
Carrier: Verizon BIS
Posts: 13,962
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by whsbuss View Post
Really? Can you post the links.




BIS Problems??

http://www.blackberryforums.com/gene...tml#post614521

Last edited by Dawg : 07-27-2007 at 07:01 AM.
Offline  
Old 07-27-2007, 07:49 AM   #7 (permalink)
CrackBerry Addict
 
wibbly's Avatar
 
Join Date: Apr 2005
Location: UK
Model: 9700
Carrier: T-Mobile UK
Posts: 857
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does the new IMAP support extend to the visibility on the BB of any IMAP folders except Inbox folder?
Offline  
Old 07-27-2007, 01:04 PM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Model: 8300
Carrier: AT&T
Posts: 42
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think perhaps I wasn't being descriptive enough; my emails are coming through fine. They are actually coming through instantly as if it was a true BES account or coming to my @blackberry.net address.

The threads linked to were about not receiving email.
Offline  
Old 07-27-2007, 01:15 PM   #9 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Imap & Bis

I spoke w/RIM today about IMAP support. They said they are working on getting the IMAP-IDLE command implemented so it will deliver in almost-realtime servers who support this in their IMAP server. They turned this on over the weekend but some issues remain.

However, there is some problems with allowing concurrent connections. Not sure why as my server allows for 100 connections to port 143 (IMAP). Still working on this w/RIM. Using Outlook for an IMAP account seems to work just fine.... new emails show up in 1-2 minutes.

Remember that BIS 2.3 does not allow for changing POP/IMAP configurations. When you setup an email account the BIS tries IMAP protocol before POP. If IMAP connects that is what it will use. AND the important thing is if IMAP-IDLE is not working you will have up to 60 minute delays (until IMAP-IDLE times out).

Its not pretty right now. I suggest forwarding critical email accounts to your BB address as well as the configured BIS.
Offline  
Old 07-27-2007, 01:16 PM   #10 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by C. Gomez View Post
I think perhaps I wasn't being descriptive enough; my emails are coming through fine. They are actually coming through instantly as if it was a true BES account or coming to my @blackberry.net address.

The threads linked to were about not receiving email.
Seems your emai/IMAP server is working correctly. That's good for you.
Offline  
Old 07-27-2007, 01:21 PM   #11 (permalink)
CrackBerry Addict
 
ladydi's Avatar
 
Join Date: Jun 2005
Location: Washington
Model: 8800
Carrier: T-mobile
Posts: 848
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Still up to 15 mins for me on t-mobile
__________________
~Di~
Windows 2003
Exchange 2003
BES 4.1
Offline  
Old 07-27-2007, 01:40 PM   #12 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 8800
PIN: N/A
Carrier: T-Mobile
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Mine has always been instant

I have only had a Blackberry for a week now, but mail delivery from IMAP has always been instant. I have BIS and my mail host is everyone.net. They do have IMAP-IDLE so maybe that's why. I was not expecting instant delivery so I've been very surprised.
Offline  
Old 07-27-2007, 01:58 PM   #13 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jcatan View Post
I have only had a Blackberry for a week now, but mail delivery from IMAP has always been instant. I have BIS and my mail host is everyone.net. They do have IMAP-IDLE so maybe that's why. I was not expecting instant delivery so I've been very surprised.
Interesting. Wonder what IMAP software they use. We're using UW-IMAP and its not working well even with IMAP-IDLE working.
Offline  
Old 07-27-2007, 02:21 PM   #14 (permalink)
Thumbs Must Hurt
 
Join Date: May 2007
Model: 9630
PIN: N/A
Carrier: SPCS
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm on Sprint and too noticed the difference over the last day or so. I'm now getting my IMAP account emails instantly pushed to the BB. Very nice feature!
Offline  
Old 07-27-2007, 04:10 PM   #15 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

For those who are getting instant IMAP delivery, please list your email provider. Looking to see what IMAP server program they are using.

Thanks.
Offline  
Old 07-27-2007, 04:40 PM   #16 (permalink)
Thumbs Must Hurt
 
Join Date: May 2007
Model: 9630
PIN: N/A
Carrier: SPCS
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm using my .edu
Offline  
Old 07-27-2007, 05:02 PM   #17 (permalink)
Talking BlackBerry Encyclopedia
 
tobyw's Avatar
 
Join Date: Feb 2007
Location: UK
Model: 8100
Carrier: T-Mobile UK
Posts: 278
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This sounds like a nice feature Brings back memories of Chatter on my Treo which also used IDLE to approximate push-email.

Thinking of switching to IMAP from OWA because of this when it is fully up and running. However, can anyone confirm what I seem to recall - IMAP doesn't offer the 2-way reconcilation of deleted messages that the recent BIS 2.3 brought in?
Offline  
Old 07-27-2007, 05:12 PM   #18 (permalink)
BlackBerry Extraordinaire
 
whsbuss's Avatar
 
Join Date: Feb 2005
Location: SE PA.
Model: 9800
OS: 4.6.0.304
Carrier: AT&T
Posts: 2,791
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Ross0 View Post
I'm using my .edu
I meant something like fusemail
Offline  
Old 07-27-2007, 10:56 PM   #19 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Model: 8300
Carrier: AT&T
Posts: 42
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It's still as of this evening pushing IMAP email immediately. Fusemail does support IDLE so I suppose the change someone noted earlier in the thread might be the cause.

They're rather inexpensive for extremely reliable IMAP email provider ($1 a month per mailbox with a gigabyte of storage).

My school email (ucsb.edu) which is almost IMAP has the old five to fifteen minute delay, so I'm assuming it's something in the software RIM BIS uses and that Fusemail or other providers have enabled.

Last edited by C. Gomez : 07-27-2007 at 10:57 PM.
Offline  
Old 07-27-2007, 11:03 PM   #20 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Model: 8300
Carrier: AT&T
Posts: 42
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by tobyw View Post
Thinking of switching to IMAP from OWA because of this when it is fully up and running. However, can anyone confirm what I seem to recall - IMAP doesn't offer the 2-way reconcilation of deleted messages that the recent BIS 2.3 brought in?
On both of my IMAP accounts that I use, there is full unread/read and delete synchronization between my BlackBerry and the IMAP server (and as a result, desktop computer) using AT&T's BIS service. I've been using BlackBerry BIS for the last year and a half of so and reconciliation of message properties has never been an issue.

Last edited by C. Gomez : 07-27-2007 at 11:04 PM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.