BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-27-2007, 01:15 AM   #1 (permalink)
New Member
 
Join Date: Dec 2007
Model: 7290
PIN: N/A
Carrier: AT&T
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 7290 Stopped working and battery now has "red line"

Please Login to Remove!

So I got a refurbed 7290 off ebay back in june and it worked great until about a month ago when I got a 404 error code, which went away when I got a new sim card. But RIGHT after I fixed that the battery RAPIDLY drained, like in 5 min. And it will no longer take a charge. I noticed that the battery has a red line through it and from what I can gather that has something to do with compatibility. So I just ordered a new Li-Ion from amazon.

Also even if it's plugged in it says the battery is drained and turns it off. SOMETIMES it will start with the wireless off, but then when I turn it on it somehow loses all battery power and does the same thing.

SO I'm going to see if it's the battery thats the problem, but if it continues what would be the most likely cause?

Thanks
Offline  
Old 12-31-2007, 01:17 PM   #2 (permalink)
New Member
 
Join Date: Dec 2007
Model: 7290
PIN: N/A
Carrier: AT&T
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

59 views and not one response?
Offline  
Old 12-31-2007, 03:50 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Dec 2007
Model: 8320
PIN: N/A
Carrier: T-mobile
Posts: 20
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try powering it off, remove the battery, push the power button. Reinsert the battery, do not power the phone up until the battery has charged for at least a couple of hours. It may be possible that the battery needs to be replaced. It may be possible that something has happened to the charger. Does the charger show the charge indication on the the battery? Have you left it plugged in for long periods of time? Say more than 12 hours? I'm no BlackBerry expert, but I did read where the owners manual for a Moto cell phone recommended unplugging the phone after it was fully charged.

Don
Offline  
Old 01-14-2008, 08:47 AM   #4 (permalink)
New Member
 
Join Date: May 2007
Model: 7290
PIN: N/A
Carrier: T-Mobile
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by dmcgrady View Post
Try powering it off, remove the battery, push the power button. Reinsert the battery, do not power the phone up until the battery has charged for at least a couple of hours. It may be possible that the battery needs to be replaced. It may be possible that something has happened to the charger. Does the charger show the charge indication on the the battery? Have you left it plugged in for long periods of time? Say more than 12 hours? I'm no BlackBerry expert, but I did read where the owners manual for a Moto cell phone recommended unplugging the phone after it was fully charged.

Don
All your comments lead to think the new battery should take care of this right? My 7290 is 2+ years old now and battery is not lasting more than 3 days; I was thinking on getting a new battery or just holding few more months more to get a new phone. Anyhow, I would like to watch how this thread goes and if the new battery solved the problem.
Offline  
Old 01-14-2008, 01:12 PM   #5 (permalink)
BBF Moderator
 
acnst's Avatar
 
Join Date: Aug 2004
Location: Germany
Model: 9700
PIN: not configured
Carrier: T-Mobile
Posts: 1,527
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Nor Cal Nomad View Post
Also even if it's plugged in it says the battery is drained and turns it off. SOMETIMES it will start with the wireless off, but then when I turn it on it somehow loses all battery power and does the same thing.

For me its sounds like your devices is broken and therefore malfunctioning.
Did the device get wet or did you drop it?
__________________
Deutsches Blackberry Forum - visit www.blackberry-forum.de


for Microsoft Exchange

Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.