BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-28-2007, 09:05 PM   #1 (permalink)
New Member
 
Join Date: Dec 2007
Model: 7290
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default T-Mobile 7290 says "No Service" even though it has t-mobile sim card in it

Please Login to Remove!

I bought a t-mobile 7290 off ebay and it's saying "No Service" after it tries to search for a network. I tried changing out the IT Policy but that didn't work. Do you guys think it's an IT Policy issue or something else?

Thanks
Offline  
Old 12-28-2007, 09:16 PM   #2 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

Are you sure the SIM card is good? Does it work in any other phone?

Are you sure the 7290 is good? Does it work with any other SIM card?
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org
Offline  
Old 12-28-2007, 09:19 PM   #3 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

"No Service" means it's not picking up any signal at all from any carrier. if you've tried Penguin's suggestions above and the sim card works in another device then I'd say the 7290 is bad.
Offline  
Old 12-28-2007, 09:19 PM   #4 (permalink)
New Member
 
Join Date: Dec 2007
Model: 7290
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The sim card works fine in another phone.

I couldn't get the phone working with another good sim card either.
Offline  
Old 12-28-2007, 09:20 PM   #5 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

I suspect defective device. Sorry.
Offline  
Old 12-28-2007, 09:22 PM   #6 (permalink)
New Member
 
Join Date: Dec 2007
Model: 7290
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Also I tried doing a scan for available networks. After I do it, it says "* Please do a scan *" under "Available Networks" instead of listing anything.
Offline  
Old 12-28-2007, 09:23 PM   #7 (permalink)
New Member
 
Join Date: Dec 2007
Model: 7290
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the replies guys. Any 2nd or 3rd opinions? Just want to exhaust all the possibilities before I attempt sending it off.
Offline  
Old 12-28-2007, 09:28 PM   #8 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Sending it off for what?
Offline  
Old 12-28-2007, 09:38 PM   #9 (permalink)
New Member
 
Join Date: Dec 2007
Model: 7290
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

For a replacement from the ebay seller. It's a little more polite than just getting my money back from paypal.
Offline  
Old 12-28-2007, 09:42 PM   #10 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

I'm of the opinion that the 7290 is broken.
Good luck returning it to your eBay seller. I hope that works out for you, because it usually doesn't.
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org
Offline  
Old 12-28-2007, 09:42 PM   #11 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Ah, yes. Good plan. I thought maybe you were going to send it in for repair. I was going to advise that it's likely not worth it to try and have it repaired. It sounds like there is a radio/antenna issue with it. It's also possible that the 1900 Mhz frequency band is bad but that the 850 Mhz band would work making it appear that the device is good to someone else using another carrier. I had this issue on a Pearl. Just one of the frequencies was bad in the radio.

Good luck!
Offline  
Old 12-28-2007, 09:49 PM   #12 (permalink)
New Member
 
Join Date: Dec 2007
Model: 7290
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

>>Penguin
It seems like the seller had a whole lot of these. Maybe he had a bunch of broken ones. Hopefully that's not the case.

>>John
I wasn't even aware the 800mhz is still around. If t-mobile has it, it certainly isn't working either.
Offline  
Old 12-28-2007, 09:51 PM   #13 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: iPh6
Carrier: AT&T
Posts: 27,821
Post Thanks: 33
Thanked 442 Times in 382 Posts
Default

850MHz. Not 800. It is the "new" North American GSM frequency that the 7290 and all quad band GSM phones use.

Sounds like a broken radio to me.
Offline  
Old 12-28-2007, 09:54 PM   #14 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

The 7290 and all GSM devices after that were Quad band. Meaning they work on 850/1900 (USA) and 900/1800 Mhz (Europe.) I'm just saying it's possible that the 1900 radio is out but if you found another carrier that was on the 850 band it's possible that it works. TMobile uses 1900 and AT&T uses 850 and 1900. It could be that the whole thing is out. I just thought I'd throw this out there as a possibility when(if) the seller checked it.
Offline  
Old 12-28-2007, 10:10 PM   #15 (permalink)
New Member
 
Join Date: Dec 2007
Model: 7290
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Good stuff, I'll take that into consideration.
Offline  
Old 12-28-2007, 10:11 PM   #16 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

I think with Verizon you can. I'm not a Verizon or an MMS user so I'm not much help. Do a search of the forum for Verizon MMS and see what you can find.
Offline  
Old 01-15-2008, 01:35 AM   #17 (permalink)
Knows Where the Search Button Is
 
Join Date: Jan 2008
Model: 7230
PIN: N/A
Carrier: hutch india
Posts: 40
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down wipe ur hanheld

Quote:
Originally Posted by John Clark View Post
I think with Verizon you can. I'm not a Verizon or an MMS user so I'm not much help. Do a search of the forum for Verizon MMS and see what you can find.

go to option-security-click wheel-click on wipe.. it may work..or you can meet your service provider(t-mobile)..
sam
Offline  
Old 01-15-2008, 01:40 AM   #18 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Uh, yeah, but be sure you backup the device first! A wipe will wipe all your data.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.