BlackBerry Forums Support Community
              

Closed Thread
 
LinkBack Thread Tools
Old 01-03-2008, 05:08 PM   #1 (permalink)
New Member
 
Join Date: Jan 2008
Model: 8800
PIN: N/A
Carrier: Rogers
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default buttons input incorrect characters

Please Login to Remove!

Summary: track ball click, escape button, and the 0 button ceased to function properly, and when pressed they would enter text such as "Yi" or "hl" or similar odd text strings.

At the onset of the issue the device froze. All buttons failed to work and the device went dark. Even the power button would not work. Removing and replacing the battery would bring the device back to normal for a few minutes, and then it would degrade to unusable again.

After a period of hours during which the battery was removed and re-inserted a series of times, the device returned to normal except for the functionality of 3 buttons: the track ball click, the escape button, and 0 button.

For each of these 3 buttons - they did not function properly and when pressed they would enter text such as "Yi" or "hl" or similar text strings.
In attempts to correct this problem I repeatedly "wiped" the device clean, and also reinstalled the OS / platform. This would not resolve the issue.

The device has not suffered water damage.

The kicker: when i synced the device on my office computer the problem would be resolved - i.e. the 3 buttons would function normally. After a period of time (days) the buttons would fail again. Syncing the device on other machines did not result the the problem being resolved - only my office machine sync would resolve the issue. I realize the observations described above seem unlikey, but they did happen. - Any insights?
i observed this syncing "fix" at least 2 times: once before I left my office for the holidays, and also upon my return.
Offline  
Old 01-03-2008, 06:04 PM   #2 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: Z30
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,921
Post Thanks: 61
Thanked 258 Times in 185 Posts
Default

First, welcome to the Forums.

At first sight, I would say your issue IS water damage, as all your symptoms do seem to point to that, and I do note that you say it is not water damage.

Otherwise I really don't have a definite answer for you. Some guesses, or rather what I might first try--disassemble the BB, and make sure the keyboard is aligned correctly with the sensors underneath. I know that could be complicated.

I don't understand why syncing with your computer corrects it (even temporarily). Pulling the battery while powered on is often the best solution.

You may have a high level glitch here.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Reconditioned Windsor Commodore 20 Carpet Extractor
$3025.0
Reconditioned Windsor Commodore 20 Carpet Extractor picture4x CM8164P Dynamic RAM DRAM 64k x1 IC 4164 Memory Apple II Commodore 64 128 Oric
$4.99
4x CM8164P Dynamic RAM DRAM 64k x1 IC 4164 Memory Apple II Commodore 64 128 Oric pictureVintage CBM COMMODORE Scientific Notation Pocket LED Calculator & Manual 1970's
$13.16
Vintage CBM COMMODORE Scientific Notation Pocket LED Calculator & Manual  1970's pictureRiver City 600jl Commodore Pvc/non-wovenpoly/nylon Jacket Yellow
$79.7
River City 600jl Commodore Pvc/non-wovenpoly/nylon Jacket Yellow pictureMCR Safety 600CL 49-Inch Commodore PVC/Non-Woven Polyester/Nylon Rain Coat with
$48.56
MCR Safety 600CL 49-Inch Commodore PVC/Non-Woven Polyester/Nylon Rain Coat with picture






Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.