BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-20-2008, 12:17 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2007
Model: 8900
PIN: N/A
Carrier: telecom italia
Posts: 19
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Sim card error?

Please Login to Remove!

Hello all, I have the BB 8700g with the latest firmware 4.2.1.

I have been using my BB for about 1 year and I am happy overall.

However I have a glitch/issue that is VERY annoying!

Every while, for no apparent reasons, I see on the top of the screen: off network, Sim card error. Than I have to manually take it out, putting the SIM back to the mobile and usually after 2, 3 attempts it will work as normal for the next few days. Than again: error message...

I got this since I got the BB.

I was wondering if this considered acceptable or getting a new SIM will for sure (???!!!) fix the problem.

Thanks in advance!
Puffo
Offline  
Old 03-20-2008, 02:25 PM   #2 (permalink)
BlackBerry B Boy
 
jeremyckitching's Avatar
 
Join Date: Apr 2007
Model: 9700
OS: 5.0.0.415
PIN: 215BE1F8
Carrier: T-Mobile U.S.A.
Posts: 4,243
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (BlackBerry 8100: Opera/9.50 (J2ME/MIDP; Opera Mini/4.0.10406/286; U; en))

I would try a new SIM card to start.
Offline  
Old 03-20-2008, 03:16 PM   #3 (permalink)
CrackBerry Addict
 
Join Date: Oct 2005
Location: LAX, NYC, CHI, STL, BOS, PHL
Model: 9780
PIN: Another name for the flagstick, term more commonly used by amateurs
Carrier: TMO, ATT, Nextel, Sprint
Posts: 863
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by puffo25 View Post
Hello all, I have the BB 8700g with the latest firmware 4.2.1.

I have been using my BB for about 1 year and I am happy overall.

However I have a glitch/issue that is VERY annoying!

Every while, for no apparent reasons, I see on the top of the screen: off network, Sim card error. Than I have to manually take it out, putting the SIM back to the mobile and usually after 2, 3 attempts it will work as normal for the next few days. Than again: error message...

I got this since I got the BB.

I was wondering if this considered acceptable or getting a new SIM will for sure (???!!!) fix the problem.

Thanks in advance!
Puffo

pls clarify the following:
- did SIM came with the BB or was it active from another device before using on BB?

- have you tried just pulling battery out and not taking SIM card out of slot to see if it would work as normal (without touching SIM card)?

- Do you still have warranty?
Offline  
Old 03-20-2008, 03:41 PM   #4 (permalink)
No longer Registered.
 
greggebhardt's Avatar
 
Join Date: Jan 2005
Location: Jacksonville, FLorida
Model: 9000!
PIN: NOT!
Carrier: AT&T
Posts: 3,762
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

SIM cards do go bad. I have had to have one replaced and afterwards all worked perfectly. I was getting SIM card error 4-5 times a week!
Offline  
Old 03-29-2008, 11:44 PM   #5 (permalink)
New Member
 
Join Date: Mar 2008
Model: 7290
PIN: N/A
Carrier: orange
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

Quote:
Originally Posted by greggebhardt View Post
SIM cards do go bad. I have had to have one replaced and afterwards all worked perfectly. I was getting SIM card error 4-5 times a week!
butxxx65292;why the same sim card can work perfectly in my nokia QD,if the card has problem.
Offline  
Old 04-01-2008, 02:31 AM   #6 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8700G
PIN: N/A
Carrier: China Mobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

8700G always has such problem
Clean your Simcard may solve the problem
Offline  
Old 04-01-2008, 10:00 PM   #7 (permalink)
Thumbs Must Hurt
 
Join Date: Dec 2006
Location: Texas
Model: 8700c
PIN: Nope
Carrier: Cingular (8700c?)
Posts: 67
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

About the only time I get a sims card error is when I drop it or severely abuse it (there are hunks out of the case). Have you dropped it or do you otherwise give it severe licks somehow?

Usually a battery pull solves the issue. Nothing else will.

MikeyMike
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.